summaryrefslogtreecommitdiff
path: root/sci-biology/cutg
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-biology/cutg
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-biology/cutg')
-rw-r--r--sci-biology/cutg/Manifest5
-rw-r--r--sci-biology/cutg/cutg-160-r1.ebuild49
-rw-r--r--sci-biology/cutg/metadata.xml15
3 files changed, 69 insertions, 0 deletions
diff --git a/sci-biology/cutg/Manifest b/sci-biology/cutg/Manifest
new file mode 100644
index 000000000000..fd6ef56d4789
--- /dev/null
+++ b/sci-biology/cutg/Manifest
@@ -0,0 +1,5 @@
+DIST cutg-160.tar.xz 178015420 SHA256 faa2e5e4417e5cadd67bfff0c011f2f3e2e0c5d8b324fc441f9346808f6ed1fa SHA512 9b72283f311fb805b7b22f59f3ca8fed2ab0af72b82247900922999792c1b112dcaca9b29b265a1e0e7b9eaf9ff846a1dc4c196fb95ddbfb3ee5175755ffb8e7 WHIRLPOOL 540f9ba9f2f69718688531c85729c567cd6ba260f12d23b5f3c00d9689da93aefab588fe3dd926defacf4a21982406055ebee413e39ce53a2916e5e571037e93
+EBUILD cutg-160-r1.ebuild 1250 SHA256 59e602274fd15e923603bb7c4f0c8f1a09048b136773adffcd03c71d129958eb SHA512 4b7e71b255def1ece36d75ac85aa39e82b9e224317631801731fa0621e4841b00f6aa830e1fc43bb7e74fb387a2663c3848d9e0a5f99f550778448ab571ccacf WHIRLPOOL f3bded2d09f31650ff2c92b38a1dd91030c094ee29251d154d136d831413e88dd0a036b4b8f87fe2dbe9061cd584a310de0d80169327b4dcab51f05d919e6deb
+MISC ChangeLog 2445 SHA256 d883f2b9bd991a0972e5739d3b89bb6dc47deeb4a3564c5fadae3c6a6054b732 SHA512 6dcbd245ade5394b4060b89833986d887e53d4d2fee8ac4f8f1dd705d900385922604a54ce45b4eabfe1997a2ac2b22a6cf08f52151f1b384372d13e2429ca35 WHIRLPOOL ae0770ac8aba3b6ca2701f2dbdc6593dd12b590d6dc6913455d1b6262d1545dafa9a8065b9cb534385fba353701ae258cbbb64d144094ef9a80df1d436562337
+MISC ChangeLog-2015 7744 SHA256 8723977349cf96250cecdefadb05bbe8270822b5baffbc477ca5a476792ce8fd SHA512 b365d6eb0563c1cdcd118e9efb1a1d12cec87fb6404f7161c9f43ecddc01523ec8dcfe0903887aca928893a32d5daa9987c15362892588b39dff4e14dff03673 WHIRLPOOL 178caf9920cb8f7b99c026196301bdaed6a42ffee61fec64d265b3aa752942adaa4d67877f62b7792ac63877aa9192cc892b27410311b1a221775c3cf397f75c
+MISC metadata.xml 608 SHA256 215bb030a1c392e7e84bd43d2df7e8e2452223df44165544fbb88e97cecf8d76 SHA512 cf8142c4e77b18076f1916311ef85d9fac5d85c2b2139923c0bfb2ec5c8cae9d40d5f09c17128c531c850d726ba30f94b20c92415cb75f05e8f1d829f751d6eb WHIRLPOOL 3116cf5de61304c4a3034385a0cb3f20770026f400fa79dff9ed4a4030633fb876af51963dcddf4f9133070fdea9d2657fe355490664396cf0429baa0badc3b8
diff --git a/sci-biology/cutg/cutg-160-r1.ebuild b/sci-biology/cutg/cutg-160-r1.ebuild
new file mode 100644
index 000000000000..9a8130969019
--- /dev/null
+++ b/sci-biology/cutg/cutg-160-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+DESCRIPTION="Codon usage tables calculated from GenBank"
+HOMEPAGE="http://www.kazusa.or.jp/codon/"
+SRC_URI="https://dev.gentoo.org/~jlec/distfiles/${P}.tar.xz"
+
+SLOT="0"
+LICENSE="public-domain"
+# Minimal build keeps only the indexed files (if applicable) and the
+# documentation. The non-indexed database is not installed.
+IUSE="emboss minimal"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="emboss? ( sci-biology/emboss )"
+RDEPEND="${DEPEND}"
+
+RESTRICT="binchecks strip"
+
+src_compile() {
+ if use emboss; then
+ mkdir CODONS || die
+ ebegin "Indexing CUTG for usage with EMBOSS."
+ EMBOSS_DATA="." cutgextract -auto -directory "${S}" || die \
+ "Indexing CUTG failed."
+ eend
+ fi
+}
+
+src_install() {
+ local file
+ dodoc README CODON_LABEL SPSUM_LABEL
+ if ! use minimal; then
+ dodir /usr/share/${PN}
+ mv *.codon *.spsum "${ED}"/usr/share/${PN} || die \
+ "Installing raw CUTG database failed."
+ fi
+
+ if use emboss; then
+ dodir /usr/share/EMBOSS/data/CODONS
+ cd CODONS || die
+ for file in *; do
+ mv ${file} "${ED}"/usr/share/EMBOSS/data/CODONS/ || die \
+ "Installing the EMBOSS-indexed database failed."
+ done
+ fi
+}
diff --git a/sci-biology/cutg/metadata.xml b/sci-biology/cutg/metadata.xml
new file mode 100644
index 000000000000..d91990ea170f
--- /dev/null
+++ b/sci-biology/cutg/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci-biology@gentoo.org</email>
+ <name>Gentoo Biology Project</name>
+ </maintainer>
+ <longdescription>
+ Codon usage tables maintained at the Kazusa DNA Research Institute.
+ Codon usage in individual genes has been calculated using the
+ nucleotide sequence data obtained from the GenBank Genetic Sequence
+ Database. The compilation of codon usage is synchronized with each
+ major release of GenBank.
+ </longdescription>
+</pkgmetadata>