summaryrefslogtreecommitdiff
path: root/sci-biology/cufflinks/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-biology/cufflinks/files
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-biology/cufflinks/files')
-rw-r--r--sci-biology/cufflinks/files/cufflinks-2.2.1-boost-1.65-tr1-removal.patch14
-rw-r--r--sci-biology/cufflinks/files/cufflinks-2.2.1-flags.patch28
-rw-r--r--sci-biology/cufflinks/files/cufflinks-2.2.1-gcc6.patch14
-rw-r--r--sci-biology/cufflinks/files/cufflinks-2.2.1-samtools-legacy.patch44
4 files changed, 100 insertions, 0 deletions
diff --git a/sci-biology/cufflinks/files/cufflinks-2.2.1-boost-1.65-tr1-removal.patch b/sci-biology/cufflinks/files/cufflinks-2.2.1-boost-1.65-tr1-removal.patch
new file mode 100644
index 000000000000..42a906e7a83a
--- /dev/null
+++ b/sci-biology/cufflinks/files/cufflinks-2.2.1-boost-1.65-tr1-removal.patch
@@ -0,0 +1,14 @@
+Boost 1.65 removed the TR1 headers.
+Bug: https://bugs.gentoo.org/show_bug.cgi?id=630654
+
+--- a/src/biascorrection.h
++++ b/src/biascorrection.h
+@@ -15,7 +15,7 @@
+ #include <vector>
+ #include <list>
+ #include <string>
+-#include <boost/tr1/unordered_map.hpp>
++#include <boost/unordered_map.hpp>
+ #include <boost/thread.hpp>
+ #include "common.h"
+
diff --git a/sci-biology/cufflinks/files/cufflinks-2.2.1-flags.patch b/sci-biology/cufflinks/files/cufflinks-2.2.1-flags.patch
new file mode 100644
index 000000000000..47784088fab9
--- /dev/null
+++ b/sci-biology/cufflinks/files/cufflinks-2.2.1-flags.patch
@@ -0,0 +1,28 @@
+ configure.ac | 7 ++++---
+ 1 file changed, 4 insertions(+), 3 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 96ffbac..e88b8e4 100755
+--- a/configure.ac
++++ b/configure.ac
+@@ -61,7 +61,8 @@ AC_CANONICAL_HOST
+
+ # set CFLAGS and CXXFLAGS
+ user_CFLAGS=${CFLAGS}
+-generic_CFLAGS="-Wall -Wno-strict-aliasing -g -gdwarf-2 -Wunused -Wuninitialized -ftemplate-depth-1024"
++generic_CFLAGS="-Wall -Wno-strict-aliasing -Wunused -Wuninitialized"
++generic_CXXFLAGS="-Wall -Wno-strict-aliasing -Wunused -Wuninitialized -ftemplate-depth-1024"
+ ext_CFLAGS=""
+ debug_CFLAGS=""
+ #echo "${host_cpu}-${host_os}"
+@@ -106,8 +107,8 @@ AC_ARG_ENABLE(profiling, [ --enable-profiling enable profiling with
+ [ext_LDFLAGS="-lprofiler -ltcmalloc"], [])
+
+ CFLAGS="${generic_CFLAGS} ${ext_CFLAGS} ${user_CFLAGS} ${debug_CFLAGS} ${OPENMP_CFLAGS}"
+-CXXFLAGS="$CFLAGS"
+-CXXFLAGS="${CXXFLAGS} ${BOOST_CPPFLAGS} ${BAM_CPPFLAGS} ${EIGEN_CPPFLAGS}"
++CXXFLAGS="${generic_CFLAGS} ${CXXFLAGS}"
++CPPFLAGS="${CPPFLAGS} ${BOOST_CPPFLAGS} ${BAM_CPPFLAGS} ${EIGEN_CPPFLAGS}"
+ user_LDFLAGS="$LDFLAGS"
+ LDFLAGS="${ext_LDFLAGS} ${user_LDFLAGS}"
+
diff --git a/sci-biology/cufflinks/files/cufflinks-2.2.1-gcc6.patch b/sci-biology/cufflinks/files/cufflinks-2.2.1-gcc6.patch
new file mode 100644
index 000000000000..6ee9bcf456d4
--- /dev/null
+++ b/sci-biology/cufflinks/files/cufflinks-2.2.1-gcc6.patch
@@ -0,0 +1,14 @@
+--- a/src/lemon/error.h
++++ b/src/lemon/error.h
+@@ -67,9 +67,9 @@
+ }
+
+ ExceptionMember& operator=(const ExceptionMember& copy) {
+- if (ptr.get() == 0) return;
++ if (ptr.get() == 0) return *this;
+ try {
+- if (!copy.valid()) return;
++ if (!copy.valid()) return *this;
+ *ptr = copy.get();
+ } catch (...) {}
+ }
diff --git a/sci-biology/cufflinks/files/cufflinks-2.2.1-samtools-legacy.patch b/sci-biology/cufflinks/files/cufflinks-2.2.1-samtools-legacy.patch
new file mode 100644
index 000000000000..374ce519ef86
--- /dev/null
+++ b/sci-biology/cufflinks/files/cufflinks-2.2.1-samtools-legacy.patch
@@ -0,0 +1,44 @@
+Modify the buildsystem to work with the legacy version of samtools,
+which can coexist with the most recent version of samtools.
+See also: https://bugs.gentoo.org/show_bug.cgi?id=577854
+
+--- cufflinks-2.2.1/ax_bam.m4
++++ cufflinks-2.2.1/ax_bam.m4
+@@ -102,7 +102,7 @@
+
+ AC_LANG_PUSH(C++)
+ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
+- @%:@include <bam/bam.h>
++ @%:@include <bam-0.1-legacy/bam.h>
+ ]], [[
+ ]])],[
+ AC_MSG_RESULT(yes)
+@@ -171,7 +171,7 @@
+
+ AC_LANG_PUSH(C++)
+ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
+- @%:@include <bam/version.hpp>
++ @%:@include <bam-0.1-legacy/version.hpp>
+ ]], [[
+ ]])],[
+ AC_MSG_RESULT(yes)
+@@ -189,7 +189,7 @@
+ AC_MSG_NOTICE([Your bam libraries seem too old (version $_version).])
+ fi
+ else
+- BAM_LIB="-lbam"
++ BAM_LIB="-lbam-0.1-legacy"
+ AC_SUBST(BAM_CPPFLAGS)
+ AC_SUBST(BAM_LDFLAGS)
+ AC_SUBST(BAM_LIB)
+--- cufflinks-2.2.1/src/hits.h
++++ cufflinks-2.2.1/src/hits.h
+@@ -18,7 +18,7 @@
+
+ #include <boost/shared_ptr.hpp>
+
+-#include <bam/sam.h>
++#include <bam-0.1-legacy/sam.h>
+
+ #include "common.h"
+ #include "multireads.h"