summaryrefslogtreecommitdiff
path: root/sci-biology/biosql/biosql-1.0.1-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
commit2719f73b6813d11d13a9650cdd2ab8ec6e69385d (patch)
tree8c816148bcbd22757d892089c989ae614eae4f5a /sci-biology/biosql/biosql-1.0.1-r2.ebuild
parent0f558761aa2dee1017b4751e4017205e015a9560 (diff)
gentoo resync : 09.07.2022
Diffstat (limited to 'sci-biology/biosql/biosql-1.0.1-r2.ebuild')
-rw-r--r--sci-biology/biosql/biosql-1.0.1-r2.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/sci-biology/biosql/biosql-1.0.1-r2.ebuild b/sci-biology/biosql/biosql-1.0.1-r2.ebuild
new file mode 100644
index 000000000000..c32ff970f9af
--- /dev/null
+++ b/sci-biology/biosql/biosql-1.0.1-r2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="A generic bioinformatics relational database model"
+HOMEPAGE="http://www.biosql.org/"
+SRC_URI="http://biosql.org/DIST/${P}.tar.bz2"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="mysql postgres"
+
+# WARNING: bioperl-db is claimed to be incompatible with >=postgresql-8.3 (see INSTALL)
+
+DEPEND="
+ mysql? ( dev-perl/DBD-mysql )
+ postgres? ( dev-perl/DBD-Pg )"
+RDEPEND="
+ ${DEPEND}
+ dev-lang/perl"
+
+src_install() {
+ insinto /usr/share/biosql
+ doins -r sql scripts/.
+
+ dodoc Changes README Release.txt doc/*.pdf
+
+ docinto biopython
+ dodoc doc/{README,schema-overview.txt,biopython/{cor6_6.gb,*.pdf}}
+ docompress -x /usr/share/doc/${PF}/biopython
+
+ docinto html
+ dodoc doc/{biopython/,}*.htm*
+}
+
+pkg_postinst() {
+ elog
+ elog "Please read the BioSQL schema installation instructions in"
+ elog "${EROOT}/usr/share/doc/${PF} to begin using the schema."
+ elog
+}