summaryrefslogtreecommitdiff
path: root/sci-biology/bioperl-run/bioperl-run-1.6.9.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-biology/bioperl-run/bioperl-run-1.6.9.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-biology/bioperl-run/bioperl-run-1.6.9.ebuild')
-rw-r--r--sci-biology/bioperl-run/bioperl-run-1.6.9.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/sci-biology/bioperl-run/bioperl-run-1.6.9.ebuild b/sci-biology/bioperl-run/bioperl-run-1.6.9.ebuild
new file mode 100644
index 000000000000..e5dc816bc78a
--- /dev/null
+++ b/sci-biology/bioperl-run/bioperl-run-1.6.9.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+BIOPERL_RELEASE=1.6.9
+
+MY_PN=BioPerl-Run
+MODULE_AUTHOR=CJFIELDS
+MODULE_VERSION=1.006900
+inherit perl-module
+
+DESCRIPTION="Perl wrapper modules for key bioinformatics applications"
+HOMEPAGE="http://www.bioperl.org/"
+
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="-minimal test"
+#SRC_TEST="do"
+
+RESTRICT="test"
+
+CDEPEND=">=sci-biology/bioperl-${BIOPERL_RELEASE}
+ !minimal? (
+ dev-perl/Algorithm-Diff
+ dev-perl/XML-Twig
+ dev-perl/IO-String
+ dev-perl/IPC-Run
+ dev-perl/File-Sort
+ )"
+DEPEND="dev-perl/Module-Build
+ ${CDEPEND}"
+RDEPEND="${CDEPEND}"
+
+src_install() {
+ mydoc="AUTHORS BUGS FAQ"
+ perl-module_src_install
+ # TODO: File collision in Bio/ConfigData.pm (a Module::Build internal file)
+ # with sci-biology/bioperl. Workaround: the "nuke it from orbit" solution :D
+ #find "${D}" -name '*ConfigData*' -print -delete
+}