summaryrefslogtreecommitdiff
path: root/sci-biology/augustus
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-biology/augustus
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-biology/augustus')
-rw-r--r--sci-biology/augustus/Manifest6
-rw-r--r--sci-biology/augustus/augustus-2.5.5.ebuild49
-rw-r--r--sci-biology/augustus/files/augustus-2.5.5-sane-build.patch156
-rw-r--r--sci-biology/augustus/metadata.xml8
4 files changed, 219 insertions, 0 deletions
diff --git a/sci-biology/augustus/Manifest b/sci-biology/augustus/Manifest
new file mode 100644
index 000000000000..ff0fe1247ee3
--- /dev/null
+++ b/sci-biology/augustus/Manifest
@@ -0,0 +1,6 @@
+AUX augustus-2.5.5-sane-build.patch 5271 SHA256 0e8692203f1cc994398bc639d101b2be915c4747a5d234d0d564cf0ada6e9ebc SHA512 5afe12b51b8ce27ef32e8e66dd72be451022757228b4c86dec938b26870885bee06712438a22801a42944d2def8ae8bf4a2d7fdb82e12455c145abcd6f0c4aa1 WHIRLPOOL f6bde27abe50c567a2a07ef61ce9c8033592261b26a61828eac9f6d6e74b104220a986d9bd57138b74375a747e2b9c619a49e7a6865be4de037a288b7882186b
+DIST augustus.2.5.5.tar.gz 70826249 SHA256 2bd97784fa651addf836e2100a7d4106b43e50fe06f13c664001d4625d0eab9a SHA512 33eb05d5c90200d2fc17026743d3a25e73aa3e217b8546f0bed4c94bcb460597d853377a67896e52e45ead5d736d13ed3b2c91b31fed8216da2920c825e8c20f WHIRLPOOL 875f56f10251767fb066b5e21b0c2361c952d5cc44daa811658be8119957ffa34fd4552fde7e17384d5bc916aee5ef91982ded3999d0077cf3834d5fc20e7f1a
+EBUILD augustus-2.5.5.ebuild 1010 SHA256 033f5e2e2b896c957d5d8967453e0b1b96f678f29868c8b5eb851eecbd8df0c1 SHA512 6cf6076dd9c1c957302f5ec65867b9055a29e4a893f925bc18cb96cc7c57509e65497013e574a33dbe718f0aeb4a25422078874cf0b85603b30ca40abe81527f WHIRLPOOL 2bb05518431d7bdd3668ec1d6a2b176c2ef1dfcb7d64795ff8cc3cbc17de24b92673f85070f0fd456010a5be31660366863240d105cf2280c2cceafea2df3e7a
+MISC ChangeLog 2473 SHA256 2c4273e98146a8dc38d829552338065b456a56e357159e132118fdf965ede5d8 SHA512 062913083dad8dac702b249e13c9ca47dd724251bc87ee8544b2e22e5a8dab6e85359a285da508d039187907df52ed34ba6f9c99550d9517f7b07425278dc5ef WHIRLPOOL dc3e0173575eeb291afb2e72623c1e13919f3c9b6ecf2bf25fd59d2e98114b55b146cd36e1b7d5facbdd8c72125911d0812309e7b83ff06cdbcb250e0f88db49
+MISC ChangeLog-2015 2694 SHA256 e16526a6f364e77aee894fdebdf37d30122ab4160720c02958d7f5da49a5d431 SHA512 6c32e0eca978ac36d1eeaca4bb8319ea279789709a09ebe00dcd3af6e581c877d1f09a6391e3c92fc0d616354bb7c6661c961a13d2256f7df5a14f8c3874d5c7 WHIRLPOOL e01995e98d2882ce11571bb9c9990de20d80d1fe22a126f295fde66b36fbedd2f5c3e3dfa00d898c2c59a3c5799018c6729a459cbb697f9ddbda24f6a5a3c4f6
+MISC metadata.xml 267 SHA256 b3535fccca0fc8511c1245214c1a7c105447b35f21093bda132991874ce82d48 SHA512 91ab266d9ab24401bc0fec759c5b6cfcf44a3c5669fc31c7301d79770839bb5dfa0e155d949392ef06176b4a0b2c32b91b1b54b0027f972db61f0a5e54644403 WHIRLPOOL d841a2f928c50434f2e8c65f583ea3aa2d04e5cebd664b1531ab5373260f735219131991000bbb2b21aa3add05dcdce29548b78eac8d8c0eced6dc5505b64e13
diff --git a/sci-biology/augustus/augustus-2.5.5.ebuild b/sci-biology/augustus/augustus-2.5.5.ebuild
new file mode 100644
index 000000000000..ff4dfd6cc7e0
--- /dev/null
+++ b/sci-biology/augustus/augustus-2.5.5.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Eukaryotic gene predictor"
+HOMEPAGE="http://augustus.gobics.de/"
+SRC_URI="http://augustus.gobics.de/binaries/${PN}.${PV}.tar.gz"
+
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="examples"
+
+S="${WORKDIR}/${PN}.${PV}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-sane-build.patch
+ tc-export CC CXX
+}
+
+src_compile() {
+ emake clean && emake
+}
+
+src_install() {
+ dobin bin/*
+# dobin src/{augustus,etraining,consensusFinder,curve2hints,fastBlockSearch,prepareAlign}
+
+ exeinto /usr/libexec/${PN}
+ doexe scripts/*.p*
+ insinto /usr/libexec/${PN}
+ doins scripts/*.conf
+
+ insinto /usr/share/${PN}
+ doins -r config
+
+ echo "AUGUSTUS_CONFIG_PATH=\"/usr/share/${PN}/config\"" > "${S}/99${PN}"
+ doenvd "${S}/99${PN}"
+
+ dodoc -r README.TXT HISTORY.TXT docs/*.{pdf,txt}
+
+ if use examples; then
+ insinto /usr/share/${PN}/
+ doins -r docs/tutorial examples
+ fi
+}
diff --git a/sci-biology/augustus/files/augustus-2.5.5-sane-build.patch b/sci-biology/augustus/files/augustus-2.5.5-sane-build.patch
new file mode 100644
index 000000000000..39cd0762b1c1
--- /dev/null
+++ b/sci-biology/augustus/files/augustus-2.5.5-sane-build.patch
@@ -0,0 +1,156 @@
+ Makefile | 8 +++---
+ scripts/Makefile | 6 +++-
+ scripts/aln2wig/Makefile | 8 +++---
+ scripts/compileSpliceCands/Makefile | 6 ++--
+ src/Makefile | 43 ++++++++++++++++++----------------
+ 5 files changed, 38 insertions(+), 33 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index e23a667..64610c8 100644
+--- a/Makefile
++++ b/Makefile
+@@ -3,9 +3,9 @@
+ #
+
+ all:
+- cd src && ${MAKE}
+- cd scripts && ${MAKE}
++ $(MAKE) -C src
++ $(MAKE) -C scripts
+
+ clean:
+- cd src && ${MAKE} clean
+- cd scripts && ${MAKE} clean
++ $(MAKE) -C src clean
++ $(MAKE) -C scripts clean
+diff --git a/scripts/Makefile b/scripts/Makefile
+index 6d4dd67..ab6a885 100644
+--- a/scripts/Makefile
++++ b/scripts/Makefile
+@@ -1,5 +1,7 @@
+ all :
+- cd aln2wig && ${MAKE}
++ $(MAKE) -C aln2wig
++ $(MAKE) -C compileSpliceCands
+
+ clean :
+- cd aln2wig && ${MAKE} clean
++ $(MAKE) -C aln2wig clean
++ $(MAKE) -C compileSpliceCands
+diff --git a/scripts/aln2wig/Makefile b/scripts/aln2wig/Makefile
+index 64d09f5..9752980 100644
+--- a/scripts/aln2wig/Makefile
++++ b/scripts/aln2wig/Makefile
+@@ -1,10 +1,10 @@
+-CFLAGS := -Wall -Wno-unused-result -Wno-sign-compare -ansi -pedantic -O2 -ggdb
++CFLAGS += -Wall -Wno-unused-result -Wno-sign-compare -ansi -pedantic
+
+ psl2wig : aln2wig.o
+- gcc $(CFLAGS) -o aln2wig aln2wig.o;
+- cp aln2wig ../../bin
++ $(CC) $(CFLAGS) $(LDFLAGS) -o aln2wig aln2wig.o;
++ cp aln2wig ../../bin/
+ psl2wig.o : aln2wig.c
+- gcc $(CFLAGS) -c aln2wig.c
++ $(CC) $(CFLAGS) -c aln2wig.c
+
+ all : psl2wig
+
+diff --git a/scripts/compileSpliceCands/Makefile b/scripts/compileSpliceCands/Makefile
+index cddada5..8079791 100644
+--- a/scripts/compileSpliceCands/Makefile
++++ b/scripts/compileSpliceCands/Makefile
+@@ -1,8 +1,8 @@
+ compileSpliceCands : compileSpliceCands.o list.h list.o
+- gcc -o compileSpliceCands compileSpliceCands.o list.o;
+-# cp compileSpliceCands ../../bin
++ $(CC) $(CFLAGS) $(LDFLAGS) -o compileSpliceCands compileSpliceCands.o list.o;
++ cp compileSpliceCands ../../bin/
+ compileSpliceCands.o : compileSpliceCands.c
+- gcc -Wall -pedantic -ansi -c compileSpliceCands.c
++ $(CC) $(CFLAGS) -Wall -pedantic -ansi -c compileSpliceCands.c
+
+ all : compileSpliceCands
+
+diff --git a/src/Makefile b/src/Makefile
+index 71795b6..732b953 100644
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -6,8 +6,8 @@
+ # a strict signed-only usage strategy to avoid mistakes since we are not warned about this.
+ # - In the current version, the order of object files in $(OBJS) IS IMPORTANT (see lldouble.hh)
+ #
+-CC = g++
+-CFLAGS := -Wall -Wno-sign-compare -ansi -pedantic -O2 ${CFLAGS} -static # -pg -DDEBUG -g -ggdb -static
++CXX ?= g++
++CXXFLAGS += -Wall -Wno-sign-compare -ansi -pedantic # -pg -DDEBUG -g -ggdb -static
+ INCLS = -I../include -I.
+ LIBS = # -lcwd
+ OBJS = genbank.o properties.o pp_profile.o pp_hitseq.o pp_scoring.o statemodel.o namgene.o \
+@@ -18,45 +18,48 @@ TOBJS = commontrain.o igenictrain.o introntrain.o exontrain.o utrtrain.o # conte
+ PROGR = augustus etraining consensusFinder curve2hints fastBlockSearch prepareAlign
+ INFO = cflags
+
+-all: $(OBJS) $(TOBJS) $(DUMOBJS) $(PROGR) info
++all: $(OBJS) $(TOBJS) $(DUMOBJS) $(PROGR) info bin
+
+ .SUFFIXES:
+ .SUFFIXES: .cc .o .so
+
+ .cc.o:
+- $(CC) -c $(CFLAGS) -o $@ $< $(INCLS)
++ $(CXX) -c $(CXXFLAGS) -o $@ $< $(INCLS)
+
+-augustus: augustus.cc $(OBJS) $(DUMOBJS)
+- $(CC) $(CFLAGS) -o $@ $^ $(INCLS) $(LIBS)
++bin: $(PROGR)
++ cp $(PROGR) ../bin/
++
++augustus: augustus.o $(OBJS) $(DUMOBJS)
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) -o $@ $^ $(INCLS) $(LIBS)
+ cp augustus ../bin/
+
+-etraining: etraining.cc $(TOBJS) $(OBJS)
+- $(CC) $(CFLAGS) -o $@ $^ $(INCLS) $(LIBS)
++etraining: etraining.o $(TOBJS) $(OBJS)
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) -o $@ $^ $(INCLS) $(LIBS)
+ cp etraining ../bin/
+
+-evaluate: evaluate.cc $(OBJS) $(DUMOBJS)
+- $(CC) $(CFLAGS) -o $@ $^ $(INCLS) $(LIBS)
++evaluate: evaluate.o $(OBJS) $(DUMOBJS)
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) -o $@ $^ $(INCLS) $(LIBS)
+
+-consensusFinder: consensusFinder.cc consensus.o
+- $(CC) $(CFLAGS) -o $@ $^ $(INCLS) $(LIBS)
++consensusFinder: consensusFinder.o consensus.o
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) -o $@ $^ $(INCLS) $(LIBS)
+
+-curve2hints: curve2hints.cc exon_seg.o
+- $(CC) $(CFLAGS) -o $@ $^ $(INCLS) $(LIBS)
++curve2hints: curve2hints.o exon_seg.o
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) -o $@ $^ $(INCLS) $(LIBS)
+
+-fastBlockSearch: fastBlockSearch.cc pp_fastBlockSearcher.o \
++fastBlockSearch: fastBlockSearch.o pp_fastBlockSearcher.o \
+ types.o properties.o geneticcode.o pp_profile.o lldouble.o
+- $(CC) $(CFLAGS) -o $@ $^ $(INCLS) $(LIBS)
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) -o $@ $^ $(INCLS) $(LIBS)
+ cp fastBlockSearch ../bin/
+
+-prepareAlign: pp_prepare_align.cc
+- $(CC) $(CFLAGS) -o $@ $^
++prepareAlign: pp_prepare_align.o
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) -o $@ $^
+ cp prepareAlign ../bin/
+
+ info:
+- echo "$(CFLAGS)" > $(INFO)
++ echo "$(CXXFLAGS)" > $(INFO)
+
+ clean:
+- rm -f $(PROGR) $(OBJS) $(DUMOBJS) $(TOBJS) consensus.o exon_seg.o pp_fastBlockSearcher.o $(INFO)
++ rm -f $(PROGR) $(OBJS) $(DUMOBJS) $(TOBJS) consensus.o exon_seg.o pp_fastBlockSearcher.o $(INFO) ../bin/*
+
+ tidy: clean
+ rm -f *~ *.o *.rej *.orig ../include/*~ ../include/*.orig ../include/*.rej $(INFO)
diff --git a/sci-biology/augustus/metadata.xml b/sci-biology/augustus/metadata.xml
new file mode 100644
index 000000000000..959160fe46b1
--- /dev/null
+++ b/sci-biology/augustus/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci-biology@gentoo.org</email>
+ <name>Gentoo Biology Project</name>
+ </maintainer>
+</pkgmetadata>