summaryrefslogtreecommitdiff
path: root/sci-astronomy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-05 03:17:06 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-05 03:17:06 +0000
commita8b01fd62375e0df65d5f8f20c5ee142ec6739b6 (patch)
tree20346875d32349138564dc9fa82d43acd8d85da4 /sci-astronomy
parentf932718a139f93e19a6883c061f81b365a408592 (diff)
gentoo auto-resync : 05:11:2022 - 03:17:06
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/Manifest.gzbin6840 -> 7000 bytes
-rw-r--r--sci-astronomy/calcmysky/Manifest3
-rw-r--r--sci-astronomy/calcmysky/calcmysky-0.2.1.ebuild65
-rw-r--r--sci-astronomy/calcmysky/metadata.xml19
-rw-r--r--sci-astronomy/stellarium/Manifest7
-rw-r--r--sci-astronomy/stellarium/files/stellarium-1.1-qxlsx.patch11
-rw-r--r--sci-astronomy/stellarium/metadata.xml3
-rw-r--r--sci-astronomy/stellarium/stellarium-1.1.ebuild172
8 files changed, 279 insertions, 1 deletions
diff --git a/sci-astronomy/Manifest.gz b/sci-astronomy/Manifest.gz
index 30ebbf058519..367815180770 100644
--- a/sci-astronomy/Manifest.gz
+++ b/sci-astronomy/Manifest.gz
Binary files differ
diff --git a/sci-astronomy/calcmysky/Manifest b/sci-astronomy/calcmysky/Manifest
new file mode 100644
index 000000000000..41084953bc2d
--- /dev/null
+++ b/sci-astronomy/calcmysky/Manifest
@@ -0,0 +1,3 @@
+DIST calcmysky-0.2.1.tar.gz 2161314 BLAKE2B b0aa1abc75f59c9c16429749bb8669e49e17e3dc7716bb78f472a9181c7d77a2c82c2f3800529f620604f233f88855908b0b55d824bf259d0912e157b9537faf SHA512 3915b965ee656b259ce7f158dfdd3c9c11a6c3ff907307899ae55e88ad6c1ccfbec8e0a1f784f5232fb0cb2c8300422fa25b8b1d4d11639d3ebb8c76d67059e5
+EBUILD calcmysky-0.2.1.ebuild 1193 BLAKE2B e12fb400bcf40d90fb612685b8eb6d7c257ca6e0140bb6159fd9c3ee7735701665be8667252c423cf67486e8eebb0c1ca8caee4cffb1a7afbab0f89eb0e2b1f8 SHA512 535c0a08f7ce74159dc19e8c47ebef10d92114dcc1578c54e5e718850218c8dcfdf1e8698745e0853ff83c37204432dfffdb539daccb90b35f1189f8a94e5ba8
+MISC metadata.xml 582 BLAKE2B dbfe97e6d7c27ec436cd080f0d9c7969f4a13a174db9637970dc19d9ca3c6387e3de1f97093fb8699e22f77927daa49e10709bfe14b91ade50e3d8bc449bfcb2 SHA512 ec397bf939ac6935284ae74ceca2cd253b9558d963ab627153cd5360bff6f506a8cfe53cbf49a38a59a71fd3013f25138c44d1034aed134f0d1995d021ad7408
diff --git a/sci-astronomy/calcmysky/calcmysky-0.2.1.ebuild b/sci-astronomy/calcmysky/calcmysky-0.2.1.ebuild
new file mode 100644
index 000000000000..47c8b4a34689
--- /dev/null
+++ b/sci-astronomy/calcmysky/calcmysky-0.2.1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multibuild cmake
+
+DESCRIPTION="Simulator of light scattering by planetary atmospheres"
+HOMEPAGE="https://github.com/10110111/CalcMySky"
+SRC_URI="
+ https://github.com/10110111/CalcMySky/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
+"
+
+LICENSE="GPL-3"
+# subslot is soversion
+SLOT="0/14"
+KEYWORDS="~amd64"
+
+IUSE="qt5 qt6"
+REQUIRED_USE="|| ( qt5 qt6 )"
+
+DEPEND="
+ dev-cpp/eigen:3
+ media-libs/glm
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5[-gles2-only]
+ dev-qt/qtopengl:5[-gles2-only]
+ dev-qt/qtwidgets:5[-gles2-only]
+ )
+ qt6? (
+ dev-qt/qtbase:6[gui,opengl,widgets,-gles2-only]
+ )
+"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/CalcMySky-${PV}"
+
+pkg_setup() {
+ MULTIBUILD_VARIANTS=( $(usev qt5) $(usev qt6) )
+}
+
+src_configure() {
+ my_src_configure() {
+ local mycmakeargs=(
+ -DQT_VERSION="${MULTIBUILD_VARIANT/qt/}"
+ )
+
+ cmake_src_configure
+ }
+
+ multibuild_foreach_variant my_src_configure
+}
+
+src_compile() {
+ multibuild_foreach_variant cmake_src_compile
+}
+
+src_test() {
+ multibuild_foreach_variant cmake_build check
+}
+
+src_install() {
+ multibuild_foreach_variant cmake_src_install
+}
diff --git a/sci-astronomy/calcmysky/metadata.xml b/sci-astronomy/calcmysky/metadata.xml
new file mode 100644
index 000000000000..ef26156cdf6d
--- /dev/null
+++ b/sci-astronomy/calcmysky/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>alexey+gentoo@asokolov.org</email>
+ <name>Alexey Sokolov</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci-astronomy@gentoo.org</email>
+ <name>Gentoo Astronomy Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">10110111/CalcMySky</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sci-astronomy/stellarium/Manifest b/sci-astronomy/stellarium/Manifest
index ca3434e49bbf..8daf9e3d1107 100644
--- a/sci-astronomy/stellarium/Manifest
+++ b/sci-astronomy/stellarium/Manifest
@@ -2,13 +2,18 @@ AUX stellarium-0.20.3-unbundle-indi.patch 3217 BLAKE2B 9de42cc423655ef8280fc5d40
AUX stellarium-0.20.3-unbundle-zlib.patch 844 BLAKE2B 24468924728aa9f77ebb2a48d87ecef2eb98768dabc8fcf914972da70feca1dc1de9e32e658afdfb796c769244a2882be8a46c4b9145c6e0109498a5f090baae SHA512 e8a645a302f890e0590369ea6b1642fe38f91b20a3076f8c5201b2b23581394dccc6a0b56e2423e3ab45e926e1a3266bf1fb24e0647ea05e59219147e8b53a1d
AUX stellarium-0.22.2-ccache.patch 340 BLAKE2B 0365157d357d55d321b297a61911dd52e7230faa9a4460c1373543e0e6021a2651ddff15457e35c966ee207db56fe4ba0cdc2dc4f9cba2255a8be9c75b2cc02b SHA512 62aa2767f02602b787560c48fa72de3c9d7ed09529abfa60bd7f11651913ea5ecabfa2ed1087a0aae16ec5b6a7f8706956d641a11fd7e29133f69041492a51b8
AUX stellarium-0.22.2-unbundle-qtcompress.patch 7561 BLAKE2B c9bc4b051fcd26949ecd805c5e235015bbd58e23d7afb92e0576e4eee41ce567ce8f31fa4512f03824493083a56c851b19ec81f806b437916b05853ccdf43f28 SHA512 7c00dac2184ec97177a65fd4d5b10af9b915da86dd72c187633060609e5080186079563b555ecbdb742f6880c37b3d489b6c1f2cde5167fc446353746c474758
+AUX stellarium-1.1-qxlsx.patch 538 BLAKE2B 0d604477ad04c23daf5b112690da0be0853e283ee670ac874d2b6d1e288e2370bcade10b30ef5efcfb18829b109d0e9297a2f39d3294b54e2379d635da799f85 SHA512 ea309f4221a8fb32680af30c4c26acbf302753ae891bbdddab83e91c1fd574ae09ff5958935798532d76ba2147eb0c2c36b6e2a7c09f81ca66c0120ef6e2fb2e
DIST stars_4_1v0_2.cat 16948302 BLAKE2B 6efe02c6343fa3cd121879dddd3017dbd42a7c8965481b1ab79a258cedc4adc85df25240003b95c325eb35a8ed9686c38b2590f78aff9cd400ecac675583232d SHA512 80e5b2d0bc78c09658e84e7ee57309be290ba66a131ff38aa471235ff513d7824b28f6852ba1fdb485f86ede1fb2388cfb6327b2f1fe60bb097ce0cdbe48d2cb
DIST stars_5_2v0_1.cat 42580300 BLAKE2B eb6528c0577b3f2001a8b03cc5a4e08fa4e75723f677d0dda98d27c50791d9825c0e0feca7b00f0cb82ce362bc83f3e8dc2260d14e81e4a070cbbfa44f2107ba SHA512 6fc0f7352d1165a0744cc932b6d379741e4614d5a95edd136522c789eaa8d1bcf05d7445f7dfd6896e8183aa64bf37b3610d87902b54542f62f2418b285892e0
DIST stars_6_2v0_1.cat 148352404 BLAKE2B c605b284b3d768cb1619ada3f58d406fa7737f09949e8926d6c14b82a85927d124d7fcb50c6d6c357d21b003938cc0b28937f2adb28ae268bb5c85d575f5e0ff SHA512 794279407595f44bbc1e492086063d98068bf332202a5448cd83dd7afbdcf7c6c3ff2878f3016369ebb5a98552874eb4eddb38e2c40e9a163c6231b640e02977
DIST stars_7_2v0_1.cat 305710678 BLAKE2B 1cc9b4a6bc35a9339e495f7e0da4f7e90a0e92b05b5de8599be1bbdd2a8053cbcec44b0e58bc9248364666db9cdf23449edf236e3f21fdc0e8f1a4a706afc919 SHA512 43b866eb793e8812c9d5502101a6c985d2055fb88bdbda274726bcd51e1527ecf342b22acd673318c9c8e88cac68eace18de8f27d29ffe64933fd32a5b84c5e3
DIST stars_8_2v0_1.cat 559068934 BLAKE2B c040a369cdf6885759998e1315b554d21a5e2b9b149a67967a8af45606aebf57bec407fab5ce1904978af0dc529aa6bddd267331ca45f58617bbf56d5ca99dee SHA512 06d4fa298b9dff8452f550377df99fcaa5e7107cfc7b75c9a4769b3cb6d97a822a54213c706102c1d7ef2dabc16df32a85f46b2f6d6c6f76a4e919353b739de4
DIST stellarium-0.22.2.tar.gz 409151525 BLAKE2B c49abfb17a8bf7b120d8a0dffbe58b83e18f86b7ef2764cddc946e0cbaad9bf01adaf8d008557108f6354ed11d79e56d94c92c2a07befbd955aed8d201b68292 SHA512 ed905f58e1ff8b257b1e054ca76c83470915b00a04f7925b63784aa62b74e972f332e0b7dc605ffc17bb6516ef4f045943cb564d9637238726b9d7ceb2d44dda
+DIST stellarium-1.1.1.tar.gz 413806998 BLAKE2B bd5679aa32edfa44807e941d0febcb1c1749eada6c2834cb16de4cc9850735c3033122fd1e4afc8b8550441b8a8f70865f6a7b3eb178bf906c8b64d7829ea3f6 SHA512 4564b8df21afb5d266c21e4d59a5df52a0695f102dc68d59d37ea29e520495132c7fb01235ceac5d68b0812fc05d35b5f8c7a5c337c55007ce562f770e3a3612
DIST stellarium-dso-catalog-3.16.dat 28678822 BLAKE2B 130513b5dcb0d06dd605ed62d6bdf12bfd636a5e5f5c33f02c7adb77a6712245a98ce3d56332fce6fea0f18c9b7915af4bb3d9812b1fd09bfc036d4135cef4f5 SHA512 9320d2a3c9af93d19cc4414f371991993793b78315448cafcd83b82de6dc16715b0cab2ddeafca667af31a9086420cbe758708333e5b95215de8a46305324c41
+DIST stellarium-dso-catalog-3.17.dat 28678790 BLAKE2B 8ec14dd34c749a5bea19cc5567b2d703a7e5d4192eda6636fcec9fb2ef0301fd654aefdf4b33db70210da73eb9e385ace2265a57199f5660ec7034887fdcc80f SHA512 c0c679bd9de9e7ac000be5902d3a1e863853e8f9c382186253dd2d77a658fe93a9e2e206ecd1396f64b7b6cd4e738ecc2e11ea43bc6f71a098a44eb77875978a
DIST stellarium_user_guide-0.22.2-1.pdf 35082446 BLAKE2B c9bb7f344a9377fe86b714904aa713c7e6cda59d31f8e547b571da0a057d141fa1b998b4adb3dbdcee0bb7a152b6f6e18b58a4a08c345dc0e77efca6ffb5a801 SHA512 45adfe53fa9c7432952152d95ab96a446a6459348fa6724fff83aababb0c967d9467cc0ca3bd24b834fd189fb69c782e521d94528a60a704062aa445e749a4a5
+DIST stellarium_user_guide-1.1-1.pdf 36567672 BLAKE2B d1b7f9c8d8974aeabe92e3127c84a79b92dd9c3a0057b7831a1851c7fc88c13ec456375847e90576448a5dbe655846142637c91067cc10df20ae2b9373190e8e SHA512 2dbcf4100c1f24770fa23b2995103b94f0736eacca76031cecac582364948a4cb0e32aabdb554a30a7a64ed53eaa3538d59d7af2434eb74a04d562f1453bc89d
EBUILD stellarium-0.22.2.ebuild 4063 BLAKE2B c5068f6b138eddcef9a1690f1645bb8b597ee3642507cd5098bf5a1a1de93e23407ba476229fb1025dfb33e2a7fd291cbbcd2c019a0b9e96ad4a24afc438ee3b SHA512 fbacac381f17706fe72ee905e2eca8dd5699e8ab0b38971baaba13f4ffa31cab5d10b38ecbb0b73dd5cf2a135a19f887132d5d62c88222be4fb58cdcf4b29a63
-MISC metadata.xml 1331 BLAKE2B 858e48ee46003e8f9d5cb7c6dfe0dd0dab5126c069592c7edbdf2ddf0e3b281d4e5cab5cf21b6197dbde7d7a152225999773265cc4319a4550f15ee2c9903626 SHA512 7e801dbdccaef56276bde6a96bfd61811e6d6b6fcba21238d889d8b882afb9e983ed921dd4d30015107cc48afe6539c19a7bb6692300800ed9f8cc5e4166b5e7
+EBUILD stellarium-1.1.ebuild 4738 BLAKE2B b17aa799a1dfe2b9b4be8861496c4c05e7ed0e9b3b10de4a1fb2ec38fea6ba21e92210ea8cc3bdcfd5ed4b1d0df669a1a9167a615e6207e715f45ec297b94f87 SHA512 0630e7d4a7937e25da41f4fa51d3197349457a56adf3d0763274984fc5525d89743a41c0580dc9dee08ca0447ad112262c5f40fa97722b6915f8cee743a86a57
+MISC metadata.xml 1667 BLAKE2B dd7848212ed755809c49cdba0ed63138b5f6f188240f71601e113894fded940ed3ea3850028915700961789f150ea7f5d91a4ff6c4570b753dbe6ff397b81b46 SHA512 bea670b08be632304aab3b9d456bce249f2109195e6e309bd703778e5a93561e552212c900897b72e293a3d81d188afabd5e1d8c213334f6d01b1dc035badca6
diff --git a/sci-astronomy/stellarium/files/stellarium-1.1-qxlsx.patch b/sci-astronomy/stellarium/files/stellarium-1.1-qxlsx.patch
new file mode 100644
index 000000000000..f3e4c9c38ab7
--- /dev/null
+++ b/sci-astronomy/stellarium/files/stellarium-1.1-qxlsx.patch
@@ -0,0 +1,11 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -815,7 +815,7 @@ IF(ENABLE_XLSX)
+ # TODO: switch to something like vcpkg or conan, and plain find_package,
+ # without the fallback of cmake downloading the dep itself.
+ # But some libraries are not available there yet.
+- CPMFindPackage(NAME QXlsx
++ CPMFindPackage(NAME QXlsxQt${QT_VERSION_MAJOR}
+ URL https://github.com/QtExcel/QXlsx/archive/refs/tags/v1.4.4.zip
+ URL_HASH SHA256=3efbd6f63a1ffd521c535dce7b5a5a7e9ebd23db51e6ae8e3e2eb89796e57675
+ DOWNLOAD_ONLY yes
diff --git a/sci-astronomy/stellarium/metadata.xml b/sci-astronomy/stellarium/metadata.xml
index a164ddaabccc..d4860f0597dd 100644
--- a/sci-astronomy/stellarium/metadata.xml
+++ b/sci-astronomy/stellarium/metadata.xml
@@ -22,9 +22,12 @@
<use>
<flag name="deep-sky">Install extra deep sky objects catalog (may affect performance)</flag>
<flag name="media">Enable sound and video support</flag>
+ <flag name="scripting">Enable JS scripting via <pkg>dev-qt/qtscript</pkg> in Qt5 or using Qml via <pkg>dev-qt/qtdeclarative</pkg> in Qt6</flag>
+ <flag name="show-my-sky">Enable a better atmosphere model via <pkg>sci-astronomy/calcmysky</pkg></flag>
<flag name="stars">Install extra star catalogs</flag>
<flag name="telescope">Enable telescope control via <pkg>sci-libs/indilib</pkg></flag>
<flag name="webengine">Show online results about the selected star in an embedded window using <pkg>dev-qt/qtwebengine</pkg></flag>
+ <flag name="xlsx">Support XLSX (Excel) files via <pkg>dev-libs/qxlsx</pkg></flag>
</use>
<upstream>
<remote-id type="github">Stellarium/stellarium</remote-id>
diff --git a/sci-astronomy/stellarium/stellarium-1.1.ebuild b/sci-astronomy/stellarium/stellarium-1.1.ebuild
new file mode 100644
index 000000000000..e10dc3e47f19
--- /dev/null
+++ b/sci-astronomy/stellarium/stellarium-1.1.ebuild
@@ -0,0 +1,172 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit cmake desktop flag-o-matic python-any-r1 xdg virtualx
+
+DESCRIPTION="3D photo-realistic skies in real time"
+HOMEPAGE="https://stellarium.org/"
+MY_DSO_VERSION="3.17"
+SRC_URI="
+ https://github.com/Stellarium/stellarium/releases/download/v${PV}/${P}.1.tar.gz
+ deep-sky? (
+ https://github.com/Stellarium/stellarium-data/releases/download/dso-${MY_DSO_VERSION}/catalog-${MY_DSO_VERSION}.dat -> ${PN}-dso-catalog-${MY_DSO_VERSION}.dat
+ )
+ doc? (
+ https://github.com/Stellarium/stellarium/releases/download/v${PV}/stellarium_user_guide-${PV}-1.pdf
+ )
+ stars? (
+ https://github.com/Stellarium/stellarium-data/releases/download/stars-2.0/stars_4_1v0_2.cat
+ https://github.com/Stellarium/stellarium-data/releases/download/stars-2.0/stars_5_2v0_1.cat
+ https://github.com/Stellarium/stellarium-data/releases/download/stars-2.0/stars_6_2v0_1.cat
+ https://github.com/Stellarium/stellarium-data/releases/download/stars-2.0/stars_7_2v0_1.cat
+ https://github.com/Stellarium/stellarium-data/releases/download/stars-2.0/stars_8_2v0_1.cat
+ )"
+
+LICENSE="GPL-2+ SGI-B-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="debug deep-sky doc gps media nls qt6 +scripting +show-my-sky stars telescope test webengine +xlsx"
+# Qt6 QAudioOutput crashes on startup; qt 6.4.0
+# https://bugreports.qt.io/browse/QTBUG-108221
+REQUIRED_USE="|| ( !media !qt6 )"
+
+# Python interpreter is used while building RemoteControl plugin
+BDEPEND="
+ ${PYTHON_DEPS}
+ dev-lang/perl
+ doc? ( app-doc/doxygen[dot] )
+ nls? (
+ !qt6? ( dev-qt/linguist-tools:5 )
+ qt6? ( dev-qt/qttools:6[linguist] )
+ )
+"
+RDEPEND="
+ media-fonts/dejavu
+ sys-libs/zlib
+ gps? ( sci-geosciences/gpsd:=[cxx] )
+ media? ( virtual/opengl )
+ !qt6? (
+ dev-qt/qtcharts:5
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5=
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5
+ sci-astronomy/calcmysky:=[qt5]
+ gps? (
+ dev-qt/qtpositioning:5
+ dev-qt/qtserialport:5
+ )
+ media? (
+ dev-qt/qtmultimedia:5[widgets]
+ dev-qt/qtopengl:5
+ )
+ scripting? ( dev-qt/qtscript:5 )
+ telescope? ( dev-qt/qtserialport:5 )
+ webengine? ( dev-qt/qtwebengine:5[widgets] )
+ xlsx? ( dev-libs/qxlsx:=[qt5] )
+ )
+ qt6? (
+ dev-qt/qtbase:6=[gui,network,widgets]
+ dev-qt/qtcharts:6
+ sci-astronomy/calcmysky:=[qt6]
+ gps? (
+ dev-qt/qtpositioning:6
+ dev-qt/qtserialport:6
+ )
+ media? (
+ dev-qt/qtmultimedia:6[gstreamer]
+ )
+ scripting? ( dev-qt/qtdeclarative:6 )
+ telescope? ( dev-qt/qtserialport:6 )
+ webengine? ( dev-qt/qtwebengine:6[widgets] )
+ xlsx? ( dev-libs/qxlsx:=[qt6] )
+ )
+ telescope? ( sci-libs/indilib:= )
+"
+DEPEND="${RDEPEND}
+ !qt6? (
+ dev-qt/qtconcurrent:5
+ test? ( dev-qt/qttest:5 )
+ )
+ qt6? ( dev-qt/qtbase:6=[concurrent] )
+"
+
+RESTRICT="!test? ( test )"
+
+PATCHES=(
+ "${FILESDIR}/stellarium-0.20.3-unbundle-zlib.patch"
+ "${FILESDIR}/stellarium-0.22.2-ccache.patch"
+ "${FILESDIR}/stellarium-1.1-qxlsx.patch"
+)
+
+src_prepare() {
+ cmake_src_prepare
+ use debug || append-cppflags -DQT_NO_DEBUG #415769
+
+ rm -r src/external/zlib/ || die
+
+ # for glues_stel aka libtess I couldn't find an upstream with the same API
+
+ local remaining="$(cd src/external/ && echo */)"
+ if [[ "${remaining}" != "glues_stel/" ]]; then
+ eqawarn "Need to unbundle more deps: ${remaining}"
+ fi
+}
+
+src_configure() {
+ filter-lto # https://bugs.gentoo.org/862249
+
+ local mycmakeargs=(
+ -DCPM_LOCAL_PACKAGES_ONLY=yes
+ -DENABLE_GPS="$(usex gps)"
+ -DENABLE_MEDIA="$(usex media)"
+ -DENABLE_NLS="$(usex nls)"
+ -DENABLE_QT6="$(usex qt6)"
+ -DENABLE_QTWEBENGINE="$(usex webengine)"
+ -DENABLE_SHOWMYSKY=$(usex show-my-sky)
+ -DENABLE_SCRIPTING=$(usex scripting)
+ -DENABLE_TESTING="$(usex test)"
+ -DENABLE_XLSX="$(usex xlsx)"
+ -DUSE_PLUGIN_TELESCOPECONTROL="$(usex telescope)"
+ )
+ cmake_src_configure
+}
+
+src_test() {
+ virtx cmake_src_test
+}
+
+src_compile() {
+ cmake_src_compile
+
+ if use doc ; then
+ cmake_build apidoc
+ fi
+}
+
+src_install() {
+ if use doc ; then
+ local HTML_DOCS=( "${BUILD_DIR}/doc/html/." )
+ dodoc "${DISTDIR}/stellarium_user_guide-${PV}-1.pdf"
+ fi
+ cmake_src_install
+
+ # use the more up-to-date system fonts
+ rm "${ED}"/usr/share/stellarium/data/DejaVuSans{Mono,}.ttf || die
+ dosym ../../fonts/dejavu/DejaVuSans.ttf /usr/share/stellarium/data/DejaVuSans.ttf
+ dosym ../../fonts/dejavu/DejaVuSansMono.ttf /usr/share/stellarium/data/DejaVuSansMono.ttf
+
+ if use stars ; then
+ insinto /usr/share/${PN}/stars/default
+ doins "${DISTDIR}"/stars_4_1v0_2.cat
+ doins "${DISTDIR}"/stars_{5,6,7,8}_2v0_1.cat
+ fi
+ if use deep-sky ; then
+ insinto /usr/share/${PN}/nebulae/default
+ newins "${DISTDIR}/${PN}-dso-catalog-${MY_DSO_VERSION}.dat" catalog.dat
+ fi
+ newicon doc/images/stellarium-logo.png ${PN}.png
+}