summaryrefslogtreecommitdiff
path: root/sci-astronomy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-26 23:59:37 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-26 23:59:37 +0100
commit3e42d1577189af123b773dc0f11e5419035308c8 (patch)
tree95d77507c924544b12363e6da6aa741c444f3e8a /sci-astronomy
parent6243676c91946098c06d42bc87b5eb99aac40bf0 (diff)
gentoo auto-resync : 26:04:2024 - 23:59:36
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/Manifest.gzbin6681 -> 6673 bytes
-rw-r--r--sci-astronomy/funtools/Manifest2
-rw-r--r--sci-astronomy/funtools/funtools-1.4.8.ebuild81
3 files changed, 83 insertions, 0 deletions
diff --git a/sci-astronomy/Manifest.gz b/sci-astronomy/Manifest.gz
index df4fb1da1d2e..870ff874ede6 100644
--- a/sci-astronomy/Manifest.gz
+++ b/sci-astronomy/Manifest.gz
Binary files differ
diff --git a/sci-astronomy/funtools/Manifest b/sci-astronomy/funtools/Manifest
index 4fdb70de5ba5..c2273eff9c93 100644
--- a/sci-astronomy/funtools/Manifest
+++ b/sci-astronomy/funtools/Manifest
@@ -1,3 +1,5 @@
DIST funtools-1.4.7.tar.gz 3270079 BLAKE2B 8c366d70d9d7e48c41dcd1f82374dce818c6f8e367b971b6ae44f36491bc41008645cfa02526b6173f8248c172639f7461f5a142434fe2791177718503f66332 SHA512 d53bdb00a2eb9cd70bf60e34a10e5e16435a10b96f89cd55f0ffb686fac30438e2dfc1d823578286be51bee5caf0dcd1c0f257cd8e725cf8e5aa798a6f3c245a
+DIST funtools-1.4.8.tar.gz 3281636 BLAKE2B dd1fd341786e09662a6de88a102a01f02be78775bdada938c4df79f6bae388d07d711df46f52eaea6557589450e104aaff65b0823758161f1aea3301f5a82338 SHA512 f916ce582d66f0350448912be6ec427b0c697e7da49595ec04e86b105af76d229d7721b5fee8844f843b1734129b53402228d7736e55fbae83df405362fb8a6c
EBUILD funtools-1.4.7.ebuild 1845 BLAKE2B 65b29c6521c44414234aaca538018bfa0fe2ef54868ed2fae88d466a4b8ae8bc9939671ed3a06a69a3953f18d51650f6fe0e3c432bd76f78d4ef6704374e0d49 SHA512 9d09686142ed4aa567276c83305cfbbdcc83776a0c135b5ea9da2630f5160c2b15b3062186c17655ef7375d6eb0b0db56139c847c6d865ebb9cea42684ed7ad9
+EBUILD funtools-1.4.8.ebuild 1917 BLAKE2B 8efd1f8f061610a7cf6d914f4f6e783cd99d7c8cc6fdddceac5d3e718288e772de8c311acbec77fc7ead4d94091061b0d109f6734c3bbbdf87a157c114bbfea2 SHA512 df6c93e2e07b860f80c59d6fb08d545ee78320c998095fa4ccabd3aab44ba994f76d395a229fdcb92903e009dc75aeadbfb200b62ed1665cefe55218f180209c
MISC metadata.xml 730 BLAKE2B f61bfa4bd01e5cbc059bcd3632090177da35ae6ac6b91362b408630f9ef533d598e70bdaa46c4ae9e33d2a1dc5f82b4bcb3c9f2fc94548d07aab045229085f4a SHA512 08e091dd36f285586fc6973d7ca3e59497ce05ca13fc66d5e543b0d27b710b2abedb6e210bfa074ae24a3cdc55db4e767f51fba8e459753903bc2c6fa799d03d
diff --git a/sci-astronomy/funtools/funtools-1.4.8.ebuild b/sci-astronomy/funtools/funtools-1.4.8.ebuild
new file mode 100644
index 000000000000..c7ba18476c52
--- /dev/null
+++ b/sci-astronomy/funtools/funtools-1.4.8.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs autotools
+
+DESCRIPTION="FITS library and utlities for astronomical images"
+HOMEPAGE="https://github.com/ericmandel/funtools"
+SRC_URI="https://github.com/ericmandel/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/1"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc static-libs"
+
+RDEPEND="
+ dev-lang/tcl:0=
+ sci-astronomy/wcstools:0=
+ sci-visualization/gnuplot
+ sys-libs/zlib:0=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+ # respect libdir, dont build wcs, respect toolchain
+ sed -e "/INSTALL/s|/lib|/$(get_libdir)|g" \
+ -e 's|${OBJS}|$(OBJS)|g' \
+ -e '/^SUBLIBS/s|wcs||g' \
+ -e 's/mkdir/mkdir -p/g' \
+ -e '/mklib/s|-o $(PACKAGE)|-o $(PACKAGE) $(LIBS)|g' \
+ -e "s| ar| $(tc-getAR)|g" \
+ -e "s|ar cruv|$(tc-getAR) cruv|g" \
+ -e "s|WCS_INC.*=.*|WCS_INC = $($(tc-getPKG_CONFIG) --cflags wcstools)|g" \
+ -i Makefile.in */Makefile.in || die
+ # fix race condition (when ccache is on)
+ sed -e 's|$(LIB):|$(LIB): FORCE|g' \
+ -e '$aFORCE:' \
+ -i */Makefile.in || die
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --exec-prefix="${EPREFIX}/usr"
+ --enable-shared
+ --enable-dl
+ --with-wcslib="$($(tc-getPKG_CONFIG) --libs wcstools)"
+ --with-zlib="$($(tc-getPKG_CONFIG) --libs zlib)"
+ --with-tcl="${EPREFIX}/usr/$(get_libdir)"
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ emake
+ emake shtclfun
+}
+
+src_install() {
+ default
+ # install missing includes
+ insinto /usr/include/funtools/fitsy
+ doins fitsy/*.h
+
+ # fix bug #536630
+ mv "${ED}"/usr/share/man/man3/funopen.3 \
+ "${ED}"/usr/share/man/man7/funopen.7 \
+ || die
+
+ if use doc; then
+ dodoc doc/*.pdf doc/*html doc/*c \
+ docompress -x /usr/share/doc/${PF}/*.c
+ fi
+
+ if ! use static-libs; then
+ find "${ED}" -name "*.a" -delete || die
+ fi
+}