summaryrefslogtreecommitdiff
path: root/sci-astronomy/siril/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-15 13:42:19 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-15 13:42:19 +0100
commitbd8ca999980e9c0c9ae40a11789c858bb58769e3 (patch)
tree355d68a84921e04a81231e74fc062f229f76a733 /sci-astronomy/siril/files
parentb3f2504c1d05b5999b74b2135860fc721e3adf68 (diff)
gentoo auto-resync : 15:07:2022 - 13:42:19
Diffstat (limited to 'sci-astronomy/siril/files')
-rw-r--r--sci-astronomy/siril/files/siril-1.0.3-dependencies.patch177
-rw-r--r--sci-astronomy/siril/files/siril-9999-dependencies.patch198
2 files changed, 375 insertions, 0 deletions
diff --git a/sci-astronomy/siril/files/siril-1.0.3-dependencies.patch b/sci-astronomy/siril/files/siril-1.0.3-dependencies.patch
new file mode 100644
index 000000000000..84595472e63f
--- /dev/null
+++ b/sci-astronomy/siril/files/siril-1.0.3-dependencies.patch
@@ -0,0 +1,177 @@
+diff --git a/meson.build b/meson.build
+index 3d8e5508..5572bf61 100644
+--- a/meson.build
++++ b/meson.build
+@@ -42,7 +42,16 @@ srcInclude = include_directories('src')
+
+ warnings = []
+
+-enable_openmp = get_option('openmp')
++enable_openmp = get_option('openmp')
++enable_libraw = get_option('libraw')
++enable_libtiff = get_option('libtiff')
++enable_libjpeg = get_option('libjpeg')
++enable_libpng = get_option('libpng')
++enable_libheif = get_option('libheif')
++enable_ffms2 = get_option('ffms2')
++enable_ffmpeg = get_option('ffmpeg')
++enable_wcslib = get_option('wcslib')
++enable_criterion = get_option('criterion')
+
+ # General version
+ siril_version = meson.project_version()
+@@ -257,32 +266,67 @@ if enable_openmp
+ siril_cpp_flag += ['-Xpreprocessor', '-fopenmp']
+ siril_c_flag += ['-Xpreprocessor', '-fopenmp']
+ else
+- openmp_dep = dependency('openmp', required : false)
++ openmp_dep = dependency('openmp', required : true)
+ endif
+ else
+ message('OpenMP disabled')
+ endif
+
+-libraw_dep = dependency('libraw', required : false)
+-libtiff_dep = dependency('libtiff-4', required : false)
+-libjpeg_dep = dependency('libjpeg', required : false)
+-libpng_dep = dependency('libpng', required : false, version: '>= 1.6.0')
+-libheif_dep = dependency('libheif', required : false)
+-ffms2_dep = dependency('ffms2', required : false)
+-ffmpeg = [
+- dependency('libavformat', required : false),
+- dependency('libavcodec', required : false),
+- dependency('libavutil', version : '>= 55.20', required : false),
+- dependency('libswscale', required : false),
+- dependency('libswresample', required : false)
+-]
++libraw_dep = no_dep
++if enable_libraw
++ libraw_dep = dependency('libraw', required : true)
++endif
++
++libtiff_dep = no_dep
++if enable_libtiff
++ libtiff_dep = dependency('libtiff-4', required : true)
++endif
++
++libjpeg_dep = no_dep
++if enable_libjpeg
++ libjpeg_dep = dependency('libjpeg', required : true)
++endif
++
++libpng_dep = no_dep
++if enable_libpng
++ libpng_dep = dependency('libpng', required : true, version: '>= 1.6.0')
++endif
++
++libheif_dep = no_dep
++if enable_libheif
++ libheif_dep = dependency('libheif', required : true)
++endif
++
++ffms2_dep = no_dep
++if enable_ffms2
++ ffms2_dep = dependency('ffms2', required : true)
++endif
++
++ffmpeg = []
++if enable_ffmpeg
++ ffmpeg = [
++ dependency('libavformat', required : true),
++ dependency('libavcodec', required : true),
++ dependency('libavutil', version : '>= 55.20', required : true),
++ dependency('libswscale', required : true),
++ dependency('libswresample', required : true)
++ ]
++endif
++
+ libcurl_dep = no_dep
+ if enable_libcurl
+- libcurl_dep = dependency('libcurl', required : false)
++ libcurl_dep = dependency('libcurl', required : true)
++endif
++
++criterion_dep = no_dep
++if enable_criterion
++ criterion_dep = dependency('criterion', required : true)
+ endif
+-criterion_dep = dependency('criterion', required : false)
+
+-wcslib_dep = dependency('wcslib', fallback : ['wcslib', 'wcslib_dep'], required : false)
++wcslib_dep = no_dep
++if enable_wcslib
++ wcslib_dep = dependency('wcslib', fallback : ['wcslib', 'wcslib_dep'], required : true)
++endif
+
+ ################################################################################
+ # Configuration
+diff --git a/meson_options.txt b/meson_options.txt
+index cd4b9cc1..5e48ae1f 100644
+--- a/meson_options.txt
++++ b/meson_options.txt
+@@ -12,9 +12,63 @@ option('openmp',
+ description: 'build with OpenMP support'
+ )
+
++option('libraw',
++ type : 'boolean',
++ value : 'false',
++ description: 'build with LibRaw support'
++)
++
++option('libtiff',
++ type : 'boolean',
++ value : 'false',
++ description: 'build with TIFF support'
++)
++
++option('libjpeg',
++ type : 'boolean',
++ value : 'false',
++ description: 'build with JPEG support'
++)
++
++option('libpng',
++ type : 'boolean',
++ value : 'false',
++ description: 'build with PNG support'
++)
++
++option('libheif',
++ type : 'boolean',
++ value : 'false',
++ description: 'build with HEIF support'
++)
++
++option('ffms2',
++ type : 'boolean',
++ value : 'false',
++ description: 'build with FFMS2 support'
++)
++
++option('ffmpeg',
++ type : 'boolean',
++ value : 'false',
++ description: 'build with FFmpeg support'
++)
++
+ option('enable-libcurl',
+ type: 'combo',
+ value: 'platform-default',
+ description: 'Use libcurl instead of GIO',
+ choices: [ 'yes', 'no', 'platform-default' ]
+-)
+\ No newline at end of file
++)
++
++option('criterion',
++ type : 'boolean',
++ value : 'false',
++ description: 'build with criterion support'
++)
++
++option('wcslib',
++ type : 'boolean',
++ value : 'false',
++ description: 'build with WCSLIB support'
++)
diff --git a/sci-astronomy/siril/files/siril-9999-dependencies.patch b/sci-astronomy/siril/files/siril-9999-dependencies.patch
new file mode 100644
index 000000000000..b9ed88f98e8a
--- /dev/null
+++ b/sci-astronomy/siril/files/siril-9999-dependencies.patch
@@ -0,0 +1,198 @@
+diff --git a/meson.build b/meson.build
+index fdfc3745..c8823c6f 100644
+--- a/meson.build
++++ b/meson.build
+@@ -42,7 +42,17 @@ srcInclude = include_directories('src')
+
+ warnings = []
+
+-enable_openmp = get_option('openmp')
++enable_openmp = get_option('openmp')
++enable_libraw = get_option('libraw')
++enable_libtiff = get_option('libtiff')
++enable_libjpeg = get_option('libjpeg')
++enable_libpng = get_option('libpng')
++enable_libheif = get_option('libheif')
++enable_ffms2 = get_option('ffms2')
++enable_ffmpeg = get_option('ffmpeg')
++enable_libconfig = get_option('libconfig')
++enable_criterion = get_option('criterion')
++enable_wcslib = get_option('wcslib')
+
+ # General version
+ siril_version = meson.project_version()
+@@ -256,33 +266,72 @@ if enable_openmp
+ siril_cpp_flag += ['-Xpreprocessor', '-fopenmp']
+ siril_c_flag += ['-Xpreprocessor', '-fopenmp']
+ else
+- openmp_dep = dependency('openmp', required : false)
++ openmp_dep = dependency('openmp', required : true)
+ endif
+ else
+ message('OpenMP disabled')
+ endif
+
+-libraw_dep = dependency('libraw', required : false)
+-libtiff_dep = dependency('libtiff-4', required : false)
+-libjpeg_dep = dependency('libjpeg', required : false)
+-libpng_dep = dependency('libpng', required : false, version: '>= 1.6.0')
+-libheif_dep = dependency('libheif', required : false)
+-ffms2_dep = dependency('ffms2', required : false)
+-ffmpeg = [
+- dependency('libavformat', required : false),
+- dependency('libavcodec', required : false),
+- dependency('libavutil', version : '>= 55.20', required : false),
+- dependency('libswscale', required : false),
+- dependency('libswresample', required : false)
+-]
++libraw_dep = no_dep
++if enable_libraw
++ libraw_dep = dependency('libraw', required : true)
++endif
++
++libtiff_dep = no_dep
++if enable_libtiff
++ libtiff_dep = dependency('libtiff-4', required : true)
++endif
++
++libjpeg_dep = no_dep
++if enable_libjpeg
++ libjpeg_dep = dependency('libjpeg', required : true)
++endif
++
++libpng_dep = no_dep
++if enable_libpng
++ libpng_dep = dependency('libpng', required : true, version: '>= 1.6.0')
++endif
++
++libheif_dep = no_dep
++if enable_libheif
++ libheif_dep = dependency('libheif', required : true)
++endif
++
++ffms2_dep = no_dep
++if enable_ffms2
++ ffms2_dep = dependency('ffms2', required : true)
++endif
++
++ffmpeg = []
++if enable_ffmpeg
++ ffmpeg = [
++ dependency('libavformat', required : true),
++ dependency('libavcodec', required : true),
++ dependency('libavutil', version : '>= 55.20', required : true),
++ dependency('libswscale', required : true),
++ dependency('libswresample', required : true)
++ ]
++endif
++
+ libcurl_dep = no_dep
+ if enable_libcurl
+- libcurl_dep = dependency('libcurl', required : false)
++ libcurl_dep = dependency('libcurl', required : true)
+ endif
+-libconfig_dep = dependency('libconfig', required : false)
+-criterion_dep = dependency('criterion', required : false)
+
+-wcslib_dep = dependency('wcslib', fallback : ['wcslib', 'wcslib_dep'], required : false)
++libconfig_dep = no_dep
++if enable_libconfig
++ libconfig_dep = dependency('libconfig', required : true)
++endif
++
++criterion_dep = no_dep
++if enable_criterion
++ criterion_dep = dependency('criterion', required : true)
++endif
++
++wcslib_dep = no_dep
++if enable_wcslib
++ wcslib_dep = dependency('wcslib', fallback : ['wcslib', 'wcslib_dep'], required : true)
++endif
+
+ ################################################################################
+ # Configuration
+@@ -546,6 +595,7 @@ summary(
+ 'FFMPEG' : ffmpeg_found,
+ 'libcurl' : libcurl_dep.found(),
+ 'wcslib' : wcslib_dep.found(),
++ 'libconfig' : libconfig_dep.found(),
+ 'criterion' : criterion_dep.found(),
+ }, section: 'Optional dependencies'
+ )
+diff --git a/meson_options.txt b/meson_options.txt
+index cd4b9cc1..07b4b904 100644
+--- a/meson_options.txt
++++ b/meson_options.txt
+@@ -12,9 +12,69 @@ option('openmp',
+ description: 'build with OpenMP support'
+ )
+
++option('libraw',
++ type : 'boolean',
++ value : 'false',
++ description: 'build with LibRaw support'
++)
++
++option('libtiff',
++ type : 'boolean',
++ value : 'false',
++ description: 'build with TIFF support'
++)
++
++option('libjpeg',
++ type : 'boolean',
++ value : 'false',
++ description: 'build with JPEG support'
++)
++
++option('libpng',
++ type : 'boolean',
++ value : 'false',
++ description: 'build with PNG support'
++)
++
++option('libheif',
++ type : 'boolean',
++ value : 'false',
++ description: 'build with HEIF support'
++)
++
++option('ffms2',
++ type : 'boolean',
++ value : 'false',
++ description: 'build with FFMS2 support'
++)
++
++option('ffmpeg',
++ type : 'boolean',
++ value : 'false',
++ description: 'build with FFmpeg support'
++)
++
+ option('enable-libcurl',
+ type: 'combo',
+ value: 'platform-default',
+ description: 'Use libcurl instead of GIO',
+ choices: [ 'yes', 'no', 'platform-default' ]
+-)
+\ No newline at end of file
++)
++
++option('libconfig',
++ type : 'boolean',
++ value : 'true',
++ description: 'build with libconfig support'
++)
++
++option('criterion',
++ type : 'boolean',
++ value : 'false',
++ description: 'build with criterion support'
++)
++
++option('wcslib',
++ type : 'boolean',
++ value : 'false',
++ description: 'build with WCSLIB support'
++)