summaryrefslogtreecommitdiff
path: root/sci-astronomy/psfex
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-05 09:25:57 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-05 09:25:57 +0000
commit6d691ad5b6239929063441bbd14c489e92e7396e (patch)
treee294f87b1ce66397fee1273bd6c7131aeb586f51 /sci-astronomy/psfex
parentd99093fb4bb5652015c06274d64083daa2439e4f (diff)
gentoo resync : 05.03.2021
Diffstat (limited to 'sci-astronomy/psfex')
-rw-r--r--sci-astronomy/psfex/Manifest2
-rw-r--r--sci-astronomy/psfex/psfex-3.17.1.ebuild22
2 files changed, 15 insertions, 9 deletions
diff --git a/sci-astronomy/psfex/Manifest b/sci-astronomy/psfex/Manifest
index 7a9d0e2d6950..ce834f7ef91f 100644
--- a/sci-astronomy/psfex/Manifest
+++ b/sci-astronomy/psfex/Manifest
@@ -2,5 +2,5 @@ AUX psfex-3.17.1-have-mmap.patch 1406 BLAKE2B 496751b652b4d9c4224465a46011026199
AUX psfex-3.17.1-plplot510.patch 5697 BLAKE2B 4d83b476230f88ee03f6635032fda031ae4daa64df368c0876d48f224c8a44c82e977b3026b16189eb327a0471b64660f95f0ac93e37bc5b8b1b1b4355a7b8b6 SHA512 269457b0592c6458f36c459ca3721df529d8f9ff06e0ed651d4151224bba537e4663a0eb2afb3c55e6e921c56c643fa77f9cb0b39528ae3c09894cc944446328
AUX psfex-3.17.1-sigbus.patch 736 BLAKE2B 4c9dd4e42dce495c7edd9f774d9d9868735f71d8947d998ea7815363f661f428fb9725b56a333aae644c69d451c50dc8dce1c1ce421725cf819e97e7cd6a174d SHA512 bca9ad7a758294812761b9f860cc40cd931a5753f248a4682858e9fd1b917a485d5e0b891e17b90c96b54d0e7f05d1aa2e2e7e6143fdc52ec57d4a609c9f4df6
DIST psfex-3.17.1.tar.gz 2366370 BLAKE2B e73ddb526b93b60baceb9edf0e1a88dc335e55490f43d3e148cf6f0eb25ae192b54abd207fab96534cf4d596c340f824d8d8afdbc7530c7037132383f1f3093e SHA512 eb562372dd75593a111c23698b0c00ce050547051803a741ac771ca346d13a0de1e478b055581619a9fa2bf6fa374915ca685cfcf1c4162271b6aa44303e6e58
-EBUILD psfex-3.17.1.ebuild 1612 BLAKE2B 5d362f782c52fc93b78c01044043d19e2688c0340be0b49305e92fa13a85746f9b4a57b2605cee22016098c618bda72be558e5ec1e23d46fc274bdfca7532926 SHA512 5bc8d5c1f86fa77af30688300d622109e9585c0d1b87f6b896cc472f766f5b7e8c2065f38b261a7c1447739d0196b1fbdae342d7c9c5bfa675c4899b1a8c711c
+EBUILD psfex-3.17.1.ebuild 1682 BLAKE2B 5ebf587bf0a350597861d5679cae2fad51af8cc659f56c8b66b5a6e232271f912a2479e70567866657f66421078ebf6b2e766647ef165f6c39fd08944d015844 SHA512 008846bb111ea2af7ec570d3956d5d627f10380333d53f6d88ef3c053fa7b2ae1e8a38f7d397171a0e4cbf1d2e6083289dc9d71e4af3c0ca58c8b6d2925fd6c3
MISC metadata.xml 720 BLAKE2B 1e96f271388a8189f8a6bbfb9e3a2d847eafc95cb2abc456e9dd429f6294545995c692c391b60cceee9bdbdd74a64f654028f523b39504c0381b2f5925954340 SHA512 7cc57534487d05bed6729a0c2462fb9ff14402145de76071af155b9451ead40cd276cb5b682fa542085066b35eed6dfefa0e73f9a20a788a5f636f38581efa9b
diff --git a/sci-astronomy/psfex/psfex-3.17.1.ebuild b/sci-astronomy/psfex/psfex-3.17.1.ebuild
index a6635393b98b..d5dbf1306d4d 100644
--- a/sci-astronomy/psfex/psfex-3.17.1.ebuild
+++ b/sci-astronomy/psfex/psfex-3.17.1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit autotools
+inherit autotools flag-o-matic
DESCRIPTION="Extracts models of the Point Spread Function from FITS images"
HOMEPAGE="http://www.astromatic.net/software/psfex"
@@ -14,12 +14,12 @@ LICENSE="GPL-3"
SLOT="0"
IUSE="doc threads plplot"
+BDEPEND="virtual/pkgconfig"
RDEPEND="
sci-libs/atlas:0[lapack,threads=]
sci-libs/fftw:3.0
plplot? ( sci-libs/plplot:= )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
+DEPEND="${RDEPEND}"
PATCHES=(
"${FILESDIR}/${P}-have-mmap.patch"
@@ -29,13 +29,16 @@ PATCHES=(
src_prepare() {
default
- local mycblas=atlcblas myclapack=atlclapack
+
+ local mycblas=atlcblas myclapack=atlclapack
+
if use threads; then
- [[ -e ${EPREFIX}/usr/$(get_libdir)/libptcblas.so ]] && \
+ [[ -e "${EPREFIX}"/usr/$(get_libdir)/libptcblas.so ]] && \
mycblas=ptcblas
- [[ -e ${EPREFIX}/usr/$(get_libdir)/libptclapack.so ]] &&
+ [[ -e "${EPREFIX}"/usr/$(get_libdir)/libptclapack.so ]] &&
myclapack=ptclapack
fi
+
# fix the configure and not the acx_atlas.m4. the eautoreconf will
# produce a configure giving a wrong install Makefile target (to fix)
sed -e "s/-lcblas/-l${mycblas}/g" \
@@ -51,6 +54,9 @@ src_prepare() {
}
src_configure() {
+ # bug #724588
+ append-cflags "-fcommon"
+
econf \
--with-atlas-incdir="${EPREFIX}/usr/include/atlas" \
$(use_enable plplot) \