summaryrefslogtreecommitdiff
path: root/sci-astronomy/montage/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-astronomy/montage/files
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-astronomy/montage/files')
-rw-r--r--sci-astronomy/montage/files/montage-4.1-fix_format_errors.patch23
-rw-r--r--sci-astronomy/montage/files/montage-4.1-fix_freetype_incude.patch13
-rw-r--r--sci-astronomy/montage/files/montage-4.1-initdistdata.patch19
-rw-r--r--sci-astronomy/montage/files/montage-4.1-use_system_libs.patch49
-rw-r--r--sci-astronomy/montage/files/montage-5.0-fix_freetype_incude.patch35
5 files changed, 139 insertions, 0 deletions
diff --git a/sci-astronomy/montage/files/montage-4.1-fix_format_errors.patch b/sci-astronomy/montage/files/montage-4.1-fix_format_errors.patch
new file mode 100644
index 000000000000..d29429ccfaad
--- /dev/null
+++ b/sci-astronomy/montage/files/montage-4.1-fix_format_errors.patch
@@ -0,0 +1,23 @@
+Author: Ole Streicher <olebole@debian.org>
+Description: Fix format security error for (s|f)printf
+--- a/grid/Pegasus/hashtable.c
++++ b/grid/Pegasus/hashtable.c
+@@ -4,8 +4,6 @@
+
+ #include <hashtable.h>
+
+-char *strdup(const char *s1);
+-
+ int HT_debug = 0;
+
+ /********************************************************/
+--- a/lib/src/coord/ccalc.c
++++ b/lib/src/coord/ccalc.c
+@@ -25,7 +25,6 @@
+ static int ConvertfromDD(char *fmt, char *clongprec, char *clatprec,
+ char *clon, char *clat, double *lon, double *lat);
+ static char *downcase(char *s);
+-char *strdup(const char *s1);
+ int ParseUnits(char *cunit, int *chflag, CoordUnit *unit);
+ int ParsePrec(CoordUnit units, char *cprec, int longflag);
+
diff --git a/sci-astronomy/montage/files/montage-4.1-fix_freetype_incude.patch b/sci-astronomy/montage/files/montage-4.1-fix_freetype_incude.patch
new file mode 100644
index 000000000000..0b27c83784db
--- /dev/null
+++ b/sci-astronomy/montage/files/montage-4.1-fix_freetype_incude.patch
@@ -0,0 +1,13 @@
+Author: Ole Streicher <olebole@debian.org>
+Description: Fix freetype include path
+--- a/util/Viewer/graphics.c
++++ b/util/Viewer/graphics.c
+@@ -1,7 +1,7 @@
+ #include <stdio.h>
+ #include <math.h>
+ #include <freetype2/ft2build.h>
+-#include <freetype.h>
++#include FT_FREETYPE_H
+
+ void labeled_curve (char *face_path, int fontsize, int showLine,
+ double *xcurve, double *ycurve, int npt,
diff --git a/sci-astronomy/montage/files/montage-4.1-initdistdata.patch b/sci-astronomy/montage/files/montage-4.1-initdistdata.patch
new file mode 100644
index 000000000000..7344bbebb122
--- /dev/null
+++ b/sci-astronomy/montage/files/montage-4.1-initdistdata.patch
@@ -0,0 +1,19 @@
+Author: Christoph Deil <Deil.Christoph@gmail.com>
+Description: non-void function 'closefitsfile' should return a value
+ This is copied from macports.
+Bug: https://trac.macports.org/ticket/41076
+Url: https://trac.macports.org/attachment/ticket/41076/patch-lib-src-two_plane_v1.1-initdistdata.c.diff
+--- a/lib/src/two_plane_v1.1/initdistdata.c
++++ b/lib/src/two_plane_v1.1/initdistdata.c
+@@ -33,9 +33,9 @@
+ if (I_fits_return_status != 0)
+ {
+ fprintf(stderr, "Error closing file\n");
+- return;
++ return -1;
+ }
+- return;
++ return 0;
+ }
+
+ int initdata_byheader(char *fitsheader, DistCoeff *coeff)
diff --git a/sci-astronomy/montage/files/montage-4.1-use_system_libs.patch b/sci-astronomy/montage/files/montage-4.1-use_system_libs.patch
new file mode 100644
index 000000000000..4f4ff8d2d748
--- /dev/null
+++ b/sci-astronomy/montage/files/montage-4.1-use_system_libs.patch
@@ -0,0 +1,49 @@
+From: Sebastien Fabbro <bicatali@gentoo.org>
+Date: Tue, 7 Jun 2016 18:25:12 +0000
+Subject: Use system libraries
+
+--- a/lib/src/Makefile
++++ b/lib/src/Makefile
+@@ -1,5 +1,5 @@
+ l:
+- (cd cfitsio-3.25; ./configure; make; cp libcfitsio.a ../..; cp *.h ../../include)
++# (cd cfitsio-3.25; ./configure; make; cp libcfitsio.a ../..; cp *.h ../../include)
+ (cd cmd; make; make install)
+ (cd coord; make; make install)
+ (cd mtbl; make; make install)
+@@ -7,25 +7,25 @@ l:
+ (cd boundaries; make; make install)
+ (cd pixbounds; make; make install)
+ (cd www; make; make install)
+- (cd wcstools-3.8.7/libwcs; make; cp libwcs.a ../../..; cp *.h ../../../include)
++# (cd wcstools-3.8.7/libwcs; make; cp libwcs.a ../../..; cp *.h ../../../include)
+ (cd two_plane_v1.1; make; make install)
+ (cd lodepng_20140823; make; make install)
+- (cd jpeg-8b; ./configure; make; cp .libs/libjpeg.a ../..; cp jpeglib.h jconfig.h jmorecfg.h ../../include)
+- (cd freetype-2.5.4; ./configure --prefix=`pwd`/../../freetype --without-png; make; make install)
++# (cd jpeg-8b; ./configure; make; cp .libs/libjpeg.a ../..; cp jpeglib.h jconfig.h jmorecfg.h ../../include)
++# (cd freetype-2.5.4; ./configure --prefix=`pwd`/../../freetype --without-png; make; make install)
+ (cd ..; ranlib *.a)
+ chmod 644 ../include/*
+
+ clean:
+ rm -rf ../include/* ../freetype ../*.a
+- (cd cfitsio-3.25; make clean; rm -rf config.log config.cache config.status lib)
++# (cd cfitsio-3.25; make clean; rm -rf config.log config.cache config.status lib)
+ (cd cmd; make clean)
+ (cd coord; make clean)
+ (cd mtbl; make clean)
+ (cd svc; make clean)
+ (cd boundaries; make clean)
+ (cd pixbounds; make clean)
+- (cd wcstools-3.8.7/libwcs; make clean)
++# (cd wcstools-3.8.7/libwcs; make clean)
+ (cd two_plane_v1.1; make clean)
+ (cd lodepng_20140823; make clean)
+- (cd jpeg-8b; make clean)
+- (cd freetype-2.5.4; make clean; rm -rf objs/libfreetype.la objs/.libs)
++# (cd jpeg-8b; make clean)
++# (cd freetype-2.5.4; make clean; rm -rf objs/libfreetype.la objs/.libs)
+--
+2.8.3
+
diff --git a/sci-astronomy/montage/files/montage-5.0-fix_freetype_incude.patch b/sci-astronomy/montage/files/montage-5.0-fix_freetype_incude.patch
new file mode 100644
index 000000000000..42fd94950b84
--- /dev/null
+++ b/sci-astronomy/montage/files/montage-5.0-fix_freetype_incude.patch
@@ -0,0 +1,35 @@
+From: Ole Streicher <olebole@debian.org>
+Date: Thu, 22 Dec 2016 14:24:44 +0100
+Subject: Fix freetype include path
+
+---
+ MontageLib/Viewer/mViewer_graphics.c | 2 +-
+ util/Viewer/graphics.c | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/MontageLib/Viewer/mViewer_graphics.c b/MontageLib/Viewer/mViewer_graphics.c
+index 932ca5f..a50281d 100644
+--- a/MontageLib/Viewer/mViewer_graphics.c
++++ b/MontageLib/Viewer/mViewer_graphics.c
+@@ -1,7 +1,7 @@
+ #include <stdio.h>
+ #include <math.h>
+ #include <freetype2/ft2build.h>
+-#include <freetype.h>
++#include FT_FREETYPE_H
+
+ void mViewer_labeledCurve (char *face_path, int fontsize, int showLine,
+ double *xcurve, double *ycurve, int npt,
+diff --git a/util/Viewer/graphics.c b/util/Viewer/graphics.c
+index 6bb7d8d..f7a5215 100644
+--- a/util/Viewer/graphics.c
++++ b/util/Viewer/graphics.c
+@@ -1,7 +1,7 @@
+ #include <stdio.h>
+ #include <math.h>
+ #include <freetype2/ft2build.h>
+-#include <freetype.h>
++#include FT_FREETYPE_H
+
+ void labeled_curve (char *face_path, int fontsize, int showLine,
+ double *xcurve, double *ycurve, int npt,