summaryrefslogtreecommitdiff
path: root/sci-astronomy/missfits/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /sci-astronomy/missfits/files
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'sci-astronomy/missfits/files')
-rw-r--r--sci-astronomy/missfits/files/missfits-2.8.0-fno-common.patch65
-rw-r--r--sci-astronomy/missfits/files/missfits-2.8.0-run-AM_PROG_AR.patch10
2 files changed, 75 insertions, 0 deletions
diff --git a/sci-astronomy/missfits/files/missfits-2.8.0-fno-common.patch b/sci-astronomy/missfits/files/missfits-2.8.0-fno-common.patch
new file mode 100644
index 000000000000..0c7e042376b7
--- /dev/null
+++ b/sci-astronomy/missfits/files/missfits-2.8.0-fno-common.patch
@@ -0,0 +1,65 @@
+--- a/src/file.c
++++ b/src/file.c
+@@ -45,6 +45,8 @@
+ #include "prefs.h"
+ #include "xml.h"
+
++char gstr[MAXCHAR];
++
+ /****** load_fitsfiles *******************************************************
+ PROTO catstruct **load_fitsfiles(char *name, int *ncat, int * outcat,
+ filenum *filetype, int *headflag)
+--- a/src/fits/fitscat.h
++++ b/src/fits/fitscat.h
+@@ -333,6 +333,6 @@
+ warning(char *msg1, char *msg2);
+
+
+-int bswapflag;
++extern int bswapflag;
+
+ #endif
+--- a/src/fits/fitscheck.c
++++ b/src/fits/fitscheck.c
+@@ -38,6 +38,8 @@
+ #include "fitscat_defs.h"
+ #include "fitscat.h"
+
++int bswapflag;
++
+ #define ENCODE_OFFSET 0x30
+ unsigned int exclude[13] = {0x3a, 0x3b, 0x3c, 0x3d, 0x3e, 0x3f, 0x40,
+ 0x5b, 0x5c, 0x5d, 0x5e, 0x5f, 0x60};
+--- a/src/globals.h
++++ b/src/globals.h
+@@ -30,7 +30,7 @@
+ #include "types.h"
+
+ /*----------------------- miscellaneous variables ---------------------------*/
+-char gstr[MAXCHAR];
++extern char gstr[MAXCHAR];
+
+ /*------------------------------- functions ---------------------------------*/
+ extern void makeit(void),
+--- a/src/prefs.c
++++ b/src/prefs.c
+@@ -50,6 +50,8 @@
+ #include "prefs.h"
+ #include "preflist.h"
+
++prefstruct prefs;
++
+ /********************************* dumpprefs ********************************/
+ /*
+ Print the default preference parameters.
+--- a/src/prefs.h
++++ b/src/prefs.h
+@@ -84,7 +84,7 @@
+ double time_diff; /* Execution time */
+ } prefstruct;
+
+-prefstruct prefs;
++extern prefstruct prefs;
+
+ /*----------------------------- Internal constants --------------------------*/
+
diff --git a/sci-astronomy/missfits/files/missfits-2.8.0-run-AM_PROG_AR.patch b/sci-astronomy/missfits/files/missfits-2.8.0-run-AM_PROG_AR.patch
new file mode 100644
index 000000000000..33166519fc6d
--- /dev/null
+++ b/sci-astronomy/missfits/files/missfits-2.8.0-run-AM_PROG_AR.patch
@@ -0,0 +1,10 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -78,6 +78,7 @@
+ ACX_PROG_CC_OPTIM
+ fi
+
++AM_PROG_AR
+ AC_PROG_RANLIB
+ AC_PROG_INSTALL
+