summaryrefslogtreecommitdiff
path: root/sci-astronomy/kstars/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-25 22:29:02 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-25 22:29:02 +0100
commit240b57012ace855bbfd9934b07642416ceeeb5b8 (patch)
treef73ef3c4e5df8a1c5ca8d47177cb034006e0ac09 /sci-astronomy/kstars/files
parent5c636a121a9064a4373d06b60d49a6f5d67c0e2f (diff)
gentoo auto-resync : 25:07:2023 - 22:29:01
Diffstat (limited to 'sci-astronomy/kstars/files')
-rw-r--r--sci-astronomy/kstars/files/kstars-3.6.5-buildfix.patch33
-rw-r--r--sci-astronomy/kstars/files/kstars-3.6.5-gsl.patch59
2 files changed, 92 insertions, 0 deletions
diff --git a/sci-astronomy/kstars/files/kstars-3.6.5-buildfix.patch b/sci-astronomy/kstars/files/kstars-3.6.5-buildfix.patch
new file mode 100644
index 000000000000..793cb2fcead4
--- /dev/null
+++ b/sci-astronomy/kstars/files/kstars-3.6.5-buildfix.patch
@@ -0,0 +1,33 @@
+From ea6f3578b047be156c89137dc61ad874775b94b4 Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Tue, 25 Jul 2023 15:51:40 +0200
+Subject: [PATCH] Drop superfluous definition
+
+While build fails only under certain downstream circumstances,
+this line should not be here in the first place.
+
+Follow-up to a56e12970b2e10305e2942f7aa47cc8bb9f0d53f
+
+See also: https://invent.kde.org/education/kstars/-/issues/251
+
+Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
+---
+ kstars/skycomponents/supernovaecomponent.cpp | 2 --
+ 1 file changed, 2 deletions(-)
+
+diff --git a/kstars/skycomponents/supernovaecomponent.cpp b/kstars/skycomponents/supernovaecomponent.cpp
+index bb427b8e8..3b3866f7d 100644
+--- a/kstars/skycomponents/supernovaecomponent.cpp
++++ b/kstars/skycomponents/supernovaecomponent.cpp
+@@ -36,8 +36,6 @@
+
+ #include <csv.h>
+
+-gzFile gzopen OF((const char *path, const char *mode));
+-
+ const QString SupernovaeComponent::tnsDataFilename("tns_public_objects.csv");
+ const QString SupernovaeComponent::tnsDataFilenameZip("tns-daily.csv.gz");
+ const QString SupernovaeComponent::tnsDataUrl(
+--
+2.41.0
+
diff --git a/sci-astronomy/kstars/files/kstars-3.6.5-gsl.patch b/sci-astronomy/kstars/files/kstars-3.6.5-gsl.patch
new file mode 100644
index 000000000000..1aaa348ba8c1
--- /dev/null
+++ b/sci-astronomy/kstars/files/kstars-3.6.5-gsl.patch
@@ -0,0 +1,59 @@
+From b83de34310d13920e1be5e980d0774f35c1d9a2a Mon Sep 17 00:00:00 2001
+From: Heiko Becker <heiko.becker@kde.org>
+Date: Wed, 31 May 2023 21:19:12 +0200
+Subject: [PATCH] Fix build without INDI
+
+Without INDI present I get the following error:
+
+"x86_64-pc-linux-gnu-ld: ../lib/libKStarsLib.a(robuststatistics.cpp.o):
+in function `Mathematics::GSLHelpers::gslMedianFromSortedData(
+double const*, unsigned long, unsigned long)':
+.../work/kstars-3.6.5/kstars/auxiliary/gslhelpers.h:306: undefined
+reference to `gsl_stats_median_from_sorted_data'"
+
+That is the case because Mathematics::RobustStatistics is used
+unconditionally, which pulls in gslhelpers and the need to link with
+GSL.
+
+Also drop the duplicate linking of KF5::Notifications, KStarsLib already
+links to it in the NOT ANDROID case.
+---
+ kstars/CMakeLists.txt | 8 ++++----
+ 1 file changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/kstars/CMakeLists.txt b/kstars/CMakeLists.txt
+index 747ce79a95..b755be5737 100644
+--- a/kstars/CMakeLists.txt
++++ b/kstars/CMakeLists.txt
+@@ -1169,6 +1169,8 @@ set(kstars_SRCS ${kstars_SRCS} ${fits2_SRCS} ${sep_SRCS} ${gpg_SRCS} ${hough_SRC
+ set(kstarslite_SRCS ${kstarslite_SRCS} ${fits_klite_SRCS} ${sep_SRCS} ${hough_SRCS} ${fits2_klite_SRCS} ${kstarslite_libtess_SRC})
+
+ IF (NOT ANDROID)
++ # GSL
++ find_package(GSL REQUIRED)
+ qt5_add_dbus_adaptor(kstars_SRCS org.kde.kstars.xml kstars.h KStars)
+ qt5_add_dbus_adaptor(kstars_SRCS org.kde.kstars.SimClock.xml simclock.h SimClock)
+ qt5_add_dbus_adaptor(kstars_SRCS org.kde.kstars.FOV.xml fov.h FOV)
+@@ -1243,6 +1245,7 @@ IF (NOT ANDROID)
+ Qt5::WebSockets
+ ${ZLIB_LIBRARIES}
+ Eigen3::Eigen
++ GSL::gsl
+ )
+
+ if (Qt5Keychain_FOUND)
+@@ -1313,10 +1316,7 @@ if(INDI_FOUND)
+ ## Linux + MacOS Lite: Requires INDI Qt5 Client
+ ## Android: Requires INDI Qt5 Client built for Android
+ if (NOT ANDROID)
+- # GSL
+- find_package(GSL REQUIRED)
+- include_directories(${GSL_INCLUDE_DIRS})
+- target_link_libraries(KStarsLib ${GSL_LIBRARIES} ${CMAKE_THREAD_LIBS_INIT} KF5::Notifications)
++ target_link_libraries(KStarsLib ${CMAKE_THREAD_LIBS_INIT})
+ # StellarSolver
+ target_link_libraries(KStarsLib StellarSolver::stellarsolver)
+ endif ()
+--
+GitLab
+