summaryrefslogtreecommitdiff
path: root/sci-astronomy/fitsh/fitsh-0.9.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-11 00:01:23 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-11 00:01:23 +0100
commitc035b2b83f0e94c4b2e82184f00bcef874e6276b (patch)
tree8e1ab9b9e65cafbc237de0d455a13bb3c831de92 /sci-astronomy/fitsh/fitsh-0.9.4.ebuild
parent17e5f1ea4a2e1c5664f96480ca46348d008e8711 (diff)
gentoo auto-resync : 11:05:2024 - 00:01:22
Diffstat (limited to 'sci-astronomy/fitsh/fitsh-0.9.4.ebuild')
-rw-r--r--sci-astronomy/fitsh/fitsh-0.9.4.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/sci-astronomy/fitsh/fitsh-0.9.4.ebuild b/sci-astronomy/fitsh/fitsh-0.9.4.ebuild
new file mode 100644
index 000000000000..365fa1515cac
--- /dev/null
+++ b/sci-astronomy/fitsh/fitsh-0.9.4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Software package for astronomical image processing"
+HOMEPAGE="https://fitsh.net/"
+SRC_URI="https://fitsh.net/download/fitsh/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.9.4-makefile.patch
+)
+
+src_prepare() {
+ default
+
+ local file
+ for file in man/*.gz ; do
+ gzip -d "${file}" || die
+ done
+
+ eautoreconf
+}