summaryrefslogtreecommitdiff
path: root/sci-astronomy/esorex/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-astronomy/esorex/files
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-astronomy/esorex/files')
-rw-r--r--sci-astronomy/esorex/files/esorex-3.10-generate-manpage.patch123
-rw-r--r--sci-astronomy/esorex/files/esorex-3.10-remove-empty-configdir.patch13
-rw-r--r--sci-astronomy/esorex/files/esorex-3.10-remove-private-ltdl.patch39
-rw-r--r--sci-astronomy/esorex/files/esorex-3.10-set-default-plugin-path.patch28
-rw-r--r--sci-astronomy/esorex/files/esorex-3.9.6-use-shared-libs.patch20
5 files changed, 223 insertions, 0 deletions
diff --git a/sci-astronomy/esorex/files/esorex-3.10-generate-manpage.patch b/sci-astronomy/esorex/files/esorex-3.10-generate-manpage.patch
new file mode 100644
index 000000000000..017eb2c8f776
--- /dev/null
+++ b/sci-astronomy/esorex/files/esorex-3.10-generate-manpage.patch
@@ -0,0 +1,123 @@
+Author: Ole Streicher <debian@liska.ath.cx>
+Subject: Generate a manpage for esorex.
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -62,3 +62,7 @@
+ include $(top_builddir)/Makefile.purify
+ endif
+
++esorex.man: esorex
++ sh esorex_create_man.sh
++
++man1_MANS = esorex.man
+--- /dev/null
++++ b/src/esorex_create_man.sh
+@@ -0,0 +1,108 @@
++#!/bin/sh
++
++help2man -N -i $0 ./esorex | sed s/^:\ // | fgrep -v "***" > esorex.man
++<< instrument.
++
++[NAME]
++esorex \- ESO Recipe Execution Tool
++
++[DESCRIPTION]
++EsoRex is the ESO Recipe Execution Tool. It can list, configure and execute
++CPL-based recipes from the command line.
++
++One of the features provided by the CPL is the ability to create
++data-reduction algorithms that run as plugins (dynamic libraries). These are
++called recipes and are one of the main aspects of the CPL data-reduction
++development environment.
++
++As these recipes are dynamic libraries, it is not possible to run them
++directly from the command line. However, ESO provides several tools to do
++this, thus saving recipe developers the need to write such an application
++themselves. One of these is GASGANO (a GUI-based tool) and the other is
++ EsoRex (which runs from the command line) and is described here.
++
++[ENVIRONMENT]
++All options can be set as environment parameters as well. See the previous
++paragraph for details.
++
++[HINTS]
++.TP
++.SH File permissions
++When a recipe is used with the \fB\-\-suppress\-prefix\fR option, and the
++\fB\-\-output\-dir\fR is set to the current working directory, then the first
++execution of a recipe will work correctly, but subsequent executions may
++fail. This is due to output products being given \`read-only\' permission
++(to avoid the potential inadvertant loss of products). The recipe itself
++is unable to modify the permissions, and thus it fails when attempting to
++create the file. The solution (other than using a different output directory
++or prefixes) is to change the permission of these output files or delete
++them prior to any subsequent execution of that recipe.
++
++This problem is less likely to occur in EsoRex v2+, due to the replacement of
++the \fB\-\-output\-overwrite\fR option with the \fB\-\-output\-readonly\fR
++(which is disabled by default). However, a determined user can still reach
++this situation, in which case the non-readable products must have their
++permissions changed, as described above.
++
++.TP
++.SH Configuration files
++When creating configuration files, if the the recipe is provided on the
++command line, then EsoRex will generate the configuration file for this
++recipe. If no recipe name is given, then EsoRex will generate a configuration
++file for EsoRex itself. All configuration files are written in the
++$HOME/.esorex/ directory.
++
++.TP
++.SH Memory checking
++It is possible to get EsoRex to check for memory leaks in the recipe
++that it is running, by enabling the \fB\-\-mem\-check\fR option. Then, at the
++conclusion of the recipe execution, and after memory deallocation, a list of
++all remaining allocated memory will be printed to screen. If there are no
++memory leaks, then no addition output is displayed.
++
++[FILES]
++.TP
++.SH /etc/esorex.rc $HOME/.esorex/esorex.rc
++Default configuration files
++
++The configuration file contains the EsoRex options, less the \`\-\-\'
++switch, but prefixed with \`esorex.caller.\'. Blank lines are ignored and
++lines beginning with \`#\' are treated as comments.
++
++Here is an example configuration file.
++
++ # Example EsoRex configuration file
++ #
++ esorex.caller.recipe-dir=/home/username/EsoRex/Plugins
++ esorex.caller.log-dir=.
++ esorex.caller.log-file=esorex.log
++ esorex.caller.log-file=esorex.log
++ esorex.caller.output-dir=.
++ esorex.caller.output-prefix=out_
++
++.TP
++.SH filename.sof
++A sof file contains a list of the input data. This data is specified in an sof
++file (which is just a text file), where each input file is specified with its
++associated classification and category. The format of each line in the sof
++file is as follows:
++
++ full-path-to-file classification
++
++Optionally, a third column may be provided. Permitted values are either RAW or
++CALIB. This is for when a recipe does not identify the type of input file, but
++as all ESO recipes are required to do so, this column is typically not needed.
++
++An example sof file, for the mythological "ZIMOS" instrument, might look like this:
++
++ /data/mos/ZIMOS.03-12-26T01:05:06.fits MOS_SCIENCE
++ /data/mos/ZIMOS.03-12-26T01:26:00.fits MOS_SCIENCE
++ /data/mos/ZIMOS.03-12-26T01:47:04.fits MOS_SCIENCE
++ /data/cal/master_bias4.fits MASTER_BIAS
++ /data/cal/grs_LR_red.3.tfits GRISM_TABLE
++ /data/gasgano/extract_table2.fits EXTRACT_TABLE
++ /data/cal/badpixel.3.tfits CCD_TABLE
++
++For an concrete example for a specific instrument, check the documentation for that
++instrument.
++
diff --git a/sci-astronomy/esorex/files/esorex-3.10-remove-empty-configdir.patch b/sci-astronomy/esorex/files/esorex-3.10-remove-empty-configdir.patch
new file mode 100644
index 000000000000..d492173da8eb
--- /dev/null
+++ b/sci-astronomy/esorex/files/esorex-3.10-remove-empty-configdir.patch
@@ -0,0 +1,13 @@
+Author: Ole Streicher <debian@liska.ath.cx>
+Description: Avoid creation of an empty directory "/usr/share/esorex/config"
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -51,8 +51,6 @@
+
+ bin_PROGRAMS = esorex
+
+-config_DATA =
+-
+ esorex_LDFLAGS = $(CPL_LDFLAGS) $(LIBLTDL)
+ esorex_LDADD = @GETOPT@ $(LIBCPLDFS) $(LIBCPLUI) $(LIBCPLCORE) $(LIBCEXT) $(LIBLTDL)
+ esorex_DEPENDENCIES = @GETOPT@ $(LIBLTDL)
diff --git a/sci-astronomy/esorex/files/esorex-3.10-remove-private-ltdl.patch b/sci-astronomy/esorex/files/esorex-3.10-remove-private-ltdl.patch
new file mode 100644
index 000000000000..e675cdbb8f73
--- /dev/null
+++ b/sci-astronomy/esorex/files/esorex-3.10-remove-private-ltdl.patch
@@ -0,0 +1,39 @@
+Author: Ole Streicher <debian@liska.ath.cx>
+Subject: Remove private library libltdl and use the installed one.
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -37,10 +37,7 @@
+ if MAINTAINER_MODE
+
+ MAINTAINERCLEANFILES = $(top_srcdir)/Makefile.in $(top_srcdir)/aclocal.m4 \
+- $(top_srcdir)/config.h.in $(top_srcdir)/configure config.status config.log \
+- $(top_srcdir)/libltdl/Makefile.in $(top_srcdir)/libltdl/aclocal.m4 \
+- $(top_srcdir)/libltdl/config-h.in $(top_srcdir)/libltdl/configure \
+- libltdl/config.status libltdl/config.log
++ $(top_srcdir)/config.h.in $(top_srcdir)/configure config.status config.log
+
+ clean-local: clean-doxygen
+
+--- a/configure.ac
++++ b/configure.ac
+@@ -30,7 +30,9 @@
+
+ ESO_CHECK_DOCTOOLS
+
+-AC_LIBLTDL_CONVENIENCE
++LT_INIT
++LT_CONFIG_LTDL_DIR([libltdl])
++AC_LIB_LTDL
+ AC_SUBST(INCLTDL)
+ AC_SUBST(LIBLTDL)
+
+@@ -76,9 +78,6 @@
+ # Determine the shared library suffix on this platform
+ AC_LTDL_SHLIBEXT
+
+-
+-AC_CONFIG_SUBDIRS(libltdl)
+-
+ AC_CONFIG_FILES(Makefile
+ Makefile.purify
+ doxygen/Doxyfile
diff --git a/sci-astronomy/esorex/files/esorex-3.10-set-default-plugin-path.patch b/sci-astronomy/esorex/files/esorex-3.10-set-default-plugin-path.patch
new file mode 100644
index 000000000000..1289bed5ab0d
--- /dev/null
+++ b/sci-astronomy/esorex/files/esorex-3.10-set-default-plugin-path.patch
@@ -0,0 +1,28 @@
+Author: Ole Streicher <debian@liska.ath.cx>
+Description: Set the default plugin path to the one where recipes are
+ installed in Debian.
+--- a/etc/esorex.rc.in
++++ b/etc/esorex.rc.in
+@@ -130,7 +130,7 @@
+ # as well. Multiple directory heads may be specified, by separating the
+ # starting paths with colons (:). This option may also be set using the
+ # environment variable ESOREX_PLUGIN_DIR.
+-esorex.caller.recipe-dir=@recipedir@/esopipes-plugins
++esorex.caller.recipe-dir=@recipedir@
+
+ # --suppress-link
+ # When TRUE, no symbolic link is created to the output product. However, if
+--- a/acinclude.m4
++++ b/acinclude.m4
+@@ -35,7 +35,10 @@
+ AC_SUBST(configdir)
+
+ if test -z "$recipedir"; then
+- recipedir="`eval echo $libdir`"
++ recipedir="`eval echo $libdir`/cpl/plugins"
++ if test $libdir != "/usr/lib"; then
++ recipedir="$recipedir:/usr/lib/cpl/plugins"
++ fi
+ fi
+ AC_SUBST(recipedir)
+
diff --git a/sci-astronomy/esorex/files/esorex-3.9.6-use-shared-libs.patch b/sci-astronomy/esorex/files/esorex-3.9.6-use-shared-libs.patch
new file mode 100644
index 000000000000..0cd348eaa446
--- /dev/null
+++ b/sci-astronomy/esorex/files/esorex-3.9.6-use-shared-libs.patch
@@ -0,0 +1,20 @@
+--- esorex-3.9.6/m4/cpl.m4.orig 2012-06-04 23:47:50.000000000 +0100
++++ esorex-3.9.6/m4/cpl.m4 2012-06-04 23:48:45.000000000 +0100
+@@ -455,7 +455,7 @@
+ AC_MSG_CHECKING([for libcext])
+
+ cpl_cext_check_header="cxtypes.h"
+- cpl_cext_check_lib="libcext.a"
++ cpl_cext_check_lib="libcext.so"
+
+ cpl_cext_incdirs=""
+ cpl_cext_libdirs=""
+@@ -1314,7 +1314,7 @@
+ AC_MSG_CHECKING([for CPL])
+
+ cpl_check_cpl_header="cpl.h"
+- cpl_check_cpl_lib="libcplcore.a"
++ cpl_check_cpl_lib="libcplcore.so"
+
+ cpl_incdirs=""
+ cpl_libdirs=""