summaryrefslogtreecommitdiff
path: root/sci-astronomy/celestia/celestia-1.7.0_pre20220120.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /sci-astronomy/celestia/celestia-1.7.0_pre20220120.ebuild
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'sci-astronomy/celestia/celestia-1.7.0_pre20220120.ebuild')
-rw-r--r--sci-astronomy/celestia/celestia-1.7.0_pre20220120.ebuild124
1 files changed, 124 insertions, 0 deletions
diff --git a/sci-astronomy/celestia/celestia-1.7.0_pre20220120.ebuild b/sci-astronomy/celestia/celestia-1.7.0_pre20220120.ebuild
new file mode 100644
index 000000000000..63864b39236b
--- /dev/null
+++ b/sci-astronomy/celestia/celestia-1.7.0_pre20220120.ebuild
@@ -0,0 +1,124 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+CMAKE_IN_SOURCE_BUILD="yes"
+LUA_COMPAT=( lua5-{1..3} luajit )
+
+inherit desktop flag-o-matic lua-single xdg cmake
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/CelestiaProject/Celestia.git"
+ inherit git-r3
+else
+ if [[ ${PV} == *_p* ]] ; then
+ COMMIT_ID="f969b37c3ee783ed51bf4d1cbeefca4132031316"
+ COMMIT_ID_DATA="cc0bc0bb4b77e47115a31fbeb42babb30da3b790"
+ SRC_URI="
+ https://github.com/${PN^}Project/${PN^}/archive/${COMMIT_ID}.tar.gz -> ${P}.tar.gz
+ https://github.com/${PN^}Project/${PN^}Content/archive/${COMMIT_ID_DATA}.tar.gz -> ${P}-data.tar.gz
+ "
+ S="${WORKDIR}/${PN^}-${COMMIT_ID}"
+ KEYWORDS="~amd64 ~x86"
+ else
+ SRC_URI="https://github.com/${PN^}Project/${PN^}/archive/${PV/_/-}.tar.gz -> ${P}.tar.gz"
+ fi
+fi
+
+DESCRIPTION="OpenGL 3D space simulator"
+HOMEPAGE="https://celestia.space"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="ffmpeg glut lua nls +qt5"
+REQUIRED_USE="|| ( glut qt5 )
+ lua? ( ${LUA_REQUIRED_USE} )"
+
+BDEPEND="
+ dev-cpp/eigen
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )
+"
+DEPEND="
+ dev-libs/libfmt:=
+ media-libs/glew:0=
+ media-libs/libepoxy
+ media-libs/libpng:0=
+ sys-libs/zlib:=
+ virtual/glu
+ virtual/jpeg:0
+ virtual/opengl
+ ffmpeg? ( media-video/ffmpeg:0 )
+ glut? ( media-libs/freeglut )
+ lua? ( ${LUA_DEPS} )
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtopengl:5
+ dev-qt/qtwidgets:5
+ )
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ # add a ~/.celestia for extra directories
+ "${FILESDIR}"/${PN}-1.6.99-cfg.patch
+ # allow forcing CMake to look for a specific Lua version instead of the newest branch installed
+ "${FILESDIR}"/${PN}-1.7.0-cmake_lua_version.patch
+)
+
+src_prepare() {
+ mv "${WORKDIR}"/CelestiaContent-${COMMIT_ID_DATA} content || die
+
+ cmake_src_prepare
+ ### This version of Celestia has a bug in the font rendering and
+ ### requires -fsigned-char. We should be able to force this flag
+ ### on all architectures. See bug #316573.
+ # FIXME: Point to upstream bug report if still valid
+ #append-flags "-fsigned-char"
+}
+
+src_configure() {
+ CMAKE_USE_DIR="${CMAKE_USE_DIR}/content" BUILD_DIR="${BUILD_DIR}/content" \
+ cmake_src_configure
+
+ local mycmakeargs=(
+ -DENABLE_CELX="$(usex lua)"
+ -DENABLE_NLS="$(usex nls)"
+ -DENABLE_FFMPEG="$(usex ffmpeg)"
+ -DENABLE_GLUT="$(usex glut)"
+ -DENABLE_GTK=OFF
+ -DENABLE_QT="$(usex qt5)"
+ -DENABLE_WIN=OFF
+ -DENABLE_SDL=OFF
+ )
+ # Upstream always looks for LuaJIT first unless stopped, and we only need
+ # the version specification when linking against PUC Lua
+ if use lua && ! use lua_single_target_luajit; then
+ mycmakeargs+=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_LuaJIT=ON
+ -DLUA_VERSION=$(lua_get_version)
+ )
+ fi
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+ CMAKE_USE_DIR="${CMAKE_USE_DIR}/content" BUILD_DIR="${BUILD_DIR}/content" cmake_src_compile
+}
+
+src_install() {
+ cmake_src_install
+
+ doicon -s 48 "${S}"/src/celestia/gtk/data/${PN}.png
+ newicon -s 128 "${S}"/src/celestia/gtk/data/${PN}-logo.png ${PN}.png
+ doicon -s scalable "${S}"/src/celestia/gtk/data/${PN}.svg
+
+ use glut && domenu "${S}"/debian/${PN}-glut.desktop
+ use qt5 && domenu "${S}"/debian//${PN}-qt.desktop
+
+ dodoc AUTHORS README TRANSLATORS *.txt
+
+ CMAKE_USE_DIR="${CMAKE_USE_DIR}/content" BUILD_DIR="${BUILD_DIR}/content" cmake_src_install
+}