summaryrefslogtreecommitdiff
path: root/sci-astronomy/aatm
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-astronomy/aatm
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-astronomy/aatm')
-rw-r--r--sci-astronomy/aatm/Manifest5
-rw-r--r--sci-astronomy/aatm/aatm-0.6.ebuild39
-rw-r--r--sci-astronomy/aatm/metadata.xml18
3 files changed, 62 insertions, 0 deletions
diff --git a/sci-astronomy/aatm/Manifest b/sci-astronomy/aatm/Manifest
new file mode 100644
index 000000000000..903f34eafc05
--- /dev/null
+++ b/sci-astronomy/aatm/Manifest
@@ -0,0 +1,5 @@
+DIST aatm-0.6.tar.gz 613800 SHA256 9fdfb7d0bba71ad32c091baf6242a5bd17041277016473959c5e90d6dcac1b68 SHA512 aef2d0fccc83a8a5817bd414b60c5167f7e378b434f9a3e9ce2bc2eeceec1cc1fb1b141cec07d78cb325dbfceac2804c07866291b2863f6839dfb6143ed9188a WHIRLPOOL 1d8fff78f72810b53f86452a930701d7910314dbd06d0060a7e677260bd29526de44e2b8658c584fd9692727af02a5ee918b319e8932be1cfe428fc579e520d0
+EBUILD aatm-0.6.ebuild 846 SHA256 70966a8917caf62c4063a3ff49ecbbafec80cafe53a5e5df8969ac5b0faddc32 SHA512 4e0440eccdbb80de3304b068f49156fad12b5b1445af4ceb39cde6b37572442475ac5e0ac591da826279308c361c9aa3e5b126c1afd0e4d82d5ec2418ef899c1 WHIRLPOOL 325fc9ab568bc85a98667aea5dd8f077b1806ecaaae1abb4eef43914666eb5b2bed242c1c15f277d77d18cee26e38dc84fd9b22848fb3f256624c57a1c6e6053
+MISC ChangeLog 2810 SHA256 bb7aaf530b006fc98d4e092dc7a3df3e32231365e65972d259d5833b29b59519 SHA512 663bbf7e07f3bd9d3e96e3b7d8490caca535b7fb36f38fce11251d3b38adcd02f76e76f9fb550545c31f7c40dc358c8af20762d6d711f7774bc6e258861d3546 WHIRLPOOL d4c90628ee6d0efef176409e5511dc528f508bcb7e5ee17c5b2480ea365918fe21e0d8b43ea7be6e21b15780ad76148fc5c1eda08264e051de0cb5e59c492394
+MISC ChangeLog-2015 455 SHA256 3c958a67838866f8ea7b985945478ef45a7c480180e1596209592726eda908ca SHA512 4a670eab4b3fb719c473fe69e49266ef4335132ed4913c22534dc6e5be00ccf92fe3fb5a191169165caf3a07e1e5c5bce134e32e0d8470935ea543be3e664a83 WHIRLPOOL 7177ab53cc7298b8710c217cb17a59aead00940ec2732bf3a5de8799ebf707d5c9afe4062a4695fbccb39cf5115767f6feb8200b8a71798430dddfddbfd88be9
+MISC metadata.xml 712 SHA256 3697e5298c72cf90ffdc4ef933efff7f176dbd7bae9eb6ac51680b2170245dfd SHA512 8c8a2c82a2355eb3c2370381a9964ddcf2e80ee367f4c02925f9ef96f6ca4e93bb0650c42d94ef28ddcf52f1a1d8a4902d688c1f183e0ac1d648fb99274a8735 WHIRLPOOL 4ef1deb4a041bc3317756ec48d6c9ba4a16e74eb8eaebd13e598b34603a64a6010e841ad5dab65bb5a9af82f806585f4b51c70562a08181ea024973d57fdca65
diff --git a/sci-astronomy/aatm/aatm-0.6.ebuild b/sci-astronomy/aatm/aatm-0.6.ebuild
new file mode 100644
index 000000000000..d1fddc1c7e8e
--- /dev/null
+++ b/sci-astronomy/aatm/aatm-0.6.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils
+
+DESCRIPTION="Atmospheric Modelling for ALMA Observatory"
+HOMEPAGE="https://svn.cv.nrao.edu/view/aatm/devel/casa/"
+# tar ball is made from the HOMEPAGE and running ./configure && make dist
+SRC_URI="https://dev.gentoo.org/~bicatali/distfiles/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/4"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc static-libs"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-libs/boost:=
+ doc? ( app-doc/doxygen[dot] )"
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_compile() {
+ emake
+ use doc && doxygen doc/developer.doxy
+}
+
+src_install() {
+ default
+ use static-libs || prune_libtool_files --all
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins -r developer/html
+ fi
+}
diff --git a/sci-astronomy/aatm/metadata.xml b/sci-astronomy/aatm/metadata.xml
new file mode 100644
index 000000000000..658a3f257bb7
--- /dev/null
+++ b/sci-astronomy/aatm/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci-astronomy@gentoo.org</email>
+ <name>Gentoo Astronomy Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ ATmospheric Modeling for ALMA is a library of routines for modelling
+ transmission of cm/mm/sub-mm wavelength radiation through the Earths
+ atmosphere. It is designed to simulate both the absorption/emission
+ of radiation and the dispersion (i.e., the frequency dependent
+ refractive index of the atmosphere).
+</longdescription>
+ <upstream>
+ <remote-id type="launchpad">aatm</remote-id>
+ </upstream>
+</pkgmetadata>