summaryrefslogtreecommitdiff
path: root/sci-astronomy/aatm/aatm-0.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-astronomy/aatm/aatm-0.6.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-astronomy/aatm/aatm-0.6.ebuild')
-rw-r--r--sci-astronomy/aatm/aatm-0.6.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/sci-astronomy/aatm/aatm-0.6.ebuild b/sci-astronomy/aatm/aatm-0.6.ebuild
new file mode 100644
index 000000000000..d1fddc1c7e8e
--- /dev/null
+++ b/sci-astronomy/aatm/aatm-0.6.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils
+
+DESCRIPTION="Atmospheric Modelling for ALMA Observatory"
+HOMEPAGE="https://svn.cv.nrao.edu/view/aatm/devel/casa/"
+# tar ball is made from the HOMEPAGE and running ./configure && make dist
+SRC_URI="https://dev.gentoo.org/~bicatali/distfiles/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/4"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc static-libs"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-libs/boost:=
+ doc? ( app-doc/doxygen[dot] )"
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_compile() {
+ emake
+ use doc && doxygen doc/developer.doxy
+}
+
+src_install() {
+ default
+ use static-libs || prune_libtool_files --all
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins -r developer/html
+ fi
+}