summaryrefslogtreecommitdiff
path: root/ros-meta/slam_gmapping
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /ros-meta/slam_gmapping
reinit the tree, so we can have metadata
Diffstat (limited to 'ros-meta/slam_gmapping')
-rw-r--r--ros-meta/slam_gmapping/Manifest5
-rw-r--r--ros-meta/slam_gmapping/metadata.xml11
-rw-r--r--ros-meta/slam_gmapping/slam_gmapping-1.3.8.ebuild17
-rw-r--r--ros-meta/slam_gmapping/slam_gmapping-9999.ebuild17
4 files changed, 50 insertions, 0 deletions
diff --git a/ros-meta/slam_gmapping/Manifest b/ros-meta/slam_gmapping/Manifest
new file mode 100644
index 000000000000..869a9c0ce766
--- /dev/null
+++ b/ros-meta/slam_gmapping/Manifest
@@ -0,0 +1,5 @@
+DIST slam_gmapping-1.3.8.tar.gz 20533 SHA256 027e31fbe6d8768a746b0eeb93238459b295b15efc0f43f9410afc57d71385d1 SHA512 d7b054296f286a5e61e5f952a29ccff2165503123ab6a89724ec34180fb0f4c452fc0ae81ec853cac170b304095e62cef420431e5aca85a262febc2b5ab5ccf2 WHIRLPOOL ced3e8b2c1f3887afd6df6ea780d3a9a111b29f20db0dedf6af497737e9b2f7c089ce3f673ba309262271c2741a1b73474c2412bbe89c84937c706bad0d95b15
+EBUILD slam_gmapping-1.3.8.ebuild 370 SHA256 f66b6f20b7ac3434c19d4d2f38c57b721b9c3ba538e90d1b503343ab6683db8f SHA512 e33e8c784dfc0047f686c399545175d5ef0bda60bdd00d3beb25153b2f38c3972b7f524637396b1857c7d27ee527bf256730b4040b75dad1d27f6e0e47288257 WHIRLPOOL 0ed4745d56ad348426e2b616049d0218f5a9f663a2e246a1c3c2da6717b516dee9d214385a633fabf02a52bb9e8690ea4c1e6e73d1a2f0536fa7f6cbf9ed1174
+EBUILD slam_gmapping-9999.ebuild 370 SHA256 f66b6f20b7ac3434c19d4d2f38c57b721b9c3ba538e90d1b503343ab6683db8f SHA512 e33e8c784dfc0047f686c399545175d5ef0bda60bdd00d3beb25153b2f38c3972b7f524637396b1857c7d27ee527bf256730b4040b75dad1d27f6e0e47288257 WHIRLPOOL 0ed4745d56ad348426e2b616049d0218f5a9f663a2e246a1c3c2da6717b516dee9d214385a633fabf02a52bb9e8690ea4c1e6e73d1a2f0536fa7f6cbf9ed1174
+MISC ChangeLog 1308 SHA256 7d079d883a600ea093094b0d2fc962ca840bce03a00a0ddd51ddae2e0bc0c8dd SHA512 60509638831ae853758460631e96bd3c81c5c5a0771ab3daa854959f73f8ace0a65f061629d2f11fc8096031a3bcd0577626b746ba323a38a3fd74d0bb885b5a WHIRLPOOL a799aecf692133bca90498b6d20037db89f38de324c387bfbfbb008bf6358dc056ce7df55c59d3e1b4b4aa8ba359d165df88da9f9946f4572e1c5a6eeb92f13c
+MISC metadata.xml 342 SHA256 ebb581e87be9c72c6de396c597ff6c586884626f4d00fd461fb1253464b586ba SHA512 2a5beef664e8c79b9e4d858d0dc093068c6e462456ae6066ea637f4b725e5c7184dd65769906c34e55eb6b03949e957edba34b84a587e1daec784e1f74ea287c WHIRLPOOL 85164a9d14d47128903fc36c818da15d46484dceb573efeeed27d7c6796fa5b59a39848493a4cc0297ef746a57941c629b7de563e6b22db1fa29048027ade81a
diff --git a/ros-meta/slam_gmapping/metadata.xml b/ros-meta/slam_gmapping/metadata.xml
new file mode 100644
index 000000000000..a45ed347785d
--- /dev/null
+++ b/ros-meta/slam_gmapping/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ros@gentoo.org</email>
+ <name>Gentoo ROS Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ros-perception/slam_gmapping</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/ros-meta/slam_gmapping/slam_gmapping-1.3.8.ebuild b/ros-meta/slam_gmapping/slam_gmapping-1.3.8.ebuild
new file mode 100644
index 000000000000..f976426e281e
--- /dev/null
+++ b/ros-meta/slam_gmapping/slam_gmapping-1.3.8.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/slam_gmapping"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="ROS wrapper for OpenSlam's Gmapping"
+LICENSE="CC-BY-NC-SA-2.5"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-ros/gmapping"
+DEPEND=""
diff --git a/ros-meta/slam_gmapping/slam_gmapping-9999.ebuild b/ros-meta/slam_gmapping/slam_gmapping-9999.ebuild
new file mode 100644
index 000000000000..f976426e281e
--- /dev/null
+++ b/ros-meta/slam_gmapping/slam_gmapping-9999.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/slam_gmapping"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="ROS wrapper for OpenSlam's Gmapping"
+LICENSE="CC-BY-NC-SA-2.5"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-ros/gmapping"
+DEPEND=""