summaryrefslogtreecommitdiff
path: root/ros-meta/roscpp_core/roscpp_core-0.6.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-11-10 00:43:02 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-11-10 00:43:02 +0000
commita5332b59346f7cbf0fdbd148b54aa8a84aaf8190 (patch)
treee6d8d3589fcd01fbc3f1286185639163daa81424 /ros-meta/roscpp_core/roscpp_core-0.6.7.ebuild
parentfceeaf01a28ee71065cf3798b70b77d3bc4ef199 (diff)
gentoo resync : 10.11.2017
Diffstat (limited to 'ros-meta/roscpp_core/roscpp_core-0.6.7.ebuild')
-rw-r--r--ros-meta/roscpp_core/roscpp_core-0.6.7.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/ros-meta/roscpp_core/roscpp_core-0.6.7.ebuild b/ros-meta/roscpp_core/roscpp_core-0.6.7.ebuild
new file mode 100644
index 000000000000..cc4bce1ba508
--- /dev/null
+++ b/ros-meta/roscpp_core/roscpp_core-0.6.7.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/roscpp_core"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Underlying data libraries for roscpp messages"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/cpp_common
+ dev-ros/rostime
+ dev-ros/roscpp_traits
+ dev-ros/roscpp_serialization
+"
+DEPEND="${RDEPEND}"