summaryrefslogtreecommitdiff
path: root/ros-meta/roscpp_core/roscpp_core-0.6.13.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /ros-meta/roscpp_core/roscpp_core-0.6.13.ebuild
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'ros-meta/roscpp_core/roscpp_core-0.6.13.ebuild')
-rw-r--r--ros-meta/roscpp_core/roscpp_core-0.6.13.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/ros-meta/roscpp_core/roscpp_core-0.6.13.ebuild b/ros-meta/roscpp_core/roscpp_core-0.6.13.ebuild
new file mode 100644
index 000000000000..492035ffee5a
--- /dev/null
+++ b/ros-meta/roscpp_core/roscpp_core-0.6.13.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/roscpp_core"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Underlying data libraries for roscpp messages"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/cpp_common
+ dev-ros/rostime
+ dev-ros/roscpp_traits
+ dev-ros/roscpp_serialization
+"
+DEPEND="${RDEPEND}"