summaryrefslogtreecommitdiff
path: root/ros-meta/ros_core/ros_core-1.5.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /ros-meta/ros_core/ros_core-1.5.0.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'ros-meta/ros_core/ros_core-1.5.0.ebuild')
-rw-r--r--ros-meta/ros_core/ros_core-1.5.0.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/ros-meta/ros_core/ros_core-1.5.0.ebuild b/ros-meta/ros_core/ros_core-1.5.0.ebuild
new file mode 100644
index 000000000000..95322c7b9c10
--- /dev/null
+++ b/ros-meta/ros_core/ros_core-1.5.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ROS_REPO_URI="https://github.com/ros/metapackages"
+KEYWORDS="~amd64"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Metapackage to aggregate the packages required to use core ROS concepts"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-util/catkin
+ dev-ros/class_loader
+ dev-ros/cmake_modules
+ ros-meta/common_msgs
+ dev-ros/gencpp
+ dev-ros/geneus
+ dev-ros/genlisp
+ dev-ros/genmsg
+ dev-ros/gennodejs
+ dev-ros/genpy
+ dev-ros/message_generation
+ dev-ros/message_runtime
+ dev-ros/pluginlib
+ ros-meta/ros
+ ros-meta/ros_comm
+ dev-ros/rosbag_migration_rule
+ dev-ros/rosconsole
+ dev-ros/rosconsole_bridge
+ ros-meta/roscpp_core
+ dev-ros/rosgraph_msgs
+ dev-ros/roslisp
+ dev-ros/rospack
+ dev-ros/std_msgs
+ dev-ros/std_srvs
+"
+DEPEND="${RDEPEND}"