summaryrefslogtreecommitdiff
path: root/ros-meta/robot/robot-1.3.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-07 13:16:39 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-07 13:16:39 +0100
commite91a1aaa5ec8fab37f0fd082ac6024d41c6651e2 (patch)
treeee7587dfd365faadd9b297d595c31368bf94f9ca /ros-meta/robot/robot-1.3.2.ebuild
parent2d446203bcf1a0db08e99abca43513d246dfa73d (diff)
gentoo resync : 07.04.2018
Diffstat (limited to 'ros-meta/robot/robot-1.3.2.ebuild')
-rw-r--r--ros-meta/robot/robot-1.3.2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/ros-meta/robot/robot-1.3.2.ebuild b/ros-meta/robot/robot-1.3.2.ebuild
new file mode 100644
index 000000000000..3762fd95629e
--- /dev/null
+++ b/ros-meta/robot/robot-1.3.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/metapackages"
+KEYWORDS="~amd64"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Metapackage which extends ros_base and includes ROS libaries for any robot hardware"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ ros-meta/ros_base
+ dev-ros/control_msgs
+ ros-meta/diagnostics
+ ros-meta/executive_smach
+ dev-ros/filters
+ ros-meta/geometry
+ dev-ros/joint_state_publisher
+ dev-ros/kdl_parser
+ dev-ros/kdl_parser_py
+ dev-ros/robot_state_publisher
+ dev-ros/urdf
+ dev-ros/urdf_parser_plugin
+ dev-ros/xacro
+"
+DEPEND="${RDEPEND}"