summaryrefslogtreecommitdiff
path: root/ros-meta/audio_common/audio_common-0.3.11.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-04 22:28:33 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-04 22:28:33 +0100
commita978c074e4272bb901fbe4a10de0a7b2af574f17 (patch)
tree8c764c1cc0576389ce22abd317bceba71ea5732d /ros-meta/audio_common/audio_common-0.3.11.ebuild
parent40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (diff)
gentoo resync : 04.05.2021
Diffstat (limited to 'ros-meta/audio_common/audio_common-0.3.11.ebuild')
-rw-r--r--ros-meta/audio_common/audio_common-0.3.11.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/ros-meta/audio_common/audio_common-0.3.11.ebuild b/ros-meta/audio_common/audio_common-0.3.11.ebuild
new file mode 100644
index 000000000000..9eb443937326
--- /dev/null
+++ b/ros-meta/audio_common/audio_common-0.3.11.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/ros-drivers/audio_common"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Common code for working with audio in ROS"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/audio_capture
+ dev-ros/audio_common_msgs
+ dev-ros/audio_play
+"
+# dev-ros/sound_play
+# https://bugs.gentoo.org/612980#c14
+
+DEPEND="${RDEPEND}"