summaryrefslogtreecommitdiff
path: root/profiles/features
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /profiles/features
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'profiles/features')
-rw-r--r--profiles/features/prefix/package.use.mask8
-rw-r--r--profiles/features/prefix/standalone/kernel-2.6.16+/profile.bashrc10
-rw-r--r--profiles/features/selinux/package.use.force3
-rw-r--r--profiles/features/selinux/package.use.mask7
4 files changed, 28 insertions, 0 deletions
diff --git a/profiles/features/prefix/package.use.mask b/profiles/features/prefix/package.use.mask
index 07d83215aa7c..37eb627c3988 100644
--- a/profiles/features/prefix/package.use.mask
+++ b/profiles/features/prefix/package.use.mask
@@ -1,6 +1,14 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
+# Fabian Groffen <grobian@gentoo.org> (2020-10-15)
+# Requires PAM
+x11-base/xorg-server elogind
+
+# Georgy Yakovlev <gyakovlev@gentoo.org> (2020-10-21)
+# depends on systemd
+sys-apps/ipmitool openbmc
+
# Benda Xu <heroxbd@gentoo.org> (2019-08-20)
# avoid gnome-extra/gnome-user-share, which depends on systemd.
gnome-base/gnome-extra-apps share
diff --git a/profiles/features/prefix/standalone/kernel-2.6.16+/profile.bashrc b/profiles/features/prefix/standalone/kernel-2.6.16+/profile.bashrc
index dad9dcbc5852..6370f687cad2 100644
--- a/profiles/features/prefix/standalone/kernel-2.6.16+/profile.bashrc
+++ b/profiles/features/prefix/standalone/kernel-2.6.16+/profile.bashrc
@@ -3,6 +3,10 @@
if [[ ${CATEGORY}/${PN} == dev-util/cmake && ${EBUILD_PHASE} == configure ]]; then
einfo "Removing utimensat outputs..."
sed -e '/UTIMENSAT=/d' -i "${S}"/Source/kwsys/CMakeLists.txt || die
+elif [[ ${CATEGORY}/${PN} == dev-libs/libuv && ${EBUILD_PHASE} == prepare ]]; then
+ einfo "Removing CLOEXEC related functions..."
+ sed -e 's/defined(__FreeBSD__) || defined(__linux__)/0/' \
+ -i "${S}"/src/unix/process.c || die
elif [[ ${CATEGORY}/${PN} == dev-qt/qtcore && ${EBUILD_PHASE} == configure ]]; then
einfo "Removing pipe2 definitions..."
sed -e '/define.*HAVE_PIPE2/d' -i "${S}"/src/3rdparty/forkfd/forkfd.c || die
@@ -14,6 +18,12 @@ elif [[ ${CATEGORY}/${PN} == dev-qt/qtcore && ${EBUILD_PHASE} == configure ]]; t
elif [[ ${CATEGORY}/${PN} == dev-lang/ocaml && ${EBUILD_PHASE} == configure ]]; then
einfo "Removing dup3 and pipe2 definitions..."
sed -e '/hasgot dup3/,/^fi/d;/hasgot pipe2/,/^fi/d' -i "${S}"/configure || die
+elif [[ ${CATEGORY}/${PN} == sys-apps/util-linux && ${EBUILD_PHASE} == configure ]]; then
+ einfo "Removing CLOEXEC related functions..."
+ sed -r -e 's/inotify_init1\(.*\)/inotify_init\(\)/' \
+ -e '/open\(/s/\| *O_CLOEXEC//' \
+ -e 's/epoll_create1\(EPOLL_CLOEXEC/epoll_create\(1/' \
+ -i "${S}"/libmount/src/monitor.c || die
fi
# Local Variables:
diff --git a/profiles/features/selinux/package.use.force b/profiles/features/selinux/package.use.force
index fec892c60b07..f368891a801f 100644
--- a/profiles/features/selinux/package.use.force
+++ b/profiles/features/selinux/package.use.force
@@ -17,3 +17,6 @@ dev-lang/python xml
# so stages can build with no interacton. Bug #527938
sys-libs/libselinux static-libs
dev-libs/libpcre static-libs
+
+# Required for semanage to run correctly.
+sys-process/audit python
diff --git a/profiles/features/selinux/package.use.mask b/profiles/features/selinux/package.use.mask
index e6c43f72558b..a22be1217f05 100644
--- a/profiles/features/selinux/package.use.mask
+++ b/profiles/features/selinux/package.use.mask
@@ -1,6 +1,10 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
+# Georgy Yakovlev <gyakovlev@gentoo.org> (2020-10-21)
+# requires systemd, as OpenBMC uses sd-dbus for communication
+sys-apps/ipmitool openbmc
+
# Jeroen Roovers <jer@gentoo.org> (2019-02-23)
# sdjournal links against sys-apps/systemd's libraries
net-analyzer/wireshark sdjournal
@@ -8,7 +12,10 @@ net-analyzer/wireshark sdjournal
# Brian Dolbec <dolsen@gentoo.org> (2014-09-17)
# mask pypy for several utilities due to incompatibility with libselinux
sys-apps/portage python_targets_pypy3
+app-portage/elogv python_targets_pypy3
app-portage/gentoolkit python_targets_pypy3
+app-portage/layman python_targets_pypy3
+app-portage/repoman python_targets_pypy3
# Jason Zaman <perfinion@gentoo.org> (2015-06-27)
# SystemD has no support in the SELinux policy at the moment.