summaryrefslogtreecommitdiff
path: root/perl-core
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-01 00:00:05 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-01 00:00:05 +0100
commit3d12b65aa1b4bb8b02b1f8d3e77bccf230b79a09 (patch)
treecb6347688c91bfbdebe49a78a55dad3d72cc193e /perl-core
parent4c2b70adc6484c35ff05e412de08a7b7f50cfb34 (diff)
gentoo auto-resync : 01:05:2024 - 00:00:04
Diffstat (limited to 'perl-core')
-rw-r--r--perl-core/File-Temp/File-Temp-0.231.100-r1.ebuild21
-rw-r--r--perl-core/File-Temp/Manifest2
-rw-r--r--perl-core/File-Temp/files/File-Temp-0.231.100-pathconf-_PC_CHOWN_RESTRICTED.patch68
-rw-r--r--perl-core/Manifest.gzbin2259 -> 2260 bytes
4 files changed, 91 insertions, 0 deletions
diff --git a/perl-core/File-Temp/File-Temp-0.231.100-r1.ebuild b/perl-core/File-Temp/File-Temp-0.231.100-r1.ebuild
new file mode 100644
index 000000000000..627209aa0edb
--- /dev/null
+++ b/perl-core/File-Temp/File-Temp-0.231.100-r1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=ETHER
+DIST_VERSION=0.2311
+inherit perl-module
+
+DESCRIPTION="File::Temp can be used to create and open temporary files in a safe way"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE=""
+
+PATCHES=(
+ # bug #390719
+ "${FILESDIR}/${PN}-0.230.0-symlink-safety.patch"
+ # bug #930949
+ "${FILESDIR}/${PN}-0.231.100-pathconf-_PC_CHOWN_RESTRICTED.patch"
+)
diff --git a/perl-core/File-Temp/Manifest b/perl-core/File-Temp/Manifest
index b21d057b2a62..61ed73b05b5c 100644
--- a/perl-core/File-Temp/Manifest
+++ b/perl-core/File-Temp/Manifest
@@ -1,4 +1,6 @@
AUX File-Temp-0.230.0-symlink-safety.patch 1120 BLAKE2B f12300564dc761ae438ebef6260858219bbd2de3400cdaae3933826c62bedac9593cb602f923e8bfbd7d6cd0926eabd90a7d09a699792aee5cd5c8e9d5bce710 SHA512 273fe8f86b8ddc91224c84091f6c37396d1c116dc0c6d97162945955ecdd605c884971c24cd260be18ea7a412c8b9c2b2737026182cd7bf97040e648480d0e48
+AUX File-Temp-0.231.100-pathconf-_PC_CHOWN_RESTRICTED.patch 2676 BLAKE2B f1682df296a395817883a70a94d069464055e063a9ba89dd9a1d22865acb2d132bef5fcf8ceb880d7de12f982c529252f1a87e5b3a3420f5f9826f543018d6fd SHA512 d9511dd50853e5b1faad7989cb37d9fd952eb8b40adf2555b7ebe687f5f8ca9123b7a1557add095cb2fdee40c6cd7c5a2cca944327350592350926f23445b118
DIST File-Temp-0.2311.tar.gz 76988 BLAKE2B d867a5c391fb8bdf1534469ad67f3e122666fd857c3cabda67fcc216896159cb95b31a4885ee47c803e147fa246defc12608780e7814ede8e5662c8f8ffd3d0e SHA512 2db3f03f4d25013c60585cd3e6aa7e68fe9bb26f1957adf6674e9cae9e963a41c559d36862943703f567d116c82747b4fae0612253a784addeb53d7867a232d1
+EBUILD File-Temp-0.231.100-r1.ebuild 613 BLAKE2B 92ddf6d7a463a32dfaf07df86bea379efdd42b755d75d48a057a6af3acd9373a6e648396393af6eaca304bcc4037cbdb05992d5c419bb0fd096ead7c476b9603 SHA512 7063ede0a900565b9460b1503bcccf62a7d7211b65a37a56ce70f975c230f68015b96a9a50163ba69ca73f4b10fb6c0c9de4c319a79775868230d228eab58175
EBUILD File-Temp-0.231.100.ebuild 520 BLAKE2B 7245a755f2166fd83352e3d8c062518f838e06dfa19059d827c7638120f11abd4b75aed24f66b1352204afc02e3d44181d67453077d9222c1001f172641041ce SHA512 b1d6a5b597ef8b80bb941ed3c3eb52a8e5b0e3bb2558e77adad88007016080846a01a57ff5b8a1895bb3a14f6a43be71bb4e9b3b5b0b91eceba247f7b051eb4a
MISC metadata.xml 453 BLAKE2B f3ed0e78c9a72ae5f2eaf7e4ae7fd7052a2d087e11d84e4bc84154ffef98d7dd92953bb9655567c91e203598901e577fc0be096ec13b6b4adf0d0966dd0e8f2f SHA512 1e1e9195ed6c48b279a0d56d2ebc78c3e9345f2463fca28e784513d799f87c33720e78885b2a3cc24d094a757824ba7300d354e4e54e8abad399c80dede19c95
diff --git a/perl-core/File-Temp/files/File-Temp-0.231.100-pathconf-_PC_CHOWN_RESTRICTED.patch b/perl-core/File-Temp/files/File-Temp-0.231.100-pathconf-_PC_CHOWN_RESTRICTED.patch
new file mode 100644
index 000000000000..f8e56f8ae1c5
--- /dev/null
+++ b/perl-core/File-Temp/files/File-Temp-0.231.100-pathconf-_PC_CHOWN_RESTRICTED.patch
@@ -0,0 +1,68 @@
+https://bugs.gentoo.org/930949
+https://github.com/Perl-Toolchain-Gang/File-Temp/issues/36
+https://github.com/Perl-Toolchain-Gang/File-Temp/pull/41
+https://github.com/Perl/perl5/pull/22156
+https://github.com/Perl/perl5/pull/22161
+
+From 2de518ab67bf3c5be2525ea0a5d78f39de50074f Mon Sep 17 00:00:00 2001
+From: Lukas Mai <lukasmai.403@gmail.com>
+Date: Thu, 18 Apr 2024 20:12:06 +0200
+Subject: [PATCH] use pathconf() to get _PC_CHOWN_RESTRICTED flag
+
+The _PC_* constants are only meaningful in pathconf(); conversely,
+sysconf() only understands _SC_* constants.
+
+Previously, this code didn't do anything meaningful. For example, on x64
+Linux _PC_CHOWN_RESTRICTED is 6, which sysconf() would have interpreted
+as _SC_TZNAME_MAX (also 6).
+---
+ lib/File/Temp.pm | 16 +++++++---------
+ 2 files changed, 8 insertions(+), 10 deletions(-)
+
+diff --git a/lib/File/Temp.pm b/lib/File/Temp.pm
+index ef34f6c..563efeb 100644
+--- a/lib/File/Temp.pm
++++ b/lib/File/Temp.pm
+@@ -718,7 +718,7 @@ sub _is_safe {
+
+ # Internal routine to check whether a directory is safe
+ # for temp files. Safer than _is_safe since it checks for
+-# the possibility of chown giveaway and if that is a possibility
++# the possibility of chown giveaway and if that is a possibility,
+ # checks each directory in the path to see if it is safe (with _is_safe)
+
+ # If _PC_CHOWN_RESTRICTED is not set, does the full test of each
+@@ -737,18 +737,16 @@ sub _is_verysafe {
+
+ my $err_ref = shift;
+
+- # Should Get the value of _PC_CHOWN_RESTRICTED if it is defined
+- # and If it is not there do the extensive test
++ # Should get the value of _PC_CHOWN_RESTRICTED if it is defined
++ # and if it is not there, do the extensive test
+ local($@);
+- my $chown_restricted;
+- $chown_restricted = &POSIX::_PC_CHOWN_RESTRICTED()
+- if eval { &POSIX::_PC_CHOWN_RESTRICTED(); 1};
++ my $chown_restricted = eval { POSIX::_PC_CHOWN_RESTRICTED() };
+
+- # If chown_resticted is set to some value we should test it
++ # If chown_restricted is set to some value, we should test it
+ if (defined $chown_restricted) {
+
+ # Return if the current directory is safe
+- return _is_safe($path,$err_ref) if POSIX::sysconf( $chown_restricted );
++ return _is_safe($path, $err_ref) if POSIX::pathconf( $path, $chown_restricted );
+
+ }
+
+@@ -2367,7 +2365,7 @@ for sticky bit.
+
+ In addition to the MEDIUM security checks, also check for the
+ possibility of ``chown() giveaway'' using the L<POSIX|POSIX>
+-sysconf() function. If this is a possibility, each directory in the
++pathconf() function. If this is a possibility, each directory in the
+ path is checked in turn for safeness, recursively walking back to the
+ root directory.
+
+
diff --git a/perl-core/Manifest.gz b/perl-core/Manifest.gz
index b0d3cc9926f7..94f6f12fa6a4 100644
--- a/perl-core/Manifest.gz
+++ b/perl-core/Manifest.gz
Binary files differ