summaryrefslogtreecommitdiff
path: root/perl-core/Math-BigInt/Math-BigInt-1.999.838.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-19 11:08:38 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-19 11:08:38 +0100
commit66d92fc8569d87a09ac014780528dcad2a12b6c6 (patch)
treec2add83cecf7705c1634a143fe36eebd8c7f2805 /perl-core/Math-BigInt/Math-BigInt-1.999.838.ebuild
parentca517256fa4afe5b579e64e267ebbc7beb8a888f (diff)
gentoo auto-resync : 19:09:2023 - 11:08:38
Diffstat (limited to 'perl-core/Math-BigInt/Math-BigInt-1.999.838.ebuild')
-rw-r--r--perl-core/Math-BigInt/Math-BigInt-1.999.838.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/perl-core/Math-BigInt/Math-BigInt-1.999.838.ebuild b/perl-core/Math-BigInt/Math-BigInt-1.999.838.ebuild
new file mode 100644
index 000000000000..6fe0c305a5e8
--- /dev/null
+++ b/perl-core/Math-BigInt/Math-BigInt-1.999.838.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=PJACKLAM
+DIST_VERSION=1.999838
+DIST_EXAMPLES=("examples/*")
+inherit perl-module
+
+DESCRIPTION="Arbitrary size floating point math package"
+
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=virtual/perl-Carp-1.220.0
+ >=virtual/perl-Math-Complex-1.390.0
+"
+BDEPEND="
+ virtual/perl-ExtUtils-MakeMaker
+ test? ( >=virtual/perl-Test-Simple-0.940.0 )
+"
+# TODO: where does this come from?
+PDEPEND="
+ >=virtual/perl-Math-BigInt-FastCalc-0.500.600
+ >=virtual/perl-bignum-0.220.0
+ >=virtual/perl-Math-BigRat-0.260.200
+"
+
+src_test() {
+ perl_rm_files t/author-*.t t/03podcov.t t/00sig.t t/02pod.t
+ perl-module_src_test
+}