summaryrefslogtreecommitdiff
path: root/perl-core/Encode/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-18 03:40:50 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-18 03:40:50 +0000
commit7bf32644d8b70a318475609992d8e4853ec4ec0e (patch)
treec1a8189f6bec3613a4c73b2158bfa7ce2640b26e /perl-core/Encode/files
parent85c74bc4e237bda22f900628aab62d70c41536d8 (diff)
gentoo auto-resync : 18:12:2022 - 03:40:50
Diffstat (limited to 'perl-core/Encode/files')
-rw-r--r--perl-core/Encode/files/Encode-3.120.0-Werror.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/perl-core/Encode/files/Encode-3.120.0-Werror.patch b/perl-core/Encode/files/Encode-3.120.0-Werror.patch
new file mode 100644
index 000000000000..34974911a32f
--- /dev/null
+++ b/perl-core/Encode/files/Encode-3.120.0-Werror.patch
@@ -0,0 +1,29 @@
+https://github.com/dankogai/p5-encode/commit/7c9c5be4e658a5b37632b46925a2735123f65c6e
+https://bugs.gentoo.org/886507
+
+From 7c9c5be4e658a5b37632b46925a2735123f65c6e Mon Sep 17 00:00:00 2001
+From: Nicholas Clark <nick@ccl4.org>
+Date: Wed, 13 Oct 2021 07:51:58 +0000
+Subject: [PATCH] Only add -Werror=declaration-after-statement for 5.035004 and
+ earlier
+
+Perl v5.35.5 now uses some C99 features. This means that Perl's headers now
+contain some code with mixed declarations and code., and so won't compile
+with -Werror=declaration-after-statement
+
+It still makes sense to add this flag for builds for earlier perl versions,
+because they support long obsolete compilers that are strict in rejecting
+certain C99 features, so adding this gcc flag allows us to audit that our
+code does not violate this.
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -20,7 +20,7 @@ if (!$ENV{PERL_CORE}) {
+ $gccver =~ s/\.//g; $gccver =~ s/ .*//;
+ $gccver .= "0" while length $gccver < 3;
+ $gccver = 0+$gccver;
+- $ccflags .= ' -Werror=declaration-after-statement' if $gccver > 412;
++ $ccflags .= ' -Werror=declaration-after-statement' if $gccver > 412 and $] < 5.035005;
+ $ccflags .= ' -Wpointer-sign' if !$Config{d_cplusplus} and $gccver > 400;
+ $ccflags .= ' -fpermissive' if $Config{d_cplusplus};
+ }
+