summaryrefslogtreecommitdiff
path: root/net-wireless/wpa_supplicant/wpa_supplicant-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-29 18:01:47 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-29 18:01:47 +0000
commitceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (patch)
tree9f47ee47c31a0f13f9496879cd88a1042550aa81 /net-wireless/wpa_supplicant/wpa_supplicant-9999.ebuild
parent53cba99042fa967e2a93da9f8db806fe2d035543 (diff)
gentoo (leap year) resync : 29.02.2020
Diffstat (limited to 'net-wireless/wpa_supplicant/wpa_supplicant-9999.ebuild')
-rw-r--r--net-wireless/wpa_supplicant/wpa_supplicant-9999.ebuild25
1 files changed, 16 insertions, 9 deletions
diff --git a/net-wireless/wpa_supplicant/wpa_supplicant-9999.ebuild b/net-wireless/wpa_supplicant/wpa_supplicant-9999.ebuild
index 3cb7b352a50f..c91b6d2f5624 100644
--- a/net-wireless/wpa_supplicant/wpa_supplicant-9999.ebuild
+++ b/net-wireless/wpa_supplicant/wpa_supplicant-9999.ebuild
@@ -59,9 +59,9 @@ RDEPEND="${CDEPEND}
DOC_CONTENTS="
If this is a clean installation of wpa_supplicant, you
have to create a configuration file named
- ${EROOT%/}/etc/wpa_supplicant/wpa_supplicant.conf
+ ${EROOT}/etc/wpa_supplicant/wpa_supplicant.conf
An example configuration file is available for reference in
- ${EROOT%/}/usr/share/doc/${PF}/
+ ${EROOT}/usr/share/doc/${PF}/
"
S="${WORKDIR}/${P}/${PN}"
@@ -247,9 +247,11 @@ src_configure() {
Kconfig_style_config OWE
Kconfig_style_config SAE
Kconfig_style_config DPP
- Kconfig_style_config SUITEB
Kconfig_style_config SUITEB192
fi
+ if ! use bindist && ! use libressl; then
+ Kconfig_style_config SUITEB
+ fi
if use smartcard ; then
Kconfig_style_config SMARTCARD
@@ -440,10 +442,10 @@ src_install() {
pkg_postinst() {
readme.gentoo_print_elog
- if [[ -e "${EROOT%/}"/etc/wpa_supplicant.conf ]] ; then
+ if [[ -e "${EROOT}"/etc/wpa_supplicant.conf ]] ; then
echo
- ewarn "WARNING: your old configuration file ${EROOT%/}/etc/wpa_supplicant.conf"
- ewarn "needs to be moved to ${EROOT%/}/etc/wpa_supplicant/wpa_supplicant.conf"
+ ewarn "WARNING: your old configuration file ${EROOT}/etc/wpa_supplicant.conf"
+ ewarn "needs to be moved to ${EROOT}/etc/wpa_supplicant/wpa_supplicant.conf"
fi
if use bindist; then
@@ -452,15 +454,20 @@ pkg_postinst() {
ewarn "This is incredibly undesirable"
fi
fi
+ if use libressl; then
+ ewarn "Libressl doesn't support SUITEB (part of WPA3)"
+ ewarn "but it does support SUITEB192 (the upgraded strength version of the same)"
+ ewarn "You probably don't care. Patches welcome"
+ fi
# Mea culpa, feel free to remove that after some time --mgorny.
local fn
for fn in wpa_supplicant{,@wlan0}.service; do
- if [[ -e "${EROOT%/}"/etc/systemd/system/network.target.wants/${fn} ]]
+ if [[ -e "${EROOT}"/etc/systemd/system/network.target.wants/${fn} ]]
then
ebegin "Moving ${fn} to multi-user.target"
- mv "${EROOT%/}"/etc/systemd/system/network.target.wants/${fn} \
- "${EROOT%/}"/etc/systemd/system/multi-user.target.wants/ || die
+ mv "${EROOT}"/etc/systemd/system/network.target.wants/${fn} \
+ "${EROOT}"/etc/systemd/system/multi-user.target.wants/ || die
eend ${?} \
"Please try to re-enable ${fn}"
fi