summaryrefslogtreecommitdiff
path: root/net-wireless/uhd/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-01-12 16:58:08 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-01-12 16:58:08 +0000
commitc8a77dfe4d3d307c1d5dd2650b7297447d8b609d (patch)
tree9ea78393bc3ecd6ab4de449383d4e97e5f3648ae /net-wireless/uhd/files
parent2891d29af8907ce881662f4a02844926d7a293c7 (diff)
gentoo resync : 12.01.2019
Diffstat (limited to 'net-wireless/uhd/files')
-rw-r--r--net-wireless/uhd/files/uhd-3.13.1.0-tinfo.patch45
1 files changed, 45 insertions, 0 deletions
diff --git a/net-wireless/uhd/files/uhd-3.13.1.0-tinfo.patch b/net-wireless/uhd/files/uhd-3.13.1.0-tinfo.patch
new file mode 100644
index 000000000000..de165e9deebf
--- /dev/null
+++ b/net-wireless/uhd/files/uhd-3.13.1.0-tinfo.patch
@@ -0,0 +1,45 @@
+diff --git host/CMakeLists.txt host/CMakeLists.txt
+index 2337396e7..3a77776a0 100644
+--- host/CMakeLists.txt
++++ host/CMakeLists.txt
+@@ -531,6 +531,9 @@ endforeach(Boost_Comp)
+ if(ENABLE_USB)
+ list(APPEND UHD_LINK_LIST_STATIC "usb-1.0")
+ endif(ENABLE_USB)
++
++LIST(APPEND UHD_LINK_LIST_STATIC "tinfo")
++
+ # UHDConfig.cmake also needs UHD_RFNOC_FOUND
+ if(ENABLE_RFNOC)
+ set(UHD_RFNOC_FOUND "TRUE")
+diff --git host/examples/CMakeLists.txt host/examples/CMakeLists.txt
+index b384d978c..402aded94 100644
+--- host/examples/CMakeLists.txt
++++ host/examples/CMakeLists.txt
+@@ -58,11 +58,11 @@ find_package(Curses)
+ if(CURSES_FOUND)
+ include_directories(${CURSES_INCLUDE_DIR})
+ add_executable(rx_ascii_art_dft rx_ascii_art_dft.cpp)
+- target_link_libraries(rx_ascii_art_dft uhd ${CURSES_LIBRARIES} ${Boost_LIBRARIES})
++ target_link_libraries(rx_ascii_art_dft uhd ${CURSES_LIBRARIES} tinfo ${Boost_LIBRARIES})
+ UHD_INSTALL(TARGETS rx_ascii_art_dft RUNTIME DESTINATION ${PKG_LIB_DIR}/examples COMPONENT examples)
+
+ add_executable(twinrx_freq_hopping twinrx_freq_hopping.cpp)
+- target_link_libraries(twinrx_freq_hopping uhd ${CURSES_LIBRARIES} ${Boost_LIBRARIES})
++ target_link_libraries(twinrx_freq_hopping uhd ${CURSES_LIBRARIES} tinfo ${Boost_LIBRARIES})
+ UHD_INSTALL(TARGETS twinrx_freq_hopping RUNTIME DESTINATION ${PKG_LIB_DIR}/examples COMPONENT examples)
+ endif(CURSES_FOUND)
+
+diff --git host/utils/latency/CMakeLists.txt host/utils/latency/CMakeLists.txt
+index 05bacd77a..d3b1449a6 100644
+--- host/utils/latency/CMakeLists.txt
++++ host/utils/latency/CMakeLists.txt
+@@ -25,7 +25,7 @@ if(CURSES_FOUND)
+ get_filename_component(name ${source} NAME_WE)
+ add_executable(${name} ${source} ${latency_lib_path})
+ LIBUHD_APPEND_SOURCES(${name})
+- target_link_libraries(${name} uhd ${Boost_LIBRARIES} ${CURSES_LIBRARIES})
++ target_link_libraries(${name} uhd ${Boost_LIBRARIES} tinfo ${CURSES_LIBRARIES})
+ UHD_INSTALL(TARGETS ${name} RUNTIME DESTINATION ${latency_comp_dest} COMPONENT ${latency_comp_name})
+ endforeach(source)
+