summaryrefslogtreecommitdiff
path: root/net-wireless/soapyuhd/soapyuhd-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-02-24 19:58:07 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-02-24 19:58:07 +0000
commit99abbc5e5a6ecd3fc981b45646fd8cb5d320377b (patch)
treeda76713365257a445f3ae3b95470917f59d46728 /net-wireless/soapyuhd/soapyuhd-9999.ebuild
parent4935506e9a5cbfabd37c64093eac5f36c2ff0017 (diff)
gentoo resync : 24.02.2018
Diffstat (limited to 'net-wireless/soapyuhd/soapyuhd-9999.ebuild')
-rw-r--r--net-wireless/soapyuhd/soapyuhd-9999.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/net-wireless/soapyuhd/soapyuhd-9999.ebuild b/net-wireless/soapyuhd/soapyuhd-9999.ebuild
new file mode 100644
index 000000000000..626e9029a89c
--- /dev/null
+++ b/net-wireless/soapyuhd/soapyuhd-9999.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="Soapy SDR plugins for UHD supported SDR devices "
+HOMEPAGE="https://github.com/pothosware/SoapyUHD"
+
+if [ "${PV}" = "9999" ]; then
+ EGIT_REPO_URI="https://github.com/pothosware/SoapyUHD.git"
+ inherit git-r3
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/pothosware/SoapyUHD/archive/soapy-uhd-${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}"/SoapyUHD-soapy-uhd-"${PV}"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="net-wireless/soapysdr
+ net-wireless/uhd:=
+ dev-libs/boost:="
+DEPEND="${RDEPEND}"