summaryrefslogtreecommitdiff
path: root/net-wireless/soapyuhd/soapyuhd-0.3.4-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-11-18 09:38:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-11-18 09:38:27 +0000
commit536c3711867ec947c1738f2c4b96f22e4863322d (patch)
tree697733f5cb713908dcf378e13fd15a798a906a91 /net-wireless/soapyuhd/soapyuhd-0.3.4-r1.ebuild
parentf65628136faa35d0c4d3b5e7332275c7b35fcd96 (diff)
gentoo resync : 18.11.2018
Diffstat (limited to 'net-wireless/soapyuhd/soapyuhd-0.3.4-r1.ebuild')
-rw-r--r--net-wireless/soapyuhd/soapyuhd-0.3.4-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/net-wireless/soapyuhd/soapyuhd-0.3.4-r1.ebuild b/net-wireless/soapyuhd/soapyuhd-0.3.4-r1.ebuild
new file mode 100644
index 000000000000..664cf2685543
--- /dev/null
+++ b/net-wireless/soapyuhd/soapyuhd-0.3.4-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="Soapy SDR plugins for UHD supported SDR devices "
+HOMEPAGE="https://github.com/pothosware/SoapyUHD"
+
+if [ "${PV}" = "9999" ]; then
+ EGIT_REPO_URI="https://github.com/pothosware/SoapyUHD.git"
+ inherit git-r3
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/pothosware/SoapyUHD/archive/soapy-uhd-${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}"/SoapyUHD-soapy-uhd-"${PV}"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="net-wireless/soapysdr:=
+ net-wireless/uhd:=
+ dev-libs/boost:="
+DEPEND="${RDEPEND}"