summaryrefslogtreecommitdiff
path: root/net-wireless/soapysdr
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-11-18 09:38:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-11-18 09:38:27 +0000
commit536c3711867ec947c1738f2c4b96f22e4863322d (patch)
tree697733f5cb713908dcf378e13fd15a798a906a91 /net-wireless/soapysdr
parentf65628136faa35d0c4d3b5e7332275c7b35fcd96 (diff)
gentoo resync : 18.11.2018
Diffstat (limited to 'net-wireless/soapysdr')
-rw-r--r--net-wireless/soapysdr/Manifest4
-rw-r--r--net-wireless/soapysdr/soapysdr-0.7.0.ebuild53
-rw-r--r--net-wireless/soapysdr/soapysdr-9999.ebuild7
3 files changed, 60 insertions, 4 deletions
diff --git a/net-wireless/soapysdr/Manifest b/net-wireless/soapysdr/Manifest
index 533c97dc58f6..3d9139c500ef 100644
--- a/net-wireless/soapysdr/Manifest
+++ b/net-wireless/soapysdr/Manifest
@@ -1,4 +1,6 @@
DIST soapysdr-0.6.1.tar.gz 112820 BLAKE2B 42376a7a43c0d5a87a5b17b7d901cc7c74885083051c433c1f22427fe07a4fb0f111ddb460867bd7f748cb3ac6858b15e3dc69ba3ecca4574802c6bd0856a8cc SHA512 80ae8d0b096139e0df70524a1ff05fa1954755177d7920dbd8acb37e45cf86729e2745dcfd4e9c7ae2d7aa564335c2f197ca25ea387daa8f376d6c3e93234106
+DIST soapysdr-0.7.0.tar.gz 122933 BLAKE2B 2bd2f8812a6258a92ca4fe82ced10e3e97e348927dfc8a1f702a7ee4900b4fbe966a32566d1640a3474734074524cf31d8850b47a9b177e6e0e4d92c531409a6 SHA512 3dc69f070a2fe7acee9239154e58b21aa9c321fe35e2de77dfed8561016a93d5e693b5288da6d05e3d8c0f9ab7552ea12c4fd74ddb8d3c118d576f58251fb632
EBUILD soapysdr-0.6.1-r1.ebuild 1287 BLAKE2B 26745867d415a983dce5bfcb5f300001dc11891ec2c63e7593b31367ec88cd3881a3a3a1bec201c58a8908ac295d072698c06023d6e8bf5cc0bcc1301d83b228 SHA512 1d955ae324654c320fca18fb7ff80b5de879ce074e6a3e50e1f650900e4c639a50e4a6882580e5bf6cefa7bd690a0f48d9baa908f4b9374b82af163e94e688da
-EBUILD soapysdr-9999.ebuild 1235 BLAKE2B 78b749481db6750124259a0e3a66034c94ede5fda924873edf807d78eff2f903b09d5c1fa1a3147810a4d930a1cd47a2eb6dbaa0e472e76d13559d00732dfcc6 SHA512 2e222f6e840fbb7e31fb4e56191a34c3b2bf1d469fbe4f60a8a09ec00fcdfc874aa0da63e48de686e1b17e6e70ee57490fda991b748db2e2321f47c879043673
+EBUILD soapysdr-0.7.0.ebuild 1290 BLAKE2B 3b2850132b31856a4b37374f28af34db3b88acc9d4c75a1a95cfd7d962932cd127424cf9a0199f1ec253ab7f13fb10baf9f4f468d40797ae2ac7c7ed79dd6372 SHA512 5e25b4f3f7f777d1413762b15e8adcca28506a498383b219c0c9de303897e2eff7e1e74a812ccd49717d471e7e3a6fb9aa5ef8a7507bf236f1a9ece8e11e9255
+EBUILD soapysdr-9999.ebuild 1290 BLAKE2B 3b2850132b31856a4b37374f28af34db3b88acc9d4c75a1a95cfd7d962932cd127424cf9a0199f1ec253ab7f13fb10baf9f4f468d40797ae2ac7c7ed79dd6372 SHA512 5e25b4f3f7f777d1413762b15e8adcca28506a498383b219c0c9de303897e2eff7e1e74a812ccd49717d471e7e3a6fb9aa5ef8a7507bf236f1a9ece8e11e9255
MISC metadata.xml 775 BLAKE2B dbcad63785d9af5b1f2f93775c645f78e6344a2c47fe0ed1f71ab47d9945be2885e4becb2d9b329e145b035cf3af2f50daacc56175126d2fc3b6feae5e4579a7 SHA512 8805602022441e46c239411c7050ae3c4ef954c796a4293f3fb2eb0ff6cbc87a47eb554b89a29c22622e088f6cb232f05c154c0d6f8f864b35cc5f9c2a292862
diff --git a/net-wireless/soapysdr/soapysdr-0.7.0.ebuild b/net-wireless/soapysdr/soapysdr-0.7.0.ebuild
new file mode 100644
index 000000000000..238bf83a0e24
--- /dev/null
+++ b/net-wireless/soapysdr/soapysdr-0.7.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit cmake-utils python-r1
+
+DESCRIPTION="vendor and platform neutral SDR support library"
+HOMEPAGE="https://github.com/pothosware/SoapySDR"
+
+if [ "${PV}" = "9999" ]; then
+ EGIT_REPO_URI="https://github.com/pothosware/SoapySDR.git"
+ EGIT_CLONE_TYPE="shallow"
+ KEYWORDS=""
+ inherit git-r3
+else
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/pothosware/SoapySDR/archive/soapy-sdr-${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}"/SoapySDR-soapy-sdr-"${PV}"
+fi
+
+LICENSE="Boost-1.0"
+SLOT="0/${PV}"
+
+IUSE="bladerf hackrf python rtlsdr plutosdr uhd"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="python? ( ${PYTHON_DEPS} )"
+DEPEND="${RDEPEND}
+ python? ( dev-lang/swig:0 )
+"
+PDEPEND="bladerf? ( net-wireless/soapybladerf )
+ hackrf? ( net-wireless/soapyhackrf )
+ rtlsdr? ( net-wireless/soapyrtlsdr )
+ plutosdr? ( net-wireless/soapyplutosdr )
+ uhd? ( net-wireless/soapyuhd )"
+
+src_configure() {
+ configuration() {
+ mycmakeargs+=( -DENABLE_PYTHON=ON )
+ if python_is_python3; then
+ mycmakeargs+=( -DBUILD_PYTHON3=ON )
+ fi
+ }
+
+ if use python; then
+ python_foreach_impl configuration
+ fi
+
+ cmake-utils_src_configure
+}
diff --git a/net-wireless/soapysdr/soapysdr-9999.ebuild b/net-wireless/soapysdr/soapysdr-9999.ebuild
index 0669ed4ac687..238bf83a0e24 100644
--- a/net-wireless/soapysdr/soapysdr-9999.ebuild
+++ b/net-wireless/soapysdr/soapysdr-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -22,9 +22,9 @@ else
fi
LICENSE="Boost-1.0"
-SLOT="0"
+SLOT="0/${PV}"
-IUSE="bladerf hackrf python rtlsdr uhd"
+IUSE="bladerf hackrf python rtlsdr plutosdr uhd"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
RDEPEND="python? ( ${PYTHON_DEPS} )"
@@ -34,6 +34,7 @@ DEPEND="${RDEPEND}
PDEPEND="bladerf? ( net-wireless/soapybladerf )
hackrf? ( net-wireless/soapyhackrf )
rtlsdr? ( net-wireless/soapyrtlsdr )
+ plutosdr? ( net-wireless/soapyplutosdr )
uhd? ( net-wireless/soapyuhd )"
src_configure() {