summaryrefslogtreecommitdiff
path: root/net-wireless/soapysdr/soapysdr-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
commit6abbf81ef2f298e3221ff5e67a1f3c5f23958212 (patch)
tree25413d1cb3a0cbfe36029db32398c0f333609215 /net-wireless/soapysdr/soapysdr-9999.ebuild
parent9c417bacd51da6d8b57fa9f37425161d30d4b95b (diff)
gentoo resync : 14.12.2020
Diffstat (limited to 'net-wireless/soapysdr/soapysdr-9999.ebuild')
-rw-r--r--net-wireless/soapysdr/soapysdr-9999.ebuild12
1 files changed, 8 insertions, 4 deletions
diff --git a/net-wireless/soapysdr/soapysdr-9999.ebuild b/net-wireless/soapysdr/soapysdr-9999.ebuild
index f3b498a69d52..d5a5aa7bad6c 100644
--- a/net-wireless/soapysdr/soapysdr-9999.ebuild
+++ b/net-wireless/soapysdr/soapysdr-9999.ebuild
@@ -3,9 +3,9 @@
EAPI=7
-PYTHON_COMPAT=( python3_{6,7} )
+PYTHON_COMPAT=( python3_{6,7,8,9} )
-inherit cmake-utils python-r1
+inherit cmake python-r1
DESCRIPTION="vendor and platform neutral SDR support library"
HOMEPAGE="https://github.com/pothosware/SoapySDR"
@@ -13,7 +13,6 @@ HOMEPAGE="https://github.com/pothosware/SoapySDR"
if [ "${PV}" = "9999" ]; then
EGIT_REPO_URI="https://github.com/pothosware/SoapySDR.git"
EGIT_CLONE_TYPE="shallow"
- KEYWORDS=""
inherit git-r3
else
KEYWORDS="~amd64 ~x86"
@@ -49,5 +48,10 @@ src_configure() {
python_foreach_impl configuration
fi
- cmake-utils_src_configure
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+ python_foreach_impl python_optimize
}