summaryrefslogtreecommitdiff
path: root/net-wireless/soapysdr/soapysdr-0.8.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-03 00:07:26 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-03 00:07:26 +0100
commita3bb28551df94028000fb72308a9e9baa01458b0 (patch)
tree33b14c7bf0dffbd5bb04dbd5b395514ebdda4896 /net-wireless/soapysdr/soapysdr-0.8.1.ebuild
parent6657c680376cedf378fcf328e5fa03ed3b41d580 (diff)
gentoo auto-resync : 03:06:2024 - 00:07:25
Diffstat (limited to 'net-wireless/soapysdr/soapysdr-0.8.1.ebuild')
-rw-r--r--net-wireless/soapysdr/soapysdr-0.8.1.ebuild60
1 files changed, 0 insertions, 60 deletions
diff --git a/net-wireless/soapysdr/soapysdr-0.8.1.ebuild b/net-wireless/soapysdr/soapysdr-0.8.1.ebuild
deleted file mode 100644
index fae8341b7d65..000000000000
--- a/net-wireless/soapysdr/soapysdr-0.8.1.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..12} )
-
-inherit cmake python-r1
-
-DESCRIPTION="vendor and platform neutral SDR support library"
-HOMEPAGE="https://github.com/pothosware/SoapySDR"
-
-if [ "${PV}" = "9999" ]; then
- EGIT_REPO_URI="https://github.com/pothosware/SoapySDR.git"
- EGIT_CLONE_TYPE="shallow"
- inherit git-r3
-else
- KEYWORDS="amd64 ~arm ~riscv ~x86"
- SRC_URI="https://github.com/pothosware/SoapySDR/archive/soapy-sdr-${PV}.tar.gz -> ${P}.tar.gz"
- S="${WORKDIR}"/SoapySDR-soapy-sdr-"${PV}"
-fi
-
-LICENSE="Boost-1.0"
-SLOT="0/${PV}"
-
-IUSE="bladerf hackrf python rtlsdr plutosdr uhd"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-RDEPEND="python? ( ${PYTHON_DEPS} )"
-DEPEND="${RDEPEND}
- python? ( dev-lang/swig:0 )
-"
-PDEPEND="bladerf? ( net-wireless/soapybladerf )
- hackrf? ( net-wireless/soapyhackrf )
- rtlsdr? ( net-wireless/soapyrtlsdr )
- plutosdr? ( net-wireless/soapyplutosdr )
- uhd? ( net-wireless/soapyuhd )"
-
-src_configure() {
- configuration() {
- mycmakeargs+=(
- -DENABLE_PYTHON=ON
- -DBUILD_PYTHON3=ON
- )
- }
-
- if use python; then
- python_foreach_impl configuration
- fi
-
- cmake_src_configure
-}
-
-src_install() {
- cmake_src_install
-
- if use python; then
- python_foreach_impl python_optimize
- fi
-}