summaryrefslogtreecommitdiff
path: root/net-wireless/soapyremote/soapyremote-0.4.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-29 20:19:23 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-29 20:19:23 +0100
commit12bb627384ddfd47382b9f1b6464481a58d01ebb (patch)
treef9760c04ccd4fcd7de214e2acd5b0e43fb530aa9 /net-wireless/soapyremote/soapyremote-0.4.3.ebuild
parent5fdd950c7ae03e12746a45c86d85861beaacc846 (diff)
gentoo resync : 29.08.2018
Diffstat (limited to 'net-wireless/soapyremote/soapyremote-0.4.3.ebuild')
-rw-r--r--net-wireless/soapyremote/soapyremote-0.4.3.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/net-wireless/soapyremote/soapyremote-0.4.3.ebuild b/net-wireless/soapyremote/soapyremote-0.4.3.ebuild
new file mode 100644
index 000000000000..0b994353296d
--- /dev/null
+++ b/net-wireless/soapyremote/soapyremote-0.4.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="Soapy SDR remote module"
+HOMEPAGE="https://github.com/pothosware/SoapyRemote"
+
+if [ "${PV}" = "9999" ]; then
+ EGIT_REPO_URI="https://github.com/pothosware/SoapyRemote.git"
+ EGIT_CLONE_TYPE="shallow"
+ KEYWORDS=""
+ inherit git-r3
+else
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/pothosware/SoapyRemote/archive/soapy-remote-${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}"/SoapyRemote-soapy-remote-"${PV}"
+fi
+
+LICENSE="Boost-1.0"
+SLOT="0"
+
+IUSE=""
+REQUIRED_USE=""
+
+RDEPEND="net-wireless/soapysdr"
+DEPEND="${RDEPEND}"