summaryrefslogtreecommitdiff
path: root/net-wireless/soapyplutosdr
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-09-08 10:50:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-09-08 10:50:14 +0100
commit3f71901f8c228f4de570abed1831ce3ee425343e (patch)
treea2dcd300d05ef8a2ec275b44a92a9d85bd3baa24 /net-wireless/soapyplutosdr
parent12bb627384ddfd47382b9f1b6464481a58d01ebb (diff)
gentoo resync 08.09.2018
Diffstat (limited to 'net-wireless/soapyplutosdr')
-rw-r--r--net-wireless/soapyplutosdr/Manifest4
-rw-r--r--net-wireless/soapyplutosdr/metadata.xml15
-rw-r--r--net-wireless/soapyplutosdr/soapyplutosdr-0.0_p20180825.ebuild28
-rw-r--r--net-wireless/soapyplutosdr/soapyplutosdr-9999.ebuild28
4 files changed, 75 insertions, 0 deletions
diff --git a/net-wireless/soapyplutosdr/Manifest b/net-wireless/soapyplutosdr/Manifest
new file mode 100644
index 000000000000..cc43387bddb7
--- /dev/null
+++ b/net-wireless/soapyplutosdr/Manifest
@@ -0,0 +1,4 @@
+DIST soapyplutosdr-0.0_p20180825.tar.gz 17597 BLAKE2B d5b6205da7aa64406ccf84d198088094c10397ca874925926dfe2ee3134e045c3ab80b68db06ee84448ae8966e2d8edecb2517ef70b10bbddd9681fcbf09385a SHA512 40cc7c83c13f1d81212c5b0b6028d49de6c9e0b4df9e479c5cb577f60a92b415f76e159d45ecf19aad2deac507f7bd779b7cce1f7bc5e6fd2ea9a3f24399dfe7
+EBUILD soapyplutosdr-0.0_p20180825.ebuild 714 BLAKE2B 105abb2805863cb268291cd5705bdd02241e5c1ca9c35e2c55ab27335067a363199d49ac079bb8700cfcebc4e03085161287f19687ee71a166ce1f78949d3390 SHA512 902bde9e0168da760af1735e6ed1b5fb2ec0412e21301c6367d2149c097aa81ec9934170e412df02af45fc5f6998d921d973c51588613c878b3d08f4071a96d0
+EBUILD soapyplutosdr-9999.ebuild 714 BLAKE2B 105abb2805863cb268291cd5705bdd02241e5c1ca9c35e2c55ab27335067a363199d49ac079bb8700cfcebc4e03085161287f19687ee71a166ce1f78949d3390 SHA512 902bde9e0168da760af1735e6ed1b5fb2ec0412e21301c6367d2149c097aa81ec9934170e412df02af45fc5f6998d921d973c51588613c878b3d08f4071a96d0
+MISC metadata.xml 435 BLAKE2B 2a0b2a0043234cf560ee6b76935c546da77ae108e3fd4e8187dcac974d1ffed8e50e86f94fb943e4396c0bc338ae1a92b899da38f7a88d3bc0c6437bf95282af SHA512 c66683ba419f5dd3d7ea63d07478366ae751ecd38250ba07fe157375d937bc0f42ae6324716dd7068c33e1d405f98207b676c6dfee3b1b1870bfb6f73b9e8a7d
diff --git a/net-wireless/soapyplutosdr/metadata.xml b/net-wireless/soapyplutosdr/metadata.xml
new file mode 100644
index 000000000000..04bd48d30e55
--- /dev/null
+++ b/net-wireless/soapyplutosdr/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>zerochaos@gentoo.org</email>
+ <name>Rick Farina</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>radio@gentoo.org</email>
+ <name>Radio</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">pothosware/SoapyPlutoSDR</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-wireless/soapyplutosdr/soapyplutosdr-0.0_p20180825.ebuild b/net-wireless/soapyplutosdr/soapyplutosdr-0.0_p20180825.ebuild
new file mode 100644
index 000000000000..a5f9a164f11d
--- /dev/null
+++ b/net-wireless/soapyplutosdr/soapyplutosdr-0.0_p20180825.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="Soapy SDR plugin for the Pluto SDR"
+HOMEPAGE="https://github.com/pothosware/SoapyPlutoSDR"
+
+if [ "${PV}" = "9999" ]; then
+ EGIT_REPO_URI="https://github.com/pothosware/SoapyPlutoSDR.git"
+ inherit git-r3
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64 ~x86"
+ COMMIT="782650597b18f311cc97fbb7c6813539e6adef16"
+ SRC_URI="https://github.com/pothosware/SoapyPlutoSDR/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}"/SoapyPlutoSDR-${COMMIT}
+fi
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+
+RDEPEND="net-wireless/soapysdr
+ net-libs/libiio:=
+ net-libs/libad9361-iio:="
+DEPEND="${RDEPEND}"
diff --git a/net-wireless/soapyplutosdr/soapyplutosdr-9999.ebuild b/net-wireless/soapyplutosdr/soapyplutosdr-9999.ebuild
new file mode 100644
index 000000000000..a5f9a164f11d
--- /dev/null
+++ b/net-wireless/soapyplutosdr/soapyplutosdr-9999.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="Soapy SDR plugin for the Pluto SDR"
+HOMEPAGE="https://github.com/pothosware/SoapyPlutoSDR"
+
+if [ "${PV}" = "9999" ]; then
+ EGIT_REPO_URI="https://github.com/pothosware/SoapyPlutoSDR.git"
+ inherit git-r3
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64 ~x86"
+ COMMIT="782650597b18f311cc97fbb7c6813539e6adef16"
+ SRC_URI="https://github.com/pothosware/SoapyPlutoSDR/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}"/SoapyPlutoSDR-${COMMIT}
+fi
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+
+RDEPEND="net-wireless/soapysdr
+ net-libs/libiio:=
+ net-libs/libad9361-iio:="
+DEPEND="${RDEPEND}"