summaryrefslogtreecommitdiff
path: root/net-wireless/portapack-havoc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-25 07:36:27 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-25 07:36:27 +0100
commit43793fab84041cfc5c60c0151d1591b8a69fb24a (patch)
tree6208a7f4fc744684fce0f55acbb47511acace498 /net-wireless/portapack-havoc
parent28e3d252dc8ac8a5635206dfefe1cfe05058d1db (diff)
gentoo resync : 25.08.2018
Diffstat (limited to 'net-wireless/portapack-havoc')
-rw-r--r--net-wireless/portapack-havoc/Manifest3
-rw-r--r--net-wireless/portapack-havoc/metadata.xml11
-rw-r--r--net-wireless/portapack-havoc/portapack-havoc-0.0_p20180612.ebuild46
3 files changed, 60 insertions, 0 deletions
diff --git a/net-wireless/portapack-havoc/Manifest b/net-wireless/portapack-havoc/Manifest
new file mode 100644
index 000000000000..648c4bd5febf
--- /dev/null
+++ b/net-wireless/portapack-havoc/Manifest
@@ -0,0 +1,3 @@
+DIST portapack-havoc-0.0_p20180612.tar.gz 74244267 BLAKE2B 7a6b632cd3766681e691cb0e8405e9493d4d4b46008c9905192f492715238378713da6a305383855b50935f5ffa943e5134677ab1580275a645b46e0e025c561 SHA512 b8ea6a4aa6682793a69cefb2815fcaf51a5f6f253bea2c34e00d76fba15f9d700f45f1a36c1ac7e1d7c640ac19ee64dc835c76c3d9964d73d18443299a2d6fdd
+EBUILD portapack-havoc-0.0_p20180612.ebuild 1321 BLAKE2B 5c05a19c2d1ca029f9a7435a68e9806a937c758473e01b8b8dcf2f34bf31e5deba41f9772bd126014609a16011097d36ec4abfd1be4e81da52cb70659fee7b33 SHA512 29511fbcb82841e86480744af001654ab049ed98e3e2e30eb0a138fb1c7d75165498f93c36b1d54cf8f0bd767e653c4f743b9decaac31c82ad18e9f242cc68cd
+MISC metadata.xml 335 BLAKE2B 86a1ca94a1af4aeea45ca7025863b74eda0267683d4ff10a8816320146ba47ed42ac6c61410cdaa3a3b74fccdce43f4309b8b85c3ba0451f7ed0086e9bd3a2c8 SHA512 bcaa25c76ac35f9e588ed193542a4835eb3bdd36e379e7808f2ac3f1da0da19cd36f0b2d86875887e6e6bc70bbf4d6cbf9fc0c0f8ba0f88b2fdc4a1db46b377c
diff --git a/net-wireless/portapack-havoc/metadata.xml b/net-wireless/portapack-havoc/metadata.xml
new file mode 100644
index 000000000000..379b11c6216c
--- /dev/null
+++ b/net-wireless/portapack-havoc/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>zerochaos@gentoo.org</email>
+ <name>Rick Farina</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">furrtek/portapack-havoc</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-wireless/portapack-havoc/portapack-havoc-0.0_p20180612.ebuild b/net-wireless/portapack-havoc/portapack-havoc-0.0_p20180612.ebuild
new file mode 100644
index 000000000000..59b7f30080d1
--- /dev/null
+++ b/net-wireless/portapack-havoc/portapack-havoc-0.0_p20180612.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Custom firmware for the HackRF SDR + PortaPack H1 addon"
+HOMEPAGE="https://github.com/furrtek/portapack-havoc/wiki"
+COMMIT="609235b19f55d0bf278c0e7c4b9f9b6b15136247"
+SRC_URI="https://github.com/furrtek/portapack-havoc/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+KEYWORDS="~amd64 ~x86"
+
+PDEPEND=">=net-wireless/hackrf-tools-2015.07.2-r1
+ >=app-mobilephone/dfu-util-0.7"
+
+src_configure() {
+ true
+}
+
+src_compile() {
+ true
+}
+
+src_install() {
+ insinto /usr/share/hackrf
+ newins firmware/portapack-h1-havoc.bin portapack-h1-havoc-${PV}.bin
+ ln -s portapack-h1-havoc-${PV}.bin "${ED}/usr/share/hackrf/portapack-h1-havoc.bin"
+
+ cat << EOF > switch_to_havoc
+#!/bin/sh
+printf "Hold down the HackRF's DFU button (the button closest to the antenna jack)\n"
+printf "then plug the HackRF into a USB port on your computer.\n"
+printf "After the HackRF is plugged in, you may release the DFU button.\n"
+printf "Press any key to continue or ^c to abort\n"
+read
+dfu-util --device 1fc9:000c --download /usr/share/hackrf/hackrf_one_usb_ram.dfu --reset
+sleep 2s
+hackrf_spiflash -w /usr/share/hackrf/portapack-h1-havoc.bin
+EOF
+ dobin switch_to_havoc
+}