summaryrefslogtreecommitdiff
path: root/net-wireless/lorcon/lorcon-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /net-wireless/lorcon/lorcon-9999.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'net-wireless/lorcon/lorcon-9999.ebuild')
-rw-r--r--net-wireless/lorcon/lorcon-9999.ebuild14
1 files changed, 7 insertions, 7 deletions
diff --git a/net-wireless/lorcon/lorcon-9999.ebuild b/net-wireless/lorcon/lorcon-9999.ebuild
index dfe0a1417ae1..36ede49a82fc 100644
--- a/net-wireless/lorcon/lorcon-9999.ebuild
+++ b/net-wireless/lorcon/lorcon-9999.ebuild
@@ -12,12 +12,14 @@ DESCRIPTION="A generic library for injecting 802.11 frames"
HOMEPAGE="https://github.com/kismetwireless/lorcon"
if [[ ${PV} == "9999" ]] ; then
+ #main repo
#EGIT_REPO_URI="https://www.kismetwireless.net/lorcon.git"
+ #reliable mirror
EGIT_REPO_URI="https://github.com/kismetwireless/lorcon.git"
inherit git-r3
S="${WORKDIR}"/${P}
else
- GIT_HASH="7dbf24ee6f7c277240c0fbd988b6902850577772"
+ GIT_HASH="4a81d6aaa2c6ac7253ecd182ffe97c6c89411196"
SRC_URI="https://github.com/kismetwireless/lorcon/archive/${GIT_HASH}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}"/"${PN}-${GIT_HASH}"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86 ~amd64-linux ~x86-linux"
@@ -27,19 +29,18 @@ LICENSE="GPL-2"
SLOT="0"
IUSE="python"
-DEPEND="
+RDEPEND="
python? ( ${PYTHON_DEPS} )
dev-libs/libnl:3=
net-libs/libpcap"
-RDEPEND="${DEPEND}"
+DEPEND="${RDEPEND}"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-RESTRICT="test"
src_unpack() {
if [[ ${PV} == "9999" ]] ; then
git-r3_src_unpack
- cp -R "${S}/" "${WORKDIR}/all"
+ cp -R "${S}/" "${WORKDIR}/all" || die
fi
default_src_unpack
}
@@ -63,10 +64,9 @@ src_compile() {
}
src_install() {
- emake DESTDIR="${ED}" install
+ emake DESTDIR="${D}" install
if use python; then
cd pylorcon2 || die
distutils-r1_src_install
fi
- find "${ED}" -name '*.la' -delete || die
}