summaryrefslogtreecommitdiff
path: root/net-wireless/kismet/kismet-2022.08.1-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-07 12:30:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-07 12:30:41 +0100
commit3c7931f8c6c90aa813912d87c684d742e0c29a05 (patch)
treefe70317ba47324f028de7df8ce1d13394263950f /net-wireless/kismet/kismet-2022.08.1-r2.ebuild
parent7336b11bd5bd8f1cc6d445b150a6c466736c3d9d (diff)
gentoo auto-resync : 07:04:2024 - 12:30:41
Diffstat (limited to 'net-wireless/kismet/kismet-2022.08.1-r2.ebuild')
-rw-r--r--net-wireless/kismet/kismet-2022.08.1-r2.ebuild12
1 files changed, 10 insertions, 2 deletions
diff --git a/net-wireless/kismet/kismet-2022.08.1-r2.ebuild b/net-wireless/kismet/kismet-2022.08.1-r2.ebuild
index 0965409505a7..fe81d7a6be92 100644
--- a/net-wireless/kismet/kismet-2022.08.1-r2.ebuild
+++ b/net-wireless/kismet/kismet-2022.08.1-r2.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
PYTHON_COMPAT=( python3_{9..12} )
-inherit autotools python-single-r1 udev systemd
+inherit autotools flag-o-matic python-single-r1 udev systemd
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://www.kismetwireless.net/git/${PN}.git"
@@ -123,6 +123,14 @@ src_prepare() {
}
src_configure() {
+ # -Werror=strict-aliasing
+ # https://bugs.gentoo.org/877761
+ # https://github.com/kismetwireless/kismet/issues/518
+ #
+ # Do not trust with LTO either.
+ append-flags -fno-strict-aliasing
+ filter-lto
+
econf \
$(use_enable libusb libusb) \
$(use_enable pcre) \