summaryrefslogtreecommitdiff
path: root/net-wireless/horst/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-02-20 15:11:50 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-02-20 15:11:50 +0000
commit16449a80e28af2209916cc66d19c9a44ca2b90d9 (patch)
treeb4cfe2332c7a6c5da27b6985bf05db4508df1a92 /net-wireless/horst/files
parent79599515788b85b18aa655e7b7f8cc05c1bbddd8 (diff)
gentoo resync : 20.02.2019
Diffstat (limited to 'net-wireless/horst/files')
-rw-r--r--net-wireless/horst/files/horst-5.1-CC.patch14
-rw-r--r--net-wireless/horst/files/horst-5.1-pcap_bufsize.patch32
-rw-r--r--net-wireless/horst/files/horst-5.1-tinfo.patch11
-rw-r--r--net-wireless/horst/files/horst-9999-tinfo.patch11
4 files changed, 68 insertions, 0 deletions
diff --git a/net-wireless/horst/files/horst-5.1-CC.patch b/net-wireless/horst/files/horst-5.1-CC.patch
new file mode 100644
index 000000000000..f9c2e5120ac8
--- /dev/null
+++ b/net-wireless/horst/files/horst-5.1-CC.patch
@@ -0,0 +1,14 @@
+--- a/Makefile
++++ b/Makefile
+@@ -99,9 +99,9 @@
+ all: $(NAME)
+
+ .objdeps.mk: $(OBJS:%.o=%.c)
+- gcc -MM -I. $^ >$@
++ $(CC) -MM -I. $^ >$@
+ ifeq ($(OSX),1)
+- gcc -MM -I. ifctrl-osx.m >>$@
++ $(CC) -MM -I. ifctrl-osx.m >>$@
+ endif
+
+ -include .objdeps.mk
diff --git a/net-wireless/horst/files/horst-5.1-pcap_bufsize.patch b/net-wireless/horst/files/horst-5.1-pcap_bufsize.patch
new file mode 100644
index 000000000000..35f3f59dd98a
--- /dev/null
+++ b/net-wireless/horst/files/horst-5.1-pcap_bufsize.patch
@@ -0,0 +1,32 @@
+--- a/capture-pcap.c
++++ b/capture-pcap.c
+@@ -32,16 +32,16 @@
+ #define PCAP_TIMEOUT 200
+
+ static unsigned char* pcap_buffer;
+-static size_t pcap_bufsize;
++static size_t horst_pcap_bufsize;
+ static pcap_t *pcap_fp = NULL;
+
+ static void handler(u_char *user, const struct pcap_pkthdr *h, const u_char *bytes)
+ {
+ *((int *)user) = h->len;
+- if (pcap_bufsize < h->len) {
++ if (horst_pcap_bufsize < h->len) {
+ printlog("ERROR: Buffer(%d) too small for %d bytes",
+- (int)pcap_bufsize, h->len);
+- *((int *)user) = pcap_bufsize;
++ (int)horst_pcap_bufsize, h->len);
++ *((int *)user) = horst_pcap_bufsize;
+ }
+ memmove(pcap_buffer, bytes, *((int *)user));
+ }
+@@ -98,7 +98,7 @@
+ {
+ int ret = 0;
+ pcap_buffer = buffer;
+- pcap_bufsize = bufsize;
++ horst_pcap_bufsize = bufsize;
+ if (0 == pcap_dispatch(pcap_fp, 1, handler, (u_char *)&ret))
+ return -1;
+ return ret;
diff --git a/net-wireless/horst/files/horst-5.1-tinfo.patch b/net-wireless/horst/files/horst-5.1-tinfo.patch
new file mode 100644
index 000000000000..059158e58cfc
--- /dev/null
+++ b/net-wireless/horst/files/horst-5.1-tinfo.patch
@@ -0,0 +1,11 @@
+--- a/Makefile
++++ b/Makefile
+@@ -54,7 +54,7 @@
+ radiotap/radiotap.o \
+ util.o \
+ wlan_util.o
+-LIBS=-lncurses -lm
++LIBS=$(shell $(PKG_CONFIG) --libs ncurses ) -lm
+ CFLAGS+=-std=gnu99 -Wall -Wextra -g -I. -DVERSION=\"$(VERSION)\"
+
+ ifeq ($(OSX),1)
diff --git a/net-wireless/horst/files/horst-9999-tinfo.patch b/net-wireless/horst/files/horst-9999-tinfo.patch
new file mode 100644
index 000000000000..eb623d67b133
--- /dev/null
+++ b/net-wireless/horst/files/horst-9999-tinfo.patch
@@ -0,0 +1,11 @@
+--- a/Makefile
++++ b/Makefile
+@@ -41,7 +41,7 @@
+ SRC += network.c
+ SRC += protocol_parser.c
+
+-LIBS = -lncurses -lm -luwifi
++LIBS = $(shell $(PKG_CONFIG) --libs ncurses ) -lm -luwifi
+ LDFLAGS += -Wl,-rpath,/usr/local/lib
+
+ INCLUDES = -I.