summaryrefslogtreecommitdiff
path: root/net-wireless/gr-paint
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-01-12 16:58:08 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-01-12 16:58:08 +0000
commitc8a77dfe4d3d307c1d5dd2650b7297447d8b609d (patch)
tree9ea78393bc3ecd6ab4de449383d4e97e5f3648ae /net-wireless/gr-paint
parent2891d29af8907ce881662f4a02844926d7a293c7 (diff)
gentoo resync : 12.01.2019
Diffstat (limited to 'net-wireless/gr-paint')
-rw-r--r--net-wireless/gr-paint/Manifest2
-rw-r--r--net-wireless/gr-paint/gr-paint-9999.ebuild41
2 files changed, 24 insertions, 19 deletions
diff --git a/net-wireless/gr-paint/Manifest b/net-wireless/gr-paint/Manifest
index dc30ad6f009f..fb00a4479a40 100644
--- a/net-wireless/gr-paint/Manifest
+++ b/net-wireless/gr-paint/Manifest
@@ -1,2 +1,2 @@
-EBUILD gr-paint-9999.ebuild 878 BLAKE2B 188bd0bc3092595b0504c2e8a2490ef80904618a3ddf4cc81a304e0ce91f96ab8b863c78720dd679abf27c241ecd34f0458a52a181cad5be35975f48446fee4c SHA512 88cf4700637072c7a7d403b8546e7cc4bafa73f5669fe39216347a16093409aad80ca754d2c22403430f70b587c3d28d20745882da1166f41757a2466b1bb522
+EBUILD gr-paint-9999.ebuild 874 BLAKE2B 440d2408d8e996fb0c26dfd4416e1770ea0cb148e6b969e9b4aedbd988dec9e1347013c9f4a8f7f84ec1d231f957cd8d7b857ded4ca157dc9e87e2b64d048368 SHA512 810adbbcf95402e41f269864b66b067a4ffaf5be74d9f34cfd329ed2487ccddd6187ea88bb85761006cf52359ba170be69a7056adc19a9cc79ab0a78541d0311
MISC metadata.xml 426 BLAKE2B c0655dfe4af8bc17dc267dcadf37625b86e4830bc565044fe43b0911d166a19d6ab56dc73d2ad37890e5d0f83ca52fd078034fd6675310447361cebd2730b704 SHA512 10082af73f8e1acbf8a97062d4802b8ae6a3f187034933c7a14fe932aac3e654b3dde399ec33b3cf174c528ac77d41f2ab75969e39cb6e2f9c343ce52f7d0b64
diff --git a/net-wireless/gr-paint/gr-paint-9999.ebuild b/net-wireless/gr-paint/gr-paint-9999.ebuild
index 730dd1b13717..e61888f8ab75 100644
--- a/net-wireless/gr-paint/gr-paint-9999.ebuild
+++ b/net-wireless/gr-paint/gr-paint-9999.ebuild
@@ -1,39 +1,44 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
PYTHON_COMPAT=( python2_7 )
-inherit git-r3
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/drmpeg/gr-paint.git"
+else
+ KEYWORDS=""
+fi
inherit cmake-utils python-single-r1
-DESCRIPTION="paints monochrome images into the waterfall of a receiver"
+DESCRIPTION="Paints monochrome images into the waterfall of a receiver"
HOMEPAGE="https://github.com/drmpeg/gr-paint"
-SRC_URI=""
-EGIT_REPO_URI="https://github.com/drmpeg/gr-paint.git"
LICENSE="GPL-3+"
SLOT="0"
-KEYWORDS=""
IUSE="doc"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-COMMON_DEPEND="${PYTHON_DEPS}
- net-wireless/gnuradio:=[${PYTHON_USEDEP}]
- dev-libs/boost:=[${PYTHON_USEDEP}]"
-RDEPEND="${COMMON_DEPEND}
- media-gfx/imagemagick"
-DEPEND="${COMMON_DEPEND}
- virtual/pkgconfig
- dev-util/cppunit
+DEPEND="${PYTHON_DEPS}
+ dev-libs/boost:=[${PYTHON_USEDEP}]
+ net-wireless/gnuradio:=[${PYTHON_USEDEP}]
+"
+RDEPEND="${DEPEND}
+ media-gfx/imagemagick
+"
+BDEPEND="
dev-lang/swig
- doc? ( app-doc/doxygen )"
+ dev-util/cppunit
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
src_configure() {
- mycmakeargs=(
- $(cmake-utils_use_enable doc DOXYGEN)
+ local mycmakeargs=(
+ -DENABLE_DOXYGEN=$(usex doc)
-DPYTHON_EXECUTABLE="${PYTHON}"
)
cmake-utils_src_configure