summaryrefslogtreecommitdiff
path: root/net-wireless/gr-paint/gr-paint-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-wireless/gr-paint/gr-paint-9999.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-wireless/gr-paint/gr-paint-9999.ebuild')
-rw-r--r--net-wireless/gr-paint/gr-paint-9999.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/net-wireless/gr-paint/gr-paint-9999.ebuild b/net-wireless/gr-paint/gr-paint-9999.ebuild
new file mode 100644
index 000000000000..730dd1b13717
--- /dev/null
+++ b/net-wireless/gr-paint/gr-paint-9999.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit git-r3
+inherit cmake-utils python-single-r1
+
+DESCRIPTION="paints monochrome images into the waterfall of a receiver"
+HOMEPAGE="https://github.com/drmpeg/gr-paint"
+SRC_URI=""
+EGIT_REPO_URI="https://github.com/drmpeg/gr-paint.git"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS=""
+IUSE="doc"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+COMMON_DEPEND="${PYTHON_DEPS}
+ net-wireless/gnuradio:=[${PYTHON_USEDEP}]
+ dev-libs/boost:=[${PYTHON_USEDEP}]"
+RDEPEND="${COMMON_DEPEND}
+ media-gfx/imagemagick"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig
+ dev-util/cppunit
+ dev-lang/swig
+ doc? ( app-doc/doxygen )"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_enable doc DOXYGEN)
+ -DPYTHON_EXECUTABLE="${PYTHON}"
+ )
+ cmake-utils_src_configure
+}