summaryrefslogtreecommitdiff
path: root/net-wireless/gr-paint/gr-paint-0.0_p20220320.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-04 16:22:09 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-04 16:22:09 +0100
commit86eece26841510c190c0b254a24efc4d6b42acec (patch)
treea1931d648bb4ba1c6fc66c1675bf3c68de7351e4 /net-wireless/gr-paint/gr-paint-0.0_p20220320.ebuild
parent2f4adc38bc4dd33f9064b281ada16084185932ec (diff)
gentoo auto-resync : 04:09:2022 - 16:22:09
Diffstat (limited to 'net-wireless/gr-paint/gr-paint-0.0_p20220320.ebuild')
-rw-r--r--net-wireless/gr-paint/gr-paint-0.0_p20220320.ebuild62
1 files changed, 0 insertions, 62 deletions
diff --git a/net-wireless/gr-paint/gr-paint-0.0_p20220320.ebuild b/net-wireless/gr-paint/gr-paint-0.0_p20220320.ebuild
deleted file mode 100644
index 5f661be66d2c..000000000000
--- a/net-wireless/gr-paint/gr-paint-0.0_p20220320.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8,9,10} )
-
-if [[ ${PV} == 9999* ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/drmpeg/gr-paint.git"
-else
- COMMIT="6cf1568eb9e32c25bf6414ad45f75048a5a2b74c"
- SRC_URI="https://github.com/drmpeg/gr-paint/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
- S="${WORKDIR}/${PN}-${COMMIT}"
- KEYWORDS="~amd64"
-fi
-inherit cmake python-single-r1
-
-DESCRIPTION="Paints monochrome images into the waterfall of a receiver"
-HOMEPAGE="https://github.com/drmpeg/gr-paint"
-
-LICENSE="GPL-3+"
-SLOT="0"
-IUSE="doc"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-#< drmpeg> What tests?
-RESTRICT="test"
-
-DEPEND="${PYTHON_DEPS}
- $(python_gen_cond_dep '
- dev-libs/boost:=[${PYTHON_USEDEP}]
- ')
- dev-libs/gmp
- sci-libs/volk:=
- sci-libs/fftw
- >=net-wireless/gnuradio-3.9:=[${PYTHON_SINGLE_USEDEP}]
- $(python_gen_cond_dep 'dev-python/pygccxml[${PYTHON_USEDEP}]')
-"
-
-RDEPEND="${DEPEND}"
-
-BDEPEND="
- $(python_gen_cond_dep 'dev-python/pybind11[${PYTHON_USEDEP}]')
- virtual/pkgconfig
- doc? ( app-doc/doxygen )
-"
-
-src_configure() {
- local mycmakeargs=(
- -DENABLE_DOXYGEN=$(usex doc)
- -DPYTHON_EXECUTABLE="${PYTHON}"
- )
- cmake_src_configure
-}
-
-src_install() {
- cmake_src_install
- find "${D}" -name '*.py[oc]' -delete || die
- python_optimize
- mv "${ED}/usr/share/doc/gr-paint" "${ED}/usr/share/doc/${P}"
-}