summaryrefslogtreecommitdiff
path: root/net-wireless/gr-iqbal/gr-iqbal-0.38.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
commitd99093fb4bb5652015c06274d64083daa2439e4f (patch)
treecf61513204d97974179580065e85df5c8009087c /net-wireless/gr-iqbal/gr-iqbal-0.38.2.ebuild
parent463397cf1e064185110fe57c568d73f99a06f5d1 (diff)
gentoo resync : 03.03.2021
Diffstat (limited to 'net-wireless/gr-iqbal/gr-iqbal-0.38.2.ebuild')
-rw-r--r--net-wireless/gr-iqbal/gr-iqbal-0.38.2.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/net-wireless/gr-iqbal/gr-iqbal-0.38.2.ebuild b/net-wireless/gr-iqbal/gr-iqbal-0.38.2.ebuild
new file mode 100644
index 000000000000..3ace7a599591
--- /dev/null
+++ b/net-wireless/gr-iqbal/gr-iqbal-0.38.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7,8,9})
+
+inherit cmake python-single-r1
+
+DESCRIPTION="gnuradio I/Q balancing"
+HOMEPAGE="http://git.osmocom.org/gr-iqbal/"
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/osmocom/gr-iqbal.git"
+else
+ SRC_URI="https://github.com/osmocom/gr-iqbal/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0/${PV}"
+IUSE="doc"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RDEPEND="=net-wireless/gnuradio-3.8*:0=[${PYTHON_SINGLE_USEDEP}]
+ net-libs/libosmo-dsp:=
+ dev-libs/boost:=
+ ${PYTHON_DEPS}"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_DOXYGEN="$(usex doc)"
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+ python_optimize
+}