summaryrefslogtreecommitdiff
path: root/net-wireless/gqrx/gqrx-2.16.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-20 21:42:17 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-20 21:42:17 +0100
commit90a3be9d71a22834f9bc82c072f1b993f9a10e31 (patch)
tree7f86c1f37e857df29494ec91436ca76bed49441a /net-wireless/gqrx/gqrx-2.16.ebuild
parenta597364520b9291d0b2a23bb007ced022e821d95 (diff)
gentoo auto-resync : 20:08:2023 - 21:42:17
Diffstat (limited to 'net-wireless/gqrx/gqrx-2.16.ebuild')
-rw-r--r--net-wireless/gqrx/gqrx-2.16.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/net-wireless/gqrx/gqrx-2.16.ebuild b/net-wireless/gqrx/gqrx-2.16.ebuild
new file mode 100644
index 000000000000..2cf2b96d63cd
--- /dev/null
+++ b/net-wireless/gqrx/gqrx-2.16.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Software defined radio receiver powered by GNU Radio and Qt"
+HOMEPAGE="https://gqrx.dk/"
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/gqrx-sdr/gqrx.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/gqrx-sdr/gqrx/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~riscv ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="gr-audio portaudio pulseaudio"
+REQUIRED_USE="^^ ( pulseaudio portaudio gr-audio )"
+
+RDEPEND="
+ >=net-wireless/gnuradio-3.10:0=[audio,analog,filter,network]
+ >=net-wireless/gr-osmosdr-0.1.0:=
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ sci-libs/volk:=
+ pulseaudio? ( media-libs/libpulse )
+ portaudio? ( media-libs/portaudio:= )"
+DEPEND="${RDEPEND}
+ dev-libs/boost:=
+ dev-libs/log4cpp:=
+"
+BDEPEND=""
+
+src_configure() {
+ if use pulseaudio; then
+ LINUX_AUDIO_BACKEND=Pulseaudio
+ elif use portaudio; then
+ LINUX_AUDIO_BACKEND=Portaudio
+ elif use gr-audio; then
+ LINUX_AUDIO_BACKEND=Gr-audio
+ fi
+
+ local mycmakeargs=(
+ "-DLINUX_AUDIO_BACKEND=${LINUX_AUDIO_BACKEND}"
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ dobin "${BUILD_DIR}"/src/gqrx
+}