summaryrefslogtreecommitdiff
path: root/net-wireless/gnuradio/gnuradio-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /net-wireless/gnuradio/gnuradio-9999.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'net-wireless/gnuradio/gnuradio-9999.ebuild')
-rw-r--r--net-wireless/gnuradio/gnuradio-9999.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/net-wireless/gnuradio/gnuradio-9999.ebuild b/net-wireless/gnuradio/gnuradio-9999.ebuild
index aa068b0e06b5..65be5a358525 100644
--- a/net-wireless/gnuradio/gnuradio-9999.ebuild
+++ b/net-wireless/gnuradio/gnuradio-9999.ebuild
@@ -5,7 +5,7 @@ EAPI=7
PYTHON_COMPAT=( python3_{6,7,8} )
CMAKE_BUILD_TYPE="None"
-inherit cmake python-single-r1 virtualx xdg-utils
+inherit cmake python-single-r1 virtualx xdg-utils desktop
DESCRIPTION="Toolkit that provides signal processing blocks to implement software radios"
HOMEPAGE="https://www.gnuradio.org/"
@@ -14,7 +14,7 @@ SLOT="0/${PV}"
if [[ ${PV} =~ "9999" ]]; then
EGIT_REPO_URI="https://github.com/gnuradio/gnuradio.git"
- EGIT_BRANCH="pybind"
+ EGIT_BRANCH="maint-3.8"
inherit git-r3
KEYWORDS=""
else
@@ -47,7 +47,6 @@ REQUIRED_USE="${PYTHON_REQUIRED_USE}
"
RDEPEND="${PYTHON_DEPS}
- $(python_gen_cond_dep 'dev-python/pybind11[${PYTHON_USEDEP}]')
$(python_gen_cond_dep 'dev-libs/boost:0=[python,${PYTHON_USEDEP}]')
dev-libs/log4cpp
$(python_gen_cond_dep 'dev-python/six[${PYTHON_USEDEP}]')
@@ -68,7 +67,7 @@ RDEPEND="${PYTHON_DEPS}
x11-libs/gtk+:3[introspection]
x11-libs/pango[introspection]
)
- jack? ( media-sound/jack-audio-connection-kit )
+ jack? ( virtual/jack )
portaudio? ( >=media-libs/portaudio-19_pre )
qt5? (
$(python_gen_cond_dep 'dev-python/PyQt5[opengl,${PYTHON_USEDEP}]')
@@ -130,6 +129,7 @@ src_configure() {
mycmakeargs=(
-DENABLE_DEFAULT=OFF
-DENABLE_VOLK=OFF
+ -DENABLE_INTERNAL_VOLK=OFF
-DENABLE_GNURADIO_RUNTIME=ON
-DENABLE_PYTHON=ON
-DENABLE_GR_BLOCKS=ON