summaryrefslogtreecommitdiff
path: root/net-wireless/blueman/blueman-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-02 09:17:58 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-02 09:17:58 +0100
commite594c992ffc7a67aab370bfe0634d498dbd82b8a (patch)
tree4f2368520ca4f275439a3da159a7d6f0a2deead9 /net-wireless/blueman/blueman-9999.ebuild
parent8f4c38a7c36dcb0533df606e6906314a00b70933 (diff)
gentoo auto-resync : 02:08:2022 - 09:17:58
Diffstat (limited to 'net-wireless/blueman/blueman-9999.ebuild')
-rw-r--r--net-wireless/blueman/blueman-9999.ebuild11
1 files changed, 8 insertions, 3 deletions
diff --git a/net-wireless/blueman/blueman-9999.ebuild b/net-wireless/blueman/blueman-9999.ebuild
index 453fb6b604da..c34ce0ed1161 100644
--- a/net-wireless/blueman/blueman-9999.ebuild
+++ b/net-wireless/blueman/blueman-9999.ebuild
@@ -7,13 +7,13 @@ DISTUTILS_SINGLE_IMPL=1
DISTUTILS_USE_PEP517=no
PYTHON_COMPAT=( python3_{8..11} )
-inherit distutils-r1 gnome2-utils linux-info systemd xdg-utils
+inherit autotools distutils-r1 gnome2-utils linux-info systemd xdg-utils
DESCRIPTION="Simple and intuitive GTK+ Bluetooth Manager"
HOMEPAGE="https://github.com/blueman-project/blueman/"
if [[ ${PV} == "9999" ]] ; then
- inherit autotools git-r3
+ inherit git-r3
EGIT_REPO_URI="https://github.com/blueman-project/blueman.git"
else
SRC_URI="
@@ -97,7 +97,12 @@ pkg_setup() {
}
src_prepare() {
- [[ ${PV} == 9999 ]] && eautoreconf
+ if [[ ${PV} == 9999 ]]; then
+ eautoreconf
+ else
+ # remove this when upstream switches to automake with .pyc fix
+ eautomake
+ fi
distutils-r1_src_prepare
}