summaryrefslogtreecommitdiff
path: root/net-wireless/blueman/blueman-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-17 20:32:17 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-17 20:32:17 +0100
commit83b5cde41ddb8fd20de4536dd68eb08da42d013e (patch)
tree6a993cfe0eb5a8024c508e9f6a6de02538f7c52e /net-wireless/blueman/blueman-9999.ebuild
parent9c26151d84a72781f240cc7ca3e2f0ab4ba60f74 (diff)
gentoo auto-resync : 17:07:2022 - 20:32:17
Diffstat (limited to 'net-wireless/blueman/blueman-9999.ebuild')
-rw-r--r--net-wireless/blueman/blueman-9999.ebuild25
1 files changed, 12 insertions, 13 deletions
diff --git a/net-wireless/blueman/blueman-9999.ebuild b/net-wireless/blueman/blueman-9999.ebuild
index 14d5a18e335a..dbedcfc7eae6 100644
--- a/net-wireless/blueman/blueman-9999.ebuild
+++ b/net-wireless/blueman/blueman-9999.ebuild
@@ -3,9 +3,11 @@
EAPI=8
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=no
PYTHON_COMPAT=( python3_{8..11} )
-inherit autotools gnome2-utils linux-info python-single-r1 systemd xdg-utils
+inherit autotools distutils-r1 gnome2-utils linux-info systemd xdg-utils
DESCRIPTION="Simple and intuitive GTK+ Bluetooth Manager"
HOMEPAGE="https://github.com/blueman-project/blueman/"
@@ -25,22 +27,23 @@ fi
# source files are mixed GPL-3+ and GPL-2+
LICENSE="GPL-3+ GPL-2"
SLOT="0"
-IUSE="appindicator network nls policykit pulseaudio"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+IUSE="network nls policykit pulseaudio"
DEPEND="
$(python_gen_cond_dep '
dev-python/pygobject:3[${PYTHON_USEDEP}]
')
>=net-wireless/bluez-5:=
- ${PYTHON_DEPS}"
+"
BDEPEND="
$(python_gen_cond_dep '
dev-python/cython[${PYTHON_USEDEP}]
')
virtual/pkgconfig
- nls? ( sys-devel/gettext )"
-RDEPEND="${DEPEND}
+ nls? ( sys-devel/gettext )
+"
+RDEPEND="
+ ${DEPEND}
$(python_gen_cond_dep '
dev-python/pycairo[${PYTHON_USEDEP}]
')
@@ -52,9 +55,6 @@ RDEPEND="${DEPEND}
x11-themes/faenza-icon-theme
x11-themes/mate-icon-theme
)
- appindicator? (
- dev-libs/libappindicator:3[introspection]
- )
network? (
net-firewall/iptables
|| (
@@ -97,18 +97,17 @@ pkg_setup() {
}
src_prepare() {
- default
[[ ${PV} == 9999 ]] && eautoreconf
+ distutils-r1_src_prepare
}
-src_configure() {
+python_configure() {
local myconf=(
--disable-runtime-deps-check
--disable-static
--with-systemdsystemunitdir="$(systemd_get_systemunitdir)"
--with-systemduserunitdir="$(systemd_get_userunitdir)"
--with-dhcp-config="/etc/dhcp/dhcpd.conf"
- $(use_enable appindicator)
$(use_enable policykit polkit)
$(use_enable nls)
$(use_enable pulseaudio)
@@ -119,7 +118,7 @@ src_configure() {
econf "${myconf[@]}"
}
-src_install() {
+python_install() {
default
if use policykit; then