summaryrefslogtreecommitdiff
path: root/net-wireless/blueman/blueman-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /net-wireless/blueman/blueman-9999.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'net-wireless/blueman/blueman-9999.ebuild')
-rw-r--r--net-wireless/blueman/blueman-9999.ebuild35
1 files changed, 22 insertions, 13 deletions
diff --git a/net-wireless/blueman/blueman-9999.ebuild b/net-wireless/blueman/blueman-9999.ebuild
index 090a7032ac19..14d5a18e335a 100644
--- a/net-wireless/blueman/blueman-9999.ebuild
+++ b/net-wireless/blueman/blueman-9999.ebuild
@@ -1,21 +1,24 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="7"
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
-PYTHON_COMPAT=( python3_{8..10} )
inherit autotools gnome2-utils linux-info python-single-r1 systemd xdg-utils
DESCRIPTION="Simple and intuitive GTK+ Bluetooth Manager"
-HOMEPAGE="https://github.com/blueman-project/blueman"
+HOMEPAGE="https://github.com/blueman-project/blueman/"
if [[ ${PV} == "9999" ]] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/blueman-project/blueman.git"
else
- SRC_URI="https://github.com/blueman-project/${PN}/releases/download/${PV/_/.}/${P/_/.}.tar.xz"
+ SRC_URI="
+ https://github.com/blueman-project/blueman/releases/download/${PV/_/.}/${P/_/.}.tar.xz
+ "
S=${WORKDIR}/${P/_/.}
- KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
fi
# icons are GPL-2
@@ -23,6 +26,7 @@ fi
LICENSE="GPL-3+ GPL-2"
SLOT="0"
IUSE="appindicator network nls policykit pulseaudio"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
DEPEND="
$(python_gen_cond_dep '
@@ -48,7 +52,9 @@ RDEPEND="${DEPEND}
x11-themes/faenza-icon-theme
x11-themes/mate-icon-theme
)
- appindicator? ( dev-libs/libappindicator:3[introspection] )
+ appindicator? (
+ dev-libs/libappindicator:3[introspection]
+ )
network? (
net-firewall/iptables
|| (
@@ -61,7 +67,9 @@ RDEPEND="${DEPEND}
>=net-misc/networkmanager-0.8
)
)
- policykit? ( sys-auth/polkit )
+ policykit? (
+ sys-auth/polkit
+ )
pulseaudio? (
|| (
media-sound/pulseaudio-daemon[bluetooth]
@@ -72,12 +80,14 @@ RDEPEND="${DEPEND}
)
"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
pkg_pretend() {
if use network; then
- local CONFIG_CHECK="~BRIDGE ~IP_NF_IPTABLES
- ~IP_NF_NAT ~IP_NF_TARGET_MASQUERADE"
+ local CONFIG_CHECK="
+ ~BRIDGE
+ ~IP_NF_IPTABLES
+ ~IP_NF_NAT
+ ~IP_NF_TARGET_MASQUERADE
+ "
check_extra_config
fi
}
@@ -88,8 +98,7 @@ pkg_setup() {
src_prepare() {
default
- # replace py-compile to fix py3
- [[ ${PV} == 9999 ]] && eautoreconf || eautomake
+ [[ ${PV} == 9999 ]] && eautoreconf
}
src_configure() {