summaryrefslogtreecommitdiff
path: root/net-vpn/openvpn/openvpn-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
commit623ee73d661e5ed8475cb264511f683407d87365 (patch)
tree993eb27c93ec7a2d2d19550300d888fc1fed9e69 /net-vpn/openvpn/openvpn-9999.ebuild
parentceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (diff)
gentoo Easter resync : 12.04.2020
Diffstat (limited to 'net-vpn/openvpn/openvpn-9999.ebuild')
-rw-r--r--net-vpn/openvpn/openvpn-9999.ebuild46
1 files changed, 22 insertions, 24 deletions
diff --git a/net-vpn/openvpn/openvpn-9999.ebuild b/net-vpn/openvpn/openvpn-9999.ebuild
index bd0472901623..8ea466d6754f 100644
--- a/net-vpn/openvpn/openvpn-9999.ebuild
+++ b/net-vpn/openvpn/openvpn-9999.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit autotools flag-o-matic user systemd linux-info git-r3
+inherit autotools flag-o-matic systemd linux-info git-r3
DESCRIPTION="Robust and highly flexible tunneling application compatible with many OSes"
EGIT_REPO_URI="https://github.com/OpenVPN/${PN}.git"
@@ -15,18 +15,18 @@ SLOT="0"
KEYWORDS=""
IUSE="down-root examples inotify iproute2 libressl lz4 +lzo mbedtls pam"
-IUSE+=" pkcs11 +plugins selinux +ssl static systemd test userland_BSD"
+IUSE+=" pkcs11 +plugins selinux +ssl systemd test userland_BSD"
RESTRICT="!test? ( test )"
-REQUIRED_USE="static? ( !inotify !plugins !pkcs11 )
- lzo? ( !lz4 )
+REQUIRED_USE="pkcs11? ( ssl )
!plugins? ( !pam !down-root )
- inotify? ( plugins )"
+ inotify? ( plugins )
+"
CDEPEND="
kernel_linux? (
iproute2? ( sys-apps/iproute2[-minimal] )
- !iproute2? ( sys-apps/net-tools )
+ !iproute2? ( >=sys-apps/net-tools-1.60_p20160215155418 )
)
pam? ( sys-libs/pam )
ssl? (
@@ -39,18 +39,19 @@ CDEPEND="
lz4? ( app-arch/lz4 )
lzo? ( >=dev-libs/lzo-1.07 )
pkcs11? ( >=dev-libs/pkcs11-helper-1.11 )
- systemd? ( sys-apps/systemd )"
+ systemd? ( sys-apps/systemd )
+"
DEPEND="${CDEPEND}
- test? ( dev-util/cmocka )"
+ test? ( dev-util/cmocka )
+"
RDEPEND="${CDEPEND}
- selinux? ( sec-policy/selinux-openvpn )"
+ acct-group/openvpn
+ acct-user/openvpn
+ selinux? ( sec-policy/selinux-openvpn )
+"
CONFIG_CHECK="~TUN"
-PATCHES=(
- "${FILESDIR}/${PN}-2.5-external-cmocka.patch"
-)
-
pkg_setup() {
linux-info_pkg_setup
}
@@ -61,7 +62,6 @@ src_prepare() {
}
src_configure() {
- use static && append-ldflags -Xcompiler -static
SYSTEMD_UNIT_DIR=$(systemd_get_systemunitdir) \
TMPFILES_DIR="/usr/lib/tmpfiles.d" \
econf \
@@ -76,7 +76,6 @@ src_configure() {
$(use_enable iproute2) \
$(use_enable pam plugin-auth-pam) \
$(use_enable down-root plugin-down-root) \
- $(use_enable test tests) \
$(use_enable systemd)
}
@@ -106,17 +105,16 @@ src_install() {
# install examples, controlled by the respective useflag
if use examples ; then
# dodoc does not supportly support directory traversal, #15193
- insinto /usr/share/doc/${PF}/examples
- doins -r sample contrib
+ docinto /usr/share/doc/${PF}/examples
+ dodoc -r sample contrib
fi
}
pkg_postinst() {
- # Add openvpn user so openvpn servers can drop privs
- # Clients should run as root so they can change ip addresses,
- # dns information and other such things.
- enewgroup openvpn
- enewuser openvpn "" "" "" openvpn
+ if use x64-macos; then
+ elog "You might want to install tuntaposx for TAP interface support:"
+ elog "http://tuntaposx.sourceforge.net"
+ fi
elog "The openvpn init script expects to find the configuration file"
elog "openvpn.conf in /etc/openvpn along with any extra files it may need."
@@ -142,7 +140,7 @@ pkg_postinst() {
if use plugins ; then
einfo ""
- einfo "plugins have been installed into /usr/$(get_libdir)/${PN}"
+ einfo "plugins have been installed into /usr/$(get_libdir)/${PN}/plugins"
fi
ewarn ""